Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 216946 - handbook: increase size of the example /boot partiton to house install-x86-minimal-2007.0-r1.iso
Summary: handbook: increase size of the example /boot partiton to house install-x86-mi...
Status: VERIFIED WONTFIX
Alias: None
Product: [OLD] Docs on www.gentoo.org
Classification: Unclassified
Component: Installation Handbook (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Docs Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-08 19:49 UTC by Martin Mokrejš
Modified: 2008-04-13 11:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2008-04-08 19:49:05 UTC
Hi,
  I think the size of the /boot partition should be larger than the 32MB suggested in the Handbook to for example house also the memtest86 and install-x86-minimal-2007.0-r1.iso (59MB). It's a smart way to have always handy a recovery media.

Further, the section "4.d. Creating Filesystems" could attract users more to use ext3 in general. Having ext2 on /boot and ext3 on the / just makes them install one more driver into the kernel. Having ext3 on both is I believe better idea. Anyway, they could mount it as ext2 (i.e. disable the journaling option). Most importantly, it should advice users to stick to ext3 because several opensource ext2/3 drivers for MS Windows exist, most notably Ext2IFS (http://www.fs-driver.org/) and I believe most of the people have dual-boot machines. Anyway, those who mostly seek for such an advice here are novice users. Personally, I have reverted from xfs to ext3 because the filesystem aging is very notable on Gentoo after regular 'emerge --sync' and recomplations of most of the packages. It is not that bad with reiserfs3, but as I say, ext3 is fast and has best support, is well tested, and there are the MS Windows drivers.
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-04-09 15:54:18 UTC
Hi, I saw this bug in the irc channel and wanted to comment. Your suggestions are good but you can't possibly expect the doc team at gentoo to add everyone's preferences. It would be like me saying, more people use vim so the handbook should change all references of nano to vim. (I made that up). The suggested size of /boot is just that...a suggestion. Furthermore, you comment about being more newbie friendly by making /boot ext3 instead of ext2 and users can just mount it as ext2 but..I ask you, do you think any newbie's really know how to mount it like that? just another line to add to the handbook, which IMHO shouldn't be there. 

Just seems like alot more work for the doc team to maintain. I'm not trying to start an argument ;) This is a handbook for Gentoo Linux, not Dual-booting with Gentoo and Windows...
Comment 2 nm (RETIRED) gentoo-dev 2008-04-09 18:41:52 UTC
Interesting ideas, but not something we should recommend to all users. Just because /boot is bloated with ISOs and additional programs does *not* guarantee that they are available if there's something wrong with your system, such as disk trouble.

Also, we made a point of trying to balance our filesystem descriptions so that all filesystems were presented more or less equally. We don't need to single out ext3 and promote it as the be-all-end-all FS that's compatible with every other OS. What you believe about "most people" dual-booting with Windows is irrelevant, and is just a guess.

Also, there's no point in using ext3 on /boot because it *does not* mean adding "one more driver", as it's identical to ext2 -- ext3 adds a journal. That journal takes up a  lot of space, up to 1/3 of a given /boot partition. There's no point in journaling a ~40MB or so partition; it just slows it down.
Comment 3 Martin Mokrejš 2008-04-09 19:36:25 UTC
It is a suggestion, anyway I still do believe 32MB for /boot is simply a bad
example. Why do not you just mention a possibility to house an iso image in the
/boot partition? Mostly, a mis-edited config file or filesystem needing fsck
are the causes, but running fsck from a well known, tested kernel from a
distribution media feels better than fsck patched by Gentoo with devel patches
run under devel linux kernel (Theo said once he does not necessarily feel
comfortable with his e2fsprogs devel patches applied to Gentoo so early). Let
people decide what they want, bu please mention what they might care about.
And, that an average compressed kernel takes about 2MB and System.map about
1MB.

BTW, mention that a swap partition is _required_ to be present and mounted by
linux kernel otherwise memory management does not work well. I could dig out my
correspondence with kernel developers on this (off-bugzilla), hopefully.

Having everywhere ext3 just keeps the kernel smaller, no need for ext2
"module".
At least mention that more important is whether people want to access the data
from other OSes or whether they just pick up some, said to be great filesystem.
Please put a link to the Ext2IFS driver in ext2/3 sections and I am fine with
that. ;-)

Other than that, yes, it is always hard to keep a document short and useful.
Comment 4 SpanKY gentoo-dev 2008-04-10 05:49:32 UTC
ext2 and ext3 have the same on-disk filesystem structure.  so the argument about tested drivers in other operating systems makes no sense.  any 3rd party package that supports ext3 will support ext2.

as for linking/mentioning applications that work under Windows, there are many applications that run in Windows that make working with Linux nice.  so until we get a Gentoo/Windows port, best to just leave it out.
Comment 5 Martin Mokrejš 2008-04-11 10:40:43 UTC
SpanKY, I think you mis-understood me. Is there a free driver to read&write data from/to XFS, reiserfs, jfs from MS Win? My point is that of much higher importance is the functionality and not cryptic speed of a filesystem. Who cares that _maybe_ xfs/reiserfs/jfs/whatever is faster than one or another when people _too late_ realize that they could have been able to mount their disk from MS Win _now_ if somebody in the past told them they loose the possibility by taking wrong choice. This is about data recovery as well, don't take it that it 'just' affects dual-booting people.
Comment 6 SpanKY gentoo-dev 2008-04-13 05:12:34 UTC
you're talking about /boot here.  nowhere do we recommend using anything but ext2 for /boot.

as for recovery of a filesystem, every type has tools to assist in recovery.  but in the end, we present aspects about the different filesystems and leave it up to the user to make the choice.