Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 216584 - qt4 problem with openssl-0.9.8g
Summary: qt4 problem with openssl-0.9.8g
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Qt Bug Alias
: 219362 (view as bug list)
Depends on:
Reported: 2008-04-06 17:17 UTC by Radu Benea
Modified: 2009-03-27 21:46 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Radu Benea 2008-04-06 17:17:01 UTC
example (from konqueror - kde4):
An error occurred while loading
Could not connect to host SSL negotiation failed.

After a bit of research I found some helping information about this - for more information read:

According to the information I read there and on other sites this bug is qt4 related (not KDE's fault)

It works with openssl-0.9.8f
the patch (posted there) doesn't work for gentoo as of now... probabily SHLIB_VERSION_NUMBER is not resolved

If you need more info I'm willing to help with testing

Reproducible: Always
Comment 1 Josepmaria Roca 2008-04-28 16:03:09 UTC
Hi, I can reproduce this.
Konqueror of KDE4 can't connect to any HTTPS sites, Kopete (KDE4 too) can't connect any protocol that uses SSL / TLS like MSN Messenger or Jabber/Gtalk.

I'm open to do some tests but I need some help.
Here is a patch for this bug:

How to apply to a custom ebuild on my local overlay?
Is SHLIB_VERSION_NUMBER defined somewhere for properly usage in Gentoo?

I'll follow this track to provide help if I can.
Comment 2 Radu Benea 2008-05-02 11:43:26 UTC
No, I already tried applying that patch... aparently it doesn't work on gentoo...

and with modifying local ebuilds... copy file to files in the corresponding directory from /usr/portage/... add your file to PATCHES="..." field.. check other ebuild to see how this is done... when you finish, type ebuild $ebuild_name digest, after this you can emerge it
Comment 3 Josepmaria Roca 2008-05-03 20:49:22 UTC
I copied the original qt.ebuild into my local overlay and added a line "epatch" with this patch and copied the patch into the files directory. I'm not sure if this is the right method, but I really sure that the patch has been applied as I expected.

After emerge this custom ebuild that applies the patch, the bug persists so yes, it seems that doesn't works on gentoo.
Qt builds but no changes on the behavior.

I reviewed too the Qt 4.4 sources for the solution and it seems quite more complex that the patch provides.

It seems that the bug (if really exists :P) has been solved in Qt 4.4, so... we can patiently wait.
Comment 4 Ingmar Vanhassel (RETIRED) gentoo-dev 2008-05-15 13:35:15 UTC
*** Bug 219362 has been marked as a duplicate of this bug. ***
Comment 5 Ben de Groot (RETIRED) gentoo-dev 2009-03-27 21:46:43 UTC
If the problem reappears in current Qt versions, feel free to reopen.