Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 216155 - net-misc/nxserver-freenx: init.d enhancement
Summary: net-misc/nxserver-freenx: init.d enhancement
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: NX Server Herd
URL:
Whiteboard:
Keywords:
: 216837 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-04 09:07 UTC by Bruno Redondi
Modified: 2008-04-09 21:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fix for the nxserver init script (nxserver.init.patch,424 bytes, patch)
2008-04-04 09:08 UTC, Bruno Redondi
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bruno Redondi 2008-04-04 09:07:34 UTC
If the system reboots without proper shutdown (i.e. due to a power failure, or a watchdog hang) the command "nxserver --start" fails (NX> 500 ERROR: Service already running), so nxserver init script does not start, so nxserver init script is not executed at system shutdown, so "nxserver --stop" is not executed at system shutdown.
The init script will never start again until someone gives the "nxserver --stop" command manually.
init script should return 0 also if "nxserver --start" command fails.


Reproducible: Always
Comment 1 Bruno Redondi 2008-04-04 09:08:25 UTC
Created attachment 148572 [details, diff]
fix for the nxserver init script
Comment 2 Bernard Cafarelli gentoo-dev 2008-04-07 14:45:23 UTC
OK in CVS, I've added session cleaning in the stop part (sample init script from upstream also does it).

As for the return code in start, nxserver-freeedition returns 0 when the service is already started (which is correct, as the service is started indeed). I'll check with freenx upstream if this can be fixed directly in the server
Comment 3 Jan Kundrát (RETIRED) gentoo-dev 2008-04-09 17:14:59 UTC
*** Bug 216837 has been marked as a duplicate of this bug. ***
Comment 4 Bernard Cafarelli gentoo-dev 2008-04-09 21:14:03 UTC
OK, patch is being reviewed upstream, adding to net-misc/nxserver-freenx-0.7.2-r2 in portage in the meantime

Thanks for the reports and suggestions all