Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 216105 - spamassin bayes use flag or info message.
Summary: spamassin bayes use flag or info message.
Status: RESOLVED DUPLICATE of bug 173759
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-03 22:42 UTC by Caleb Cushing
Modified: 2009-11-26 17:53 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Caleb Cushing 2008-04-03 22:42:37 UTC
to use bayes with spamassassin you require

perl-core/DB_File

could this be pulled by spamassassin with a bayes use flag? or at least added to this info message

 * have reported that this makes no difference. ;)
 * For spf support, please emerge dev-perl/Mail-SPF-Query
 * For dcc support, please emerge mail-filter/dcc
 * For pyzor support, please emerge dev-python/pyzor
 * For razor support, please emerge mail-filter/razor
 * For addtional functionality, you may wish to emerge:
 * dev-perl/IP-Country       dev-perl/Net-Ident
 * dev-perl/Mail-DKIM


Reproducible: Always
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2008-04-03 22:49:46 UTC
Actually it is via the berkdb use flag. But I do not see what bayes has to do with perl-core/DB_File. I have spamassassin installed without it and bayes filtering  works just fine.
Comment 2 Carsten Lohrke (RETIRED) gentoo-dev 2008-04-03 22:51:58 UTC
Err, the last sentence was a blatant lie as I just noticed...
Comment 3 Caleb Cushing 2008-04-04 02:36:27 UTC
what does bayes have to do with berkdb? I believe I have it working now and I don't have the berkdb flag on.
Comment 4 Graham Murray 2008-04-04 05:29:06 UTC
It is possible to run bayes, awl and user configuration using MySQL or Postgresql databases (I am using Postgresql). Therefore db_FILE is not needed for bayes, but it is the default database used if you do not configure SpamAssassin to use one of the SQL databases.
Comment 5 David Abbott gentoo-dev 2009-11-26 17:53:54 UTC

*** This bug has been marked as a duplicate of bug 173759 ***