Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 215714 - regression in kernels >=2.6.24 ipw2200s rtap iface not working
Summary: regression in kernels >=2.6.24 ipw2200s rtap iface not working
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL:
Whiteboard: insvn
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-01 15:28 UTC by whitehawk
Modified: 2008-07-24 14:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description whitehawk 2008-04-01 15:28:13 UTC
The rtap0 interface can't  be brought up with ifconfig rtap0 up. I have tested it in gentoo-sources 2.6.23 and 2.6.22 and it worked. I tested gentoo-sources 2.6.24-rX and didn't have any success. I also tested vanilla-sources 2.6.25-rcX and it does not work.

~ # ifconfig rtap0 up
SIOCSIFFLAGS: Invalid argument
~ # 

the rtap0 interface exist, it is listed with ifconfig -a
Comment 1 Daniel Drake (RETIRED) gentoo-dev 2008-04-01 20:22:37 UTC
you dont need to bring it up
Comment 2 whitehawk 2008-04-02 06:01:23 UTC
Can you show me a link that states this? It is not working without being brought up. I tried wireshark. From kernel menuconfig:

CONFIG_IPW2200_PROMISCUOUS:                                                                                                            

Enables the creation of a second interface prefixed 'rtap'.                                                                              
This second interface will provide every received in radiotap                                                                          
format.                                                                                                                                 

This is useful for performing wireless network analysis while                                                                          
maintaining an active association.                                                                                                     

Example usage:                                                                                                                          
% modprobe ipw2200 rtap_iface=1                                                                                                        
% ifconfig rtap0 up                                                                                                                    
% tethereal -i rtap0
Comment 3 whitehawk 2008-04-02 18:29:06 UTC
I verified the behavior with other people. To use the rtap0 you must activate it. Only then can you capture packets with for example wireshark or airodump-ng.
Comment 4 whitehawk 2008-04-02 18:53:03 UTC
reopening it
Comment 5 Daniel Drake (RETIRED) gentoo-dev 2008-04-02 19:34:55 UTC
Sorry for incorrect diagnosis, I think I got confused with something else.

As debugged on IRC, this is another case of an all-zero mac address. Sent a patch upstream.
Comment 6 Daniel Drake (RETIRED) gentoo-dev 2008-04-19 21:19:30 UTC
Fixed in gentoo-sources-2.6.24-r6 / genpatches-2.6.24-7
Comment 7 Hendrik Lemelson 2008-07-24 14:04:02 UTC
I am having the same issue again with 2.6.24-r8.
rtap0 is there with "iwconfig" but cannot be brought up with "ifconfig rtap0 up".
Didn't the patch make it into 2.6.24-r8?