Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 215683 - media-plugins/vdr-console-0.6.0 does not compile with vdr 1.6.0
Summary: media-plugins/vdr-console-0.6.0 does not compile with vdr 1.6.0
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo VDR Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-01 09:49 UTC by Ed O'Donnell
Modified: 2008-07-06 17:17 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Emerge output (emerge-output.txt,7.32 KB, text/plain)
2008-04-01 09:50 UTC, Ed O'Donnell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ed O'Donnell 2008-04-01 09:49:07 UTC
Vdr has been upgraded to new stable version 1.6 and vdr-console plugin will not compile

Reproducible: Always

Steps to Reproduce:
1. emerge vdr-console

Actual Results:  
g++ -O2 -march=i686 -pipe -fPIC -c -DCONFDIR=\"/etc/vdr\" -DUSE_CHANNELSCAN -DUSE_SETUP -DUSE_PINPLUGIN -DUSE_PLUGINMISSING -DUSE_TTXTSUBS -DUSE_YAEPG -DPLUGIN_NAME_I18N='"console"' -D_GNU_SOURCE -I/usr/include -I/usr/include/ config.c
fontsmallfix.c:2: error: âtPixelDataâ in class âcFontâ does not name a type
menu.c: In function âvoid WriteChar(cBitmap&, const cFont&, int, int, unsigned char, tColor, tColor)â:
menu.c:62: error: expected initializer before â*â token
menu.c:65: error: âCharDataâ was not declared in this scope
menu.c:71: error: âtPixelDataâ is not a member of âcFontâ
menu.c:71: error: expected `;' before âPixelDataâ
menu.c:73: error: âPixelDataâ was not declared in this scope
menu.c: In constructor âcMenuConsole::cMenuConsole(int)â:
menu.c:797: error: invalid conversion from âcharâ to âconst char*â
menu.c:797: error:   initializing argument 1 of âint cFont::Height(const char*) constâ
menu.c:803: error: âconsFontSmallFixâ was not declared in this scope
menu.c:803: error: cannot allocate an object of abstract type âcFontâ
/usr/include/vdr/font.h:35: note:   because the following virtual functions are pure within âcFontâ:
/usr/include/vdr/font.h:40: note:       virtual int cFont::Width(uint) const
/usr/include/vdr/font.h:42: note:       virtual int cFont::Width(const char*) const
/usr/include/vdr/font.h:44: note:       virtual int cFont::Height() const
/usr/include/vdr/font.h:48: note:       virtual void cFont::DrawText(cBitmap*, int, int, const char*, tColor, tColor, int) const
menu.c:805: error: invalid conversion from âcharâ to âconst char*â
menu.c:805: error:   initializing argument 1 of âint cFont::Height(const char*) constâ
menu.c:812: error: invalid conversion from âcharâ to âconst char*â
menu.c:812: error:   initializing argument 1 of âint cFont::Height(const char*) constâ
make: *** [menu.o] Error 1
Comment 1 Ed O'Donnell 2008-04-01 09:50:52 UTC
Created attachment 147951 [details]
Emerge output
Comment 2 Carsten Lohrke (RETIRED) gentoo-dev 2008-04-01 16:42:00 UTC
metadata.xml is wrong. A maintainer is always an individual. Please have a look at 

http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=2&chap=4
Comment 3 Matthias Schwarzott gentoo-dev 2008-04-01 16:51:40 UTC
(In reply to comment #2)
> metadata.xml is wrong. A maintainer is always an individual. Please have a look
> at 
> 
> http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=2&chap=4
> 
well, fine. That is only peripherical related to the bug issue itself.
So what do you suggest?
What we wanted to archive was: Be some kind of sub-herd of media-tv.
But I am not motivated now to change all metadata.xml files.
Comment 4 Mark Loeser (RETIRED) gentoo-dev 2008-04-05 22:53:56 UTC
Making a new bug for the metadata issue
Comment 5 Joerg Bornkessel gentoo-dev 2008-04-13 19:35:28 UTC
Hi Ed

there is in the moment no solution to fix this,
console-0.6.0 is based on pixelfonts, used in <=vdr-1.5.8

maybe we can add a dirty fix, but you will miss then all pixelfont based charter symbols, defined in source.

I contakt the Maintainer of this plugin,

waiting for upstream...
Comment 6 Joerg Bornkessel gentoo-dev 2008-07-06 17:17:26 UTC
Ed,

Iam added a patch, it compiles now, but 
how i suggest before, you will miss all charakter symbols
Looks like, the plugin is no maintained anymore ...

Please, give a short feedback