Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 213810 - mail-client/mutt: Backspace does not work in Konsole (and likely many other graphical terminal emulators)
Summary: mail-client/mutt: Backspace does not work in Konsole (and likely many other g...
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Fabian Groffen
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-18 11:52 UTC by Benno Schulenberg
Modified: 2011-05-07 18:54 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments
patch for /usr/share/apps/konsole/default.keytab (patch,319 bytes, text/plain)
2010-05-22 20:46 UTC, Andreas K. Hüttel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Benno Schulenberg 2008-03-18 11:52:03 UTC
Even though <backspace> is bound to previous-page in ~/.muttrc and in the top line it says "<BackSpace>:PrevPg", the Backspace key is not working when running mutt in a Konsole, but it does work in an xterm.

Googling I found http://www.webservertalk.com/message2183722.html
which suggests doing the equivalent of the following:
$ infocmp >thisterminfo
$ sed -i 's/kbs=^H/kbs=\\177/' thisterminfo
$ tic -x thisterminfo

Indeed, after that redefinition of the key, Backspace works in mutt on a Konsole, but not any more on an xterm.  Hmm..., it would be better if Konsole had its own terminfo entry.

(Bug only reported for others to easily find the workaround.)
Comment 1 Fernando J. Pereda (RETIRED) gentoo-dev 2008-06-07 16:05:41 UTC
I guess this should be addressed at the kde guys.

- ferdy
Comment 2 Fabian Groffen gentoo-dev 2009-07-23 13:52:07 UTC
Has this issue been fixed in the meanwhile?  It sounds like a Konsole or termcap problem unrelated to mutt.
Comment 3 Alex Alexander (RETIRED) gentoo-dev 2009-11-06 12:45:48 UTC
this bug is still valid, mutt thinks backspace is another key in konsole and says its not bound anywhere.

it works ok in rxvt-unicode.
Comment 4 Luke-Jr 2010-04-17 18:10:18 UTC
Has this been tested with KDE 4.3.5's Konsole?
Comment 5 Andreas K. Hüttel gentoo-dev 2010-05-17 21:25:45 UTC
Confirmed for konsole-4.4.3.

It seems this is an oddity in the default keymapping. While xterm maps the [<--] key to \b=0x08, Konsole by default maps it to DEL=0x7f.

This should be solved by modifying the current profile in the settings menu:

Profile "Shell" -> Input -> Key assignments -> Modify Default(XFree 4)
then replace the code assigned to Backspace with a simple \b

No idea how to change this by default for whole kde, and what the side effects will be...
Comment 7 Andreas K. Hüttel gentoo-dev 2010-05-22 20:46:45 UTC
Created attachment 232515 [details]
patch for /usr/share/apps/konsole/default.keytab

Here's an (untested but trivial) patch that should modify konsole's default behaviour.
Comment 8 Andreas K. Hüttel gentoo-dev 2010-05-22 22:13:20 UTC
I placed a patched version of 4.4.3-r1 in the KDE overlay. Please test this a lot, since I am not fully sure about the implications of that change to the backspace keybinding.

The same fix should apply for 4.4.2 if needed. 
Comment 9 Andreas K. Hüttel gentoo-dev 2010-05-24 09:56:45 UTC
After some discussion on IRC we decided not to apply this fix. So, the patch in the overlay has been reverted.

Reason:
* about every graphical terminal uses TERM=xterm
* but only xterm uses the keybinding that is required by mutt
* Additionally if we apply this fix console programs cannot tell the difference between backspace and ^H anymore (needed e.g. by emacs).

So, if we fix this, we break other things. I'm reassigning this back to the mutt maintainers; maybe they know how to teach mutt the new de-facto standard. 

A workaround is to change the keybinding yourself in the konsole setup, as described above. 
Comment 10 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-01-12 14:20:55 UTC
I'll remove kde from CC, and imo this bug is WONTFIX
Comment 11 Eray Aslan gentoo-dev 2011-05-07 11:26:28 UTC
Agreed.  But it's grobian's call.  Assigning to him.
Comment 12 Fabian Groffen gentoo-dev 2011-05-07 18:54:10 UTC
xterm is the defacto standard, any derivative that calls itself xterm is at fault.  Get yourself a termcap entry and fix it there.

To me, this is not a mutt bug.