Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 213398 - special keys (macbook pro) not working
Summary: special keys (macbook pro) not working
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal with 1 vote (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-14 15:34 UTC by Jan Rüegg
Modified: 2008-10-22 22:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Rüegg 2008-03-14 15:34:56 UTC
The special keys for adjusting the keyboard and the backlight brightness are not working in gentoo. Volume adjustment and Eject button function, and also the num lock button does.

This is working in Ubuntu, so it must be some kind of gentoo - related

Reproducible: Always
Comment 1 Doug Goldstein (RETIRED) gentoo-dev 2008-03-14 15:43:47 UTC
Do you think that this bug report provides enough information to track down the issue?

I strongly suggest reading the bug reporting guide before submitting another bug. http://www.gentoo.org/doc/en/bugzilla-howto.xml
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-03-14 15:59:26 UTC
This is not a gnome bug at all. This is a kernel problem.
I suppose your fn key doesn't work as well. You can follow howtos on gentoo-wiki.com (although it's not an official information source that's where I got my information to make my macbook 3,1 work properly). I highly suggest applying patches from mactel on top of the latest gentoo-sources.

The rest is a matter of configuration. I'm tempted to closed this as INVALID.
Comment 3 Jan Rüegg 2008-03-14 20:35:21 UTC
Sorry for not providing too much information, ok, here is what I have got:

I don't think it is a kernel problem as the Fn-key IS working, as are the "volume" keys, as I sayed. I'm on an up-to-date Gentoo AMD64 unstable system, using hal 0.5.10 and gnome-power-manager 2.20.2

I applied the latest mactel-patches on tuxonice-sources 2.6.24-r3

Did all possible searches and tried about everything from the gentoo-wiki, but nothing worked. This is my emerge --info:

Portage 2.1.4.4 (default-linux/amd64/2007.0/desktop, gcc-4.2.3, glibc-2.7-r1, 2.6.24-tuxonice-r3-mactel x86_64)
=================================================================
System uname: 2.6.24-tuxonice-r3-mactel x86_64 Intel(R) Core(TM)2 CPU T7400 @ 2.16GHz
Timestamp of tree: Fri, 14 Mar 2008 14:45:03 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.5
dev-lang/python:     2.5.1-r5
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="#collision-protect ccache distlocks metadata-transfer nodoc parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/ "
LANG="en_GB.UTF-8"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/desktop-effects"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acpi additions alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdda cdio cdr cracklib crypt cups dbus dri dts dv dvd dvdr dvdread dvi eds encode esd evo fam ffmpeg firefox foomaticdb gdbm gecko gif glitz gnome gnutls gpm gtk hal iconv ieee1394 injection ipv6 java jpeg kerberos laptop latex ldap libwww lm_sensors mad matroska midi mikmod mmx mono mp3 mpeg mudflap ncurses nptl nptlonly nsplugin obex ogg opengl openmp pam pcre pda pdf perl png ppds python quicktime readline reiserfs samba sdl session spell sse sse2 ssl stream svg symlink syslog tcpd tetex theora threads tiff truetype unicode vcd vim vim-syntax vorbis wifi wxwindows x264 xml xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="fglrx vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

If I can provide anything helpful - the kernel config or something like that for example - just tell me.

Comment 4 Gilles Dartiguelongue gentoo-dev 2008-03-15 01:04:20 UTC
err sorry I misunderstood the report. If you just miss the backlight changes then it's driver specific. With intel drivers I can control backlight with xbacklight but this is xrandr-1.2 only.

In any case, using gpommed should make it work.
Comment 5 Jan Rüegg 2008-03-15 09:02:29 UTC
The point is, I CAN control the backlight, but only with the the slider in the gnome power preferences. And the keyboard backlight is sometines on and sometimes off (I think, controlled by the ambient light sensor).

But the special keys are not all working as they did under Ubuntu and I don't know, if I have to just adjust some configfile to tell the gnome-power-manager which keys he has to listen to...

By the way: Pommed doesn't work anymore, neither. Although I think, it worked once with an older kernel...
Comment 6 Gilles Dartiguelongue gentoo-dev 2008-05-08 14:59:38 UTC
hum pommed not working would also make me think it's a kernel problem but if you say your volume keys work then maybe it's just because we need an updated hal-info. Could you try hal/hal-info packages from gentopia overlay ?
Comment 7 Jan Rüegg 2008-05-10 09:09:42 UTC
(In reply to comment #6)
> hum pommed not working would also make me think it's a kernel problem but if
> you say your volume keys work then maybe it's just because we need an updated
> hal-info. Could you try hal/hal-info packages from gentopia overlay ?
> 

Actually, I'm not really using Gentoo anymore, although I have it still got installed. Should I close the bug or would it be good to try it out anyway for others possibly having the problem?
Comment 8 Gilles Dartiguelongue gentoo-dev 2008-10-22 22:55:38 UTC
(In reply to comment #7)

well whenever you want to give another try to gentoo you can just reopen that bug. I'm the meantime, I'll just close it cantfix.