Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 213379 - app-text/gnomesword fails to compile with net-libs/xulrunner-1.9
Summary: app-text/gnomesword fails to compile with net-libs/xulrunner-1.9
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Theology Herd (disbanded)
URL:
Whiteboard:
Keywords:
: 235340 (view as bug list)
Depends on:
Blocks: xul-1.9
  Show dependency tree
 
Reported: 2008-03-14 12:28 UTC by Nirbheek Chauhan (RETIRED)
Modified: 2009-08-10 15:43 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
app-text/gnomesword-2.3.1-r1 build fail log (build.log,38.28 KB, text/plain)
2008-03-14 12:29 UTC, Nirbheek Chauhan (RETIRED)
Details
Updated ebuild forces configure to only find gecko of version 1.8 (gnomesword-2.3.6.ebuild,1.52 KB, text/plain)
2008-08-28 02:07 UTC, maurerpe
Details
Patch to accompany preceding ebuild (gnomesword-gecko-version.patch,642 bytes, text/plain)
2008-08-28 02:08 UTC, maurerpe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nirbheek Chauhan (RETIRED) gentoo-dev 2008-03-14 12:28:32 UTC
Compilation error for app-text/gnomesword-2.3.1 USE=xulrunner :


In file included from gecko-utils.cpp:31:
/usr/include/xulrunner-1.9/unstable/./gtkmozembed.h:57:1: warning: "NS_HIDDEN" redefined
In file included from /usr/include/xulrunner-1.9/unstable/./nsXPCOMStrings.h:42,
                 from /usr/include/xulrunner-1.9/unstable/./nsStringAPI.h:52,
                 from gecko-utils.cpp:29:
/usr/include/xulrunner-1.9/unstable/./nscore.h:117:1: warning: this is the location of the previous definition
In file included from gecko-utils.cpp:31:
/usr/include/xulrunner-1.9/unstable/./gtkmozembed.h:63:1: warning: "NS_EXPORT_" redefined
In file included from /usr/include/xulrunner-1.9/unstable/./nsXPCOMStrings.h:42,
                 from /usr/include/xulrunner-1.9/unstable/./nsStringAPI.h:52,
                 from gecko-utils.cpp:29:
/usr/include/xulrunner-1.9/unstable/./nscore.h:208:1: warning: this is the location of the previous definition
In file included from gecko-utils.cpp:31:
/usr/include/xulrunner-1.9/unstable/./gtkmozembed.h:64:1: warning: "NS_IMPORT_" redefined
In file included from /usr/include/xulrunner-1.9/unstable/./nsXPCOMStrings.h:42,
                 from /usr/include/xulrunner-1.9/unstable/./nsStringAPI.h:52,
                 from gecko-utils.cpp:29:
/usr/include/xulrunner-1.9/unstable/./nscore.h:206:1: warning: this is the location of the previous definition
mv -f .deps/gecko-utils.Tpo .deps/gecko-utils.Po
In file included from Yelper.cpp:31:
/usr/include/xulrunner-1.9/unstable/./gtkmozembed.h:57:1: warning: "NS_HIDDEN" redefined
In file included from /usr/include/xulrunner-1.9/unstable/./nsStringFwd.h:45,
                 from /usr/include/xulrunner-1.9/unstable/./nsAString.h:43,
                 from /usr/include/xulrunner-1.9/unstable/./nsSubstring.h:43,
                 from /usr/include/xulrunner-1.9/unstable/./nsString.h:44,
                 from Yelper.cpp:29:
/usr/include/xulrunner-1.9/unstable/./nscore.h:117:1: warning: this is the location of the previous definition
In file included from Yelper.cpp:31:
/usr/include/xulrunner-1.9/unstable/./gtkmozembed.h:63:1: warning: "NS_EXPORT_" redefined
In file included from /usr/include/xulrunner-1.9/unstable/./nsStringFwd.h:45,
                 from /usr/include/xulrunner-1.9/unstable/./nsAString.h:43,
                 from /usr/include/xulrunner-1.9/unstable/./nsSubstring.h:43,
                 from /usr/include/xulrunner-1.9/unstable/./nsString.h:44,
                 from Yelper.cpp:29:
/usr/include/xulrunner-1.9/unstable/./nscore.h:208:1: warning: this is the location of the previous definition
In file included from Yelper.cpp:31:
/usr/include/xulrunner-1.9/unstable/./gtkmozembed.h:64:1: warning: "NS_IMPORT_" redefined
In file included from /usr/include/xulrunner-1.9/unstable/./nsStringFwd.h:45,
                 from /usr/include/xulrunner-1.9/unstable/./nsAString.h:43,
                 from /usr/include/xulrunner-1.9/unstable/./nsSubstring.h:43,
                 from /usr/include/xulrunner-1.9/unstable/./nsString.h:44,
                 from Yelper.cpp:29:
/usr/include/xulrunner-1.9/unstable/./nscore.h:206:1: warning: this is the location of the previous definition
In file included from /usr/include/xulrunner-1.9/unstable/./nsrootidl.h:11,
                 from /usr/include/xulrunner-1.9/unstable/./nsISupports.h:10,
                 from /usr/include/xulrunner-1.9/unstable/./nsIPrintingPromptService.h:10,
                 from ../../src/gecko/gecko-services.h:28,
                 from gecko-html.cpp:42:
/usr/include/xulrunner-1.9/unstable/./nscore.h:117:1: warning: "NS_HIDDEN" redefined
In file included from ../../src/gecko/gecko-html.h:26,
                 from gecko-html.cpp:41:
/usr/include/xulrunner-1.9/unstable/./gtkmozembed.h:57:1: warning: this is the location of the previous definition
In file included from /usr/include/xulrunner-1.9/unstable/./nsrootidl.h:11,
                 from /usr/include/xulrunner-1.9/unstable/./nsISupports.h:10,
                 from /usr/include/xulrunner-1.9/unstable/./nsIPrintingPromptService.h:10,
                 from ../../src/gecko/gecko-services.h:28,
                 from gecko-html.cpp:42:
/usr/include/xulrunner-1.9/unstable/./nscore.h:206:1: warning: "NS_IMPORT_" redefined
In file included from ../../src/gecko/gecko-html.h:26,
                 from gecko-html.cpp:41:
/usr/include/xulrunner-1.9/unstable/./gtkmozembed.h:64:1: warning: this is the location of the previous definition
In file included from /usr/include/xulrunner-1.9/unstable/./nsrootidl.h:11,
                 from /usr/include/xulrunner-1.9/unstable/./nsISupports.h:10,
                 from /usr/include/xulrunner-1.9/unstable/./nsIPrintingPromptService.h:10,
                 from ../../src/gecko/gecko-services.h:28,
                 from gecko-html.cpp:42:
/usr/include/xulrunner-1.9/unstable/./nscore.h:208:1: warning: "NS_EXPORT_" redefined
In file included from ../../src/gecko/gecko-html.h:26,
                 from gecko-html.cpp:41:
/usr/include/xulrunner-1.9/unstable/./gtkmozembed.h:63:1: warning: this is the location of the previous definition
mv -f .deps/gecko-html.Tpo .deps/gecko-html.Po
gecko-services.cpp: In static member function ‘static nsresult PrintListener::SetPrintSettings(GeckoPrintInfo*, PRBool, nsIPrintSettings*)’:
gecko-services.cpp:305: error: ‘class nsIPrintSettings’ has no member named ‘SetPaperSize’
make[3]: *** [gecko-services.o] Error 1
make[3]: *** Waiting for unfinished jobs....
Yelper.cpp: In member function ‘PRBool Yelper::Find(const char*)’:
Yelper.cpp:210: error: no matching function for call to ‘nsDerivedSafe<nsITypeAheadFind>::Find(NS_ConvertUTF8toUTF16, int, PRPackedBool&, PRUint16*)’
/usr/include/xulrunner-1.9/unstable/./nsITypeAheadFind.h:43: note: candidates are: virtual nsresult nsITypeAheadFind::Find(const nsAString_internal&, PRBool, PRUint16*)
Yelper.cpp: In member function ‘gint Yelper::ProcessMouseEvent(void*)’:
Yelper.cpp:475: error: ‘class nsAutoString’ has no member named ‘ToCString’
make[3]: *** [Yelper.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/app-text/gnomesword-2.3.1-r1/work/gnomesword-2.3.1/src/gecko'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/app-text/gnomesword-2.3.1-r1/work/gnomesword-2.3.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-text/gnomesword-2.3.1-r1/work/gnomesword-2.3.1'
make: *** [all] Error 2
 * 
 * ERROR: app-text/gnomesword-2.3.1-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2566:  Called gnome2_src_compile
 *             environment, line 1952:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-text/gnomesword-2.3.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-text/gnomesword-2.3.1-r1/temp/environment'.
 * 
 * GNU info directory index is up-to-date.

----

If this package seems to not head towards fixing itself for xulrunner 1.9, it should be made to depend on net-libs/xulrunner:1.8

The build.log is attached in the comment below
Comment 1 Nirbheek Chauhan (RETIRED) gentoo-dev 2008-03-14 12:29:22 UTC
Created attachment 146113 [details]
app-text/gnomesword-2.3.1-r1 build fail log
Comment 2 Steve Dibb (RETIRED) gentoo-dev 2008-08-21 19:46:24 UTC
*** Bug 235340 has been marked as a duplicate of this bug. ***
Comment 3 maurerpe 2008-08-28 02:07:49 UTC
Created attachment 163956 [details]
Updated ebuild forces configure to only find gecko of version 1.8

I am having similar difficulty with app-text/gnomesowrd-2.3.6

The ebuild requests =net-libs/xulrunner-1.8*, but the autoconf script will find libxul-1.9, if it is installed.

I have updated the gecko.m4 file to only search for installed xul versions 1.8*
Comment 4 maurerpe 2008-08-28 02:08:31 UTC
Created attachment 163957 [details]
Patch to accompany preceding ebuild
Comment 5 Steve Dibb (RETIRED) gentoo-dev 2009-07-24 19:57:29 UTC
Gnomesword is going to be removed (renamed / replaced by Xiphos).  Can you guys test and see if the bug is still present in there?