Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 213344 - gnome-extra/yelp fails to compile with net-libs/xulrunner-1.9
Summary: gnome-extra/yelp fails to compile with net-libs/xulrunner-1.9
Status: RESOLVED DUPLICATE of bug 204632
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: xul-1.9
  Show dependency tree
 
Reported: 2008-03-14 06:56 UTC by Nirbheek Chauhan (RETIRED)
Modified: 2008-06-19 10:21 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
06_xulrunner19.patch (06_xulrunner19.patch,13.60 KB, patch)
2008-03-14 20:34 UTC, Pacho Ramos
Details | Diff
patch for the modified ebuilt which uses the ubuntu patch (yelp-2.22.1-r2.ebuild.patch,1.53 KB, patch)
2008-06-08 11:06 UTC, Balazs Nemeth
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nirbheek Chauhan (RETIRED) gentoo-dev 2008-03-14 06:56:04 UTC
For gnome-extra/yelp-2.22.0

mv -f .deps/yelp-gtkentryaction.Tpo .deps/yelp-gtkentryaction.Po
mv -f .deps/yelp-yelp-window.Tpo .deps/yelp-yelp-window.Po
mv -f .deps/yelp-yelp-search.Tpo .deps/yelp-yelp-search.Po
yelp-gecko-services.cpp: In static member function ‘static nsresult PrintListener::SetPrintSettings(YelpPrintInfo*, PRBool, nsIPrintSettings*)’:
yelp-gecko-services.cpp:301: error: ‘class nsIPrintSettings’ has no member named ‘SetPaperSize’
make[3]: *** [yelp-yelp-gecko-services.o] Error 1
make[3]: *** Waiting for unfinished jobs....
mv -f .deps/yelp-yelp-search-parser.Tpo .deps/yelp-yelp-search-parser.Po
make[3]: Leaving directory `/var/tmp/portage/gnome-extra/yelp-2.22.0-r1/work/yelp-2.22.0/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/gnome-extra/yelp-2.22.0-r1/work/yelp-2.22.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-extra/yelp-2.22.0-r1/work/yelp-2.22.0'
make: *** [all] Error 2
 * 
 * ERROR: gnome-extra/yelp-2.22.0-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2601:  Called gnome2_src_compile
 *             environment, line 1981:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/gnome-extra/yelp-2.22.0-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-extra/yelp-2.22.0-r1/temp/environment'.
 * 

The older versions of Yelp probably fail in similar ways, but I cannot test them because of problems mixing older versions of gnome packages with newer gnome libs.
Comment 1 Raúl Porcel (RETIRED) gentoo-dev 2008-03-14 17:16:13 UTC
Please, set the dep to =net-libs/xulrunner-1.8*

Thanks
Comment 2 Pacho Ramos gentoo-dev 2008-03-14 20:34:42 UTC
Created attachment 146157 [details, diff]
06_xulrunner19.patch

For yelp-2.22 (I don't know for 2.20 sorry), ubuntu is using this patch
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-04-10 22:50:11 UTC

*** This bug has been marked as a duplicate of bug 204632 ***
Comment 4 Balazs Nemeth 2008-06-08 11:05:12 UTC
(In reply to comment #2)
> Created an attachment (id=146157) [edit]
> 06_xulrunner19.patch
> 
> For yelp-2.22 (I don't know for 2.20 sorry), ubuntu is using this patch
> 

I applied that patch and rewrite a GCONF settings in the ebuild. Now it compiles.
I attach the ubuntu patch, and a patch to the ebuild.
Comment 5 Balazs Nemeth 2008-06-08 11:06:17 UTC
Created attachment 155913 [details, diff]
patch for the modified ebuilt which uses the ubuntu patch