Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 213218 - revdep-rebuild doesn't re-emerge ebuilds with broken linkage
Summary: revdep-rebuild doesn't re-emerge ebuilds with broken linkage
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2008-03-13 01:15 UTC by Brian Atkinson
Modified: 2008-03-16 20:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

The files created from running revdep-rebuild plus a copy of "env" (revdep-rebuild-files.tar.bz2,72.02 KB, application/octet-stream)
2008-03-13 16:41 UTC, Brian Atkinson

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Atkinson 2008-03-13 01:15:42 UTC
I am guessing would come from media-gfx/exiv2-0.16 (which is installed). I tried a "ln -s /usr/lib64/ /usr/lib64/" and started digikam.  It quickly failed printing:

terminate called after throwing an instance of 'std::bad_alloc'
  what():  St9bad_alloc
KCrash: Application 'digikam' crashing...

Installed packages in the dependency chain:

I have tried revdep-rebuild - and since it cannot find the file digikam needs as /usr/lib64/ does not exist it will not re-emerge any packages.  I have manually re-emerged libexiv2, then libkexiv2, then digikam with no luck.
emerge --info follows:
Portage (default-linux/amd64/2006.1/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r8 x86_64)
System uname: 2.6.23-gentoo-r8 x86_64 AMD Athlon(tm) 64 Processor 2800+
Timestamp of tree: Wed, 12 Mar 2008 23:30:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r5, 2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-O2 -pipe -march=athlon64 -g"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=athlon64 -g"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/layman/nx /usr/portage/local/layman/bcaOverlay"
USE="X a52 aac alsa amd64 arts avahi berkdb bzip2 cairo cdr cli cracklib crypt curl dbus device-mapper dri dts dvd dvdr dvdread eds emboss encode esd exif fam fame firefox flac fortran gdbm gif gphoto2 gpm gstreamer gtk gtk2 hal iconv ipv6 isdnlog jpeg jpeg2k kde kdeenablefinal ldap mad mbox mdnsresponder-compat midi mikmod mozdevelop mp3 mpeg msn mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcre perl png pop3d ppds pppd python qt3 qt4 quicktime readline reflection sdl session spell spl sqlite sqlite3 ssl subversion svg tcpd theora threads tiff truetype unicode urandom utempter vorbis wxwindows x264 xine xinerama xml xorg xscreensaver xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon kodak ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nv nvidia"


Reproducible: Always
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2008-03-13 07:17:16 UTC
I really don't understand what are you trying to do here? Attach a complete emerge log if this is a compile-time failure or clarify what 'cannot find' does mean.
Comment 2 Brian Atkinson 2008-03-13 15:31:50 UTC
~ $ digikam
digikam: error while loading shared libraries: cannot open shared object file: No such file or directory

Sorry sometimes the obvious escapes me.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2008-03-13 15:34:25 UTC
Yeah, so run revdep-rebuild (without any arguments).
Comment 4 Brian Atkinson 2008-03-13 15:46:28 UTC
I have tried revdep-rebuild - and since it cannot find the file digikam needs
as /usr/lib64/ does not exist it will not re-emerge any packages. 
I have manually re-emerged libexiv2, then libkexiv2, then digikam with no luck.

But I run again:

~ $ sudo revdep-rebuild
Configuring search environment for revdep-rebuild

Checking reverse dependencies...

Packages containing binaries and libraries broken by a package update
will be emerged.

Collecting system binaries and libraries... done.

Collecting complete LD_LIBRARY_PATH... done.

Checking dynamic linking consistency...
  broken /usr/kde/3.5/lib/kde3/ (requires
  broken /usr/kde/3.5/lib/kde3/ (requires
  broken /usr/kde/3.5/lib/kde3/ (requires
  broken /usr/kde/3.5/lib/kde3/ (requires
  broken /usr/kde/3.5/lib/kde3/ (requires
  broken /usr/kde/3.5/lib/kde3/ (requires
  broken /usr/kde/3.5/lib/kde3/ (requires
  broken /usr/kde/3.5/lib/kde3/ (requires
  broken /usr/kde/3.5/lib/kde3/ (requires
  broken /usr/kde/3.5/lib/ (requires
  broken /usr/kde/3.5/lib64/kde3/ (requires
  broken /usr/kde/3.5/lib64/kde3/ (requires
  broken /usr/kde/3.5/lib64/kde3/ (requires
  broken /usr/kde/3.5/lib64/kde3/ (requires
  broken /usr/kde/3.5/lib64/kde3/ (requires
  broken /usr/kde/3.5/lib64/kde3/ (requires
  broken /usr/kde/3.5/lib64/kde3/ (requires
  broken /usr/kde/3.5/lib64/kde3/ (requires
  broken /usr/kde/3.5/lib64/kde3/ (requires
  broken /usr/kde/3.5/lib64/ (requires

Assigning files to ebuilds... done.

Evaluating package order... done.

Dynamic linking on your system is consistent... All done.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2008-03-13 15:55:11 UTC
Well, maybe you'd actually get a proper environment passed to revdep-rebuild if you ran it properly when logged on as root or using -E, otherwise everything will get scrapped.

If that doesn't work, then attach all the files created by revdep-rebuild in /root, post your gentoolkit version and reopen then bug then.
Comment 6 Brian Atkinson 2008-03-13 16:41:30 UTC
Created attachment 146045 [details]
The files created from running revdep-rebuild plus a copy of "env"

app-portage/gentoolkit-0.2.3-r1 was used.
Comment 7 Brian Atkinson 2008-03-16 20:42:31 UTC
Some old libraries were hanging around from some dev work I did and an upgrade made them come to light again...removed them, re compiled and everything worked.