Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 212976 - gentoo-sources-2.6.23-r9 - system freeze on reading from usb-serial device
Summary: gentoo-sources-2.6.23-r9 - system freeze on reading from usb-serial device
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Depends on:
Reported: 2008-03-10 20:12 UTC by Jeroen Roos
Modified: 2008-04-15 00:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roos 2008-03-10 20:12:09 UTC
I am using a tool called iTU4l ( to get some info from a GPS logging device. This tool uses the usbserial kernel module to talk to this device. I am running 
Linux jeroen 2.6.23-gentoo-r9 #1 SMP Sat Mar 8 13:37:44 CET 2008 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ AuthenticAMD GNU/Linux
(but I also had this problem with -r8)

The script hangs the entire machine.

I have added a link to the Redhat bugzilla with the exact same problem. I have applied the patch in their ticket to my kernel and now it works like a charm.

Reproducible: Always

Steps to Reproduce:
1. modprobe usbserial
2. -d /dev/ttyUSB0

Actual Results:  
system hangs

Expected Results:  
downloads GPS info from device

jeroen ~ # emerge --info
Portage (default-linux/amd64/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r9 x86_64)
System uname: 2.6.23-gentoo-r9 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Timestamp of tree: Sun, 09 Mar 2008 23:30:01 +0000
app-shells/bash:     3.2_p17-r1
dev-lang/python:     2.4.4-r9
dev-python/pycrypto: 2.0.1-r6
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-march=k8 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="en_GB nl"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac aalib acl acpi alsa amd64 arts asf berkdb branding cairo cdda cddb cdio cdr cli cracklib crypt cups dbus divx dri dts dvd dvdr dvdread eds emboss encode esd evo exif fam ffmpeg firefox fortran gdbm gif gimp gimpprint gmedia gphoto2 gpm gstreamer gtk hal iconv isdnlog jpeg kde mad midi mikmod mmx mozbranding mp3 mpeg mudflap musicbrainz mysql ncurses nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcre pdf perl png pppd python qt3 qt3support qt4 quicktime rar readline realmedia reflection sdl session spell spl sse sse2 ssl stream svg tcpd threads tiff truetype type1 unicode v4l v4l2 vorbis wmp x264 xine xml xorg xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB nl" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"
Comment 1 Jeroen Roos 2008-03-11 12:24:21 UTC
I see the bug has been changed to "NEEDINFO", what info do you need and do you expect me to deliver that info?
Comment 2 Jeroen Roos 2008-03-17 11:48:24 UTC
What info is needed?
Comment 3 Mike Pagano gentoo-dev 2008-03-23 14:03:06 UTC
Not sure if dsd wants to do a new 23-rX release. We very well might, but we will be doing a new gentoo-sources-2.6.24-rX release probably during the week of March 31st.

Could you apply this patch:;a=commitdiff_plain;h=b507cc9710d8b6e3013468b40522e235342fc84a

to gentoo-sources-2.6.24-r3 and just let me know that it works. I will then put it in the queue for the 2.6.24-r4.

Comment 4 Jeroen Roos 2008-03-24 10:37:38 UTC
I have applied the patch, recompiled and rebooted with the new kernel. That all went well and when I run, it no longer hangs the machine, however it also doesn't work anymore. It seems unable to set the terminal speed for /dev/ttyUSB0.

usb 2-3: new full speed USB device using ohci_hcd and address 5
usb 2-3: configuration #1 chosen from 1 choice
usbserial_generic 2-3:1.0: Generic device with no bulk out, not allowed.
usbserial_generic: probe of 2-3:1.0 failed with error -5
usbserial_generic 2-3:1.1: generic converter detected
usb 2-3: generic converter now attached to ttyUSB0

jeroen ~ # -d /dev/ttyUSB0

Trying to talk to the USB device
stty: standard input: unable to perform all requested operations
 Error while setting /dev/ttyUSB0 to cs8 raw 115200

USB devices found, but not detected as the GPS logger we searched. To find
it please follow the instructions on

jeroen ~ # stty -F /dev/ttyUSB0 cs8 raw 115200
stty: /dev/ttyUSB0: unable to perform all requested operations
jeroen ~ # stty -F /dev/ttyUSB0 cs8 raw
jeroen ~ # stty -F /dev/ttyUSB0 115200
stty: /dev/ttyUSB0: unable to perform all requested operations
Comment 5 Jeroen Roos 2008-04-06 18:17:10 UTC
I have just upgraded to 2.6.24-r9, and the problem still persists... worse, the patch attached to this bug doesn't apply anymore, so I now basicly cannot use my GPS tracker anymore.
Comment 6 Jeroen Roos 2008-04-06 18:18:02 UTC
> 2.6.24-r9
That is supposed to read 2.6.24-r4
Comment 7 Jeroen Roos 2008-04-06 18:49:01 UTC
> the patch attached to this bug doesn't apply anymore
Actually, the patch does apply, but I still have the problem not being able to set the baudrate. I have copied usb-serial.c from 2.6.23-r9 into 2.6.24-r4 and applied the patch from Redhat, and now I have a working config again.
Comment 8 Mike Pagano gentoo-dev 2008-04-06 20:02:00 UTC
Can you test with the latest development kernel at this time, 2.6.25_rc8.

Comment 9 Greg Kroah-Hartman (RETIRED) gentoo-dev 2008-04-07 03:56:27 UTC
The generic usb-serial driver can not set any line settings or flow control, so those options will always fail.

Please take this to the developers, on the linux-usb mailing list, and send a copy of the perl script that is causing the problem.  This is not a gentoo-specific issue at all.
Comment 10 Jeroen Roos 2008-04-10 17:16:08 UTC
(In reply to comment #8)
> Can you test with the latest development kernel at this time, 2.6.25_rc8.
Tried it, same problem: no crash, but failing on the stty

Comment 11 Mike Pagano gentoo-dev 2008-04-15 00:02:05 UTC
As advised in  Comment  #9, when you have a chance please take this to linux-usb mailing list with the requested information.  Please reopen with a link to the archive once this is done.