Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 212815 - media-libs/faad2-2.6.1 fails to emerge with libtool-2.2
Summary: media-libs/faad2-2.6.1 fails to emerge with libtool-2.2
Status: RESOLVED DUPLICATE of bug 212760
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-09 11:57 UTC by Alexey Shevchuck
Modified: 2008-03-09 12:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Automake error. Equals for moc, faad2 (automake.out,635 bytes, text/plain)
2008-03-09 11:58 UTC, Alexey Shevchuck
Details
My workaround for this stuff. Faad2 example. (faad2-2.6.1-cxx.patch,253 bytes, patch)
2008-03-09 11:59 UTC, Alexey Shevchuck
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Shevchuck 2008-03-09 11:57:35 UTC
Today (09/03/2008) I try to build some packages <moc-alpha3, faad2, etc>, and I couldn't. Example of error in attach.
Sample local patch in attach too.

Reproducible: Always

Steps to Reproduce:
1. emerge faad2

Actual Results:  
Example for faad2:

>>> Emerging (1 of 1) media-libs/faad2-2.6.1 to /
 * faad2-2.6.1.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                                                                   [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                    [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                   [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                  [ ok ]
 * checking faad2-2.6.1.tar.gz ;-) ...                                                                                                                                  [ ok ]
>>> Unpacking source...
>>> Unpacking faad2-2.6.1.tar.gz to /home/shara/tmp/build/portage/media-libs/faad2-2.6.1/work
 * Applying faad2-2.6.1-abi_has_changed.patch ...                                                                                                                       [ ok ]
 * Running eautoreconf in '/home/shara/tmp/build/portage/media-libs/faad2-2.6.1/work/faad2' ...
 * Running aclocal ...                                                                                                                                                  [ ok ]
 * Running libtoolize --copy --force --install --automake ...                                                                                                           [ ok ]
 * Running aclocal ...                                                                                                                                                  [ ok ]
 * Running autoconf ...                                                                                                                                                 [ ok ]
 * Running autoheader ...                                                                                                                                               [ ok ]
 * Running automake --add-missing --copy --foreign ...                                                                                                                  [ !! ]

 * Failed Running automake !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /home/shara/tmp/build/portage/media-libs/faad2-2.6.1/temp/automake-11248.out

 * 
 * ERROR: media-libs/faad2-2.6.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 2564:  Called eautoreconf
 *             environment, line  886:  Called eautomake
 *             environment, line  860:  Called autotools_run_tool 'src_unpack' 'src_unpack' 'automake' '--add-missing'
 *             environment, line  380:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *  The die message:
 *   Failed Running automake !
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/home/shara/tmp/build/portage/media-libs/faad2-2.6.1/temp/build.log'.
 * The ebuild environment file is located at '/home/shara/tmp/build/portage/media-libs/faad2-2.6.1/temp/environment'.
 * 


Expected Results:  
Build :]

avatar@Nemesis ecb % emerge --info
Portage 2.1.4.4 (default-linux/x86/2006.1, gcc-4.2.2, glibc-2.7-r1, 2.6.24-tuxonice-r1-T21 i686)
=================================================================
System uname: 2.6.24-tuxonice-r1-T21 i686 Pentium III (Coppermine)
Timestamp of tree: Sat, 08 Mar 2008 23:00:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.2-r1
dev-lang/python:     2.5.1-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.17-r1, 2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium3 -O3 -pipe -ffast-math"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/kde/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/service"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=pentium3 -O3 -pipe -ffast-math"
DISTDIR="/usr/portage/distfiles"
FEATURES="distcc distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="ru_RU.UTF-8"
LDFLAGS=""
LINGUAS="ru uk ua"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/shara/tmp/build"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/plan9 /usr/portage/local/layman/gnustep /usr/portage/local/layman/d /usr/portage/local/layman/liquidx /usr/portage/local/layman/java-overlay /usr/portage/local/layman/gentoo-china /usr/portage/local/layman/custom-kernels /usr/portage/local/layman/zugaina /usr/portage/local/layman/lapis /usr/portage/local/layman/emacs /usr/portage/local/layman/suka /usr/portage/local/layman/linamh /usr/portage/local/layman/mozilla /usr/portage/local /usr/portage/local/hawking-overlay /usr/portage/local/layman/mabi /usr/portage/local/layman/zeypher"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi additions ads alsa amr amrnb amrwb bash-completion berkdb bidi bluetooth bzip2 caps cdda cddb cdparanoia cli clism clisp color-console consolekit crypt cscope cups curl d dbus dga directfb disk-partition djvu dmi dmus dmx dts dvd dvdread dvi emacs enca encode exif fbcon fbdev fbmode firefox flac fontconfig foomaticdb fortran ftp fuse gd gdbm gdc ggi gif gimp gjvu gnutls gpgme gpm graphviz gs gsf gtk gzip0el hal icc iconv icq icu idn ifc imap inotruetype ion3-voidupstreamsupport-truetype iontruetype irda isdnlog jabber java javascript joystick jpeg kqemu laptop latex lcms ldap libedit libnotify libotf libsamplerate lirc live lua lzo mad maildir mailwrapper mbox midi mktemp mmap mmx mmxext mng mono mp2 mp3 mudflap multislot multitarget musepack ncurses netbeans network network-cron nls nntp no-old-linux nptl nptlonly nsplugin ntfs odbc ogg openmp oss otr pam passdqc pch pcmcia pcre pdf perl png pop ppds pppd preview-latex pth pulseaudio pvr python qt3 qt3support qt4 quicktime radio rar rcc readline reflection reiserfs rss rtc samba sdl session shm skey skins slp smime smtp sndfile socks5 spell spl sqlite sqlite3 srt sse ssl suid svg sysfs syslog t1lib tcl tcpd tex theora threads tiff tk transmitter truetype ucs2 udev unicode usb utf8 vim-pager vim-syntax vorbis webdav wifi win32codecs winbind wmf wxwindows x264 x265 x86 xanim xattr xcb xface xforms xft xftp xine xinerama xinetd xml xorg xosd xprint xv xvid xvmc zlib" ALSA_CARDS="cs46xx intel8x0m" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard evdev joustick mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru uk ua" LIRC_DEVICES="sir" USERLAND="GNU" VIDEO_CARDS="savage vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alexey Shevchuck 2008-03-09 11:58:52 UTC
Created attachment 145633 [details]
Automake error. Equals for moc, faad2
Comment 2 Alexey Shevchuck 2008-03-09 11:59:42 UTC
Created attachment 145635 [details, diff]
My workaround for this stuff. Faad2 example.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2008-03-09 12:53:16 UTC

*** This bug has been marked as a duplicate of bug 212760 ***