Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 210956 - kde-base/plasma-4.0.1 do not compile on g/fbsd due to a non portable snippet of code
Summary: kde-base/plasma-4.0.1 do not compile on g/fbsd due to a non portable snippet ...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: FreeBSD (show other bugs)
Hardware: All FreeBSD
: High normal (vote)
Assignee: Gentoo/BSD Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-21 10:53 UTC by MT
Modified: 2008-12-05 10:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
plasma-4.0.1_fbsd.patch (plasma-4.0.1_fbsd.patch,1.00 KB, patch)
2008-02-21 10:54 UTC, MT
Details | Diff
plasma-4.0.1.ebuild.patch (plasma-4.0.1.ebuild.patch,329 bytes, patch)
2008-02-21 10:56 UTC, MT
Details | Diff
plasma-4.0.4.ebuild.patch (plasma-4.0.4.ebuild.patch,357 bytes, patch)
2008-06-04 16:26 UTC, MT
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description MT 2008-02-21 10:53:36 UTC
on g/fbsd the compilation fails with:

[ 75%] Building CXX object plasma/plasma/CMakeFiles/kdeinit_plasma-qgv.dir/plasmaapp.o
/var/tmp/portage/kde-base/plasma-4.0.1/work/plasma-4.0.1/plasma/plasma/plasmaapp.cpp: In constructor 'PlasmaApp::PlasmaApp(Display*, Qt::HANDLE, Qt::HANDLE)':
/var/tmp/portage/kde-base/plasma-4.0.1/work/plasma-4.0.1/plasma/plasma/plasmaapp.cpp:142: error: '_SC_PHYS_PAGES' was not declared in this scope
gmake[2]: *** [plasma/plasma/CMakeFiles/kdeinit_plasma-qgv.dir/plasmaapp.o] Error 1
gmake[1]: *** [plasma/plasma/CMakeFiles/kdeinit_plasma-qgv.dir/all] Error 2


this error is due to the fact that _SC_PHYS_PAGES do not exists for *BSD.
upstream have just fixed the problem in SVN: http://bugs.kde.org/show_bug.cgi?id=156200

so i have simply reverted the upstream SVN patch for the portage 4.0.1 branch. attached there are the fix and the ebuild patch for kde-base/plasma-4.0.1.

Reproducible: Always
Comment 1 MT 2008-02-21 10:54:49 UTC
Created attachment 144195 [details, diff]
plasma-4.0.1_fbsd.patch
Comment 2 MT 2008-02-21 10:56:48 UTC
Created attachment 144196 [details, diff]
plasma-4.0.1.ebuild.patch
Comment 3 MT 2008-06-04 16:26:02 UTC
Created attachment 155521 [details, diff]
plasma-4.0.4.ebuild.patch

the same problem happen also with kde-base/plasma-4.0.4, here the ebuild fix
Comment 4 Tomáš Chvátal (RETIRED) gentoo-dev 2008-10-17 12:05:51 UTC
Hi could you test whole kde4.1 on gfbsd? :P

It would be great :]
Comment 5 Tomáš Chvátal (RETIRED) gentoo-dev 2008-10-18 16:34:15 UTC
Hups sorry missed tab :( This bug has nothing to do with 216127, 237018.
Comment 6 Pawel Madej aka Nysander 2008-12-04 21:13:26 UTC
please close this bug as there is no kde-4.0.1 in the whole portage tree
Comment 7 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-05 10:08:17 UTC
since plasma is splitted in 4.X please test the according packages in 4.X and report a new bug if needed