Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 210457 - sys-kernel/genkernel-3.4.10_pre2: /etc/initrd.scripts syntax error
Summary: sys-kernel/genkernel-3.4.10_pre2: /etc/initrd.scripts syntax error
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: genkernel (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Genkernel Maintainers
URL:
Whiteboard:
Keywords: InVCS
: 210593 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-02-17 12:42 UTC by Paul Taylor
Modified: 2008-02-26 03:15 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Remove non-ash syntax (initrd.scripts.patch,457 bytes, patch)
2008-02-17 14:28 UTC, Sanne Wouda
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Taylor 2008-02-17 12:42:04 UTC
After building gentoo-sources-2.6.24-r2 with genkernel-3.4.10-r2, booting fails with the following error:

/init: /etc/initrd.scripts: 936: Syntax error: Bad substitution

After reverting to genkernel-3.4.9, it works fine.


# emerge --info
Portage 2.1.4.4 (default-linux/amd64/2007.0/desktop, gcc-4.2.3, glibc-2.7-r1, 2.6.24-gentoo-r2 x86_64)
=================================================================
System uname: 2.6.24-gentoo-r2 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5600+
Timestamp of tree: Sun, 17 Feb 2008 07:16:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.5.1-r5
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -msse3 -mfpmath=sse -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -msse3 -mfpmath=sse -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.iinet.com.au/pub/Gentoo http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.iinet.net.au/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 amr asf audiofile bash-completion berkdb bitmap-fonts bzip2 bzlib cairo cdparanoia cdr cdrom chroot clamav clamd cli cracklib crypt cups curl dbus djbfft dmi dpms dri dts dv dvb dvd dvdr dvdread eds emboss encode evo exif expat extrafilters fam fame fbcon fbcondecor ffmpeg flac foomaticdb fortran gdbm gif gimpprint glitz glut gmp gpm gps gsl gstreamer gtk hal iconv id3 idn imagemagick imap imlib ipod ipv6 isdnlog jack java jbig jpeg jpeg2k junit kde ladspa lame lcms libsamplerate lirc lm_sensors lzo mad mailwrapper midi mjpeg mmap mmx mng mp3 mp4 mp4live mpeg mpeg2 mpeg4 mpi msn mudflap musepack musicbrainz ncurses network nls nptl nptlonly nsplugin nvidia ogg oggvorbis openal opengl openmp pam pcre pda pdf perl pic png pppd python qt3 qt3support qt4 quicktime readline reflection regex rle schedule sdk sdl server session slang smp sndfile speex spell spl sqlite sse sse2 ssl svg symlink tcpd test theora threads tiff truetype truetype-fonts type1-fonts unicode usb userlocales v4l v4l2 vcd vdr vim vim-syntax visualization vorbis vorbis-psy wavpack wmf xcb xcomposite xine xml xml2 xorg xpm xprint xscreensaver xulrunner xv xvid xvmc yv12 zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIRC_DEVICES="devinput" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Alexey Shvetsov gentoo-dev 2008-02-17 14:24:13 UTC
I confirm this bug on ThinkPad X31 w tuxonice-r2
Comment 2 Sanne Wouda 2008-02-17 14:28:29 UTC
Created attachment 143783 [details, diff]
Remove non-ash syntax

Line 936 a type of parameter expansion that is not supported in busybox ash.

This patch fixes this.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2008-02-18 15:59:56 UTC
*** Bug 210593 has been marked as a duplicate of this bug. ***
Comment 4 Andrew Gaffney (RETIRED) gentoo-dev 2008-02-19 19:39:07 UTC
This is fixed in SVN. Thanks.
Comment 5 DEMAINE Benoît-Pierre, aka DoubleHP 2008-02-21 02:27:26 UTC
I confirm. When will patch be available on mirors ?
Comment 6 Andrew Gaffney (RETIRED) gentoo-dev 2008-02-26 03:15:43 UTC
This was released in 3.4.10_pre3.