Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 210029 - dev-util/boost-build-1.34.1 fails when LDFLAGS isn't set
Summary: dev-util/boost-build-1.34.1 fails when LDFLAGS isn't set
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Tiziano Müller
URL:
Whiteboard:
Keywords:
: 210044 210050 210243 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-02-13 17:41 UTC by Stéphane Bisinger
Modified: 2008-05-21 06:02 UTC (History)
21 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
corrected boost-build patch (boost-build.diff,704 bytes, patch)
2008-02-13 22:30 UTC, Daniel Pielmeier
Details | Diff
Build log on x86 of boost-build v1.34 (dev-util:boost-build-1.34.1:20080505-151240.log,3.23 KB, text/plain)
2008-05-05 15:16 UTC, Jason McGuiness
Details
emerge info output (emerge-info.txt,4.37 KB, text/plain)
2008-05-07 02:59 UTC, Steven Elling
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stéphane Bisinger 2008-02-13 17:41:44 UTC
With the latest boost-build update it fails compiling:

[COMPILE] bin.linux/bjam
x86_64-pc-linux-gnu-gcc: : No such file or directory

    "x86_64-pc-linux-gnu-gcc"   -o bin.linux/bjam -DNDEBUG -DOPT_HEADER_CACHE_EXT -DOPT_GRAPH_DEBUG_EXT -DOPT_SEMAPHORE -DOPT_AT_FILES -DOPT_FIX_TARGET_VARIABLES_EXT -DOPT_IMPROVED_PATIENCE_EXT -DYYSTACKSIZE=5000 -O2 -pipe -march=athlon64 -fno-strict-aliasing -O "" command.c compile.c debug.c expand.c glob.c hash.c hcache.c headers.c hdrmacro.c jam.c jambase.c jamgram.c lists.c make.c make1.c newstr.c option.c parse.c regexp.c rules.c scan.c search.c subst.c w32_getreg.c timestamp.c variable.c modules.c strings.c filesys.c builtins.c pwd.c class.c native.c modules/set.c modules/path.c modules/regex.c modules/property-set.c modules/sequence.c modules/order.c execunix.c fileunix.c pathunix.c

...failed [COMPILE] bin.linux/bjam...
...failed updating 1 target...
...updated 1 target...
 * 
 * ERROR: dev-util/boost-build-1.34.1 failed.
 * Call stack:
 *                   ebuild.sh, line 1701:  Called dyn_compile
 *                   ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *                   ebuild.sh, line   44:  Called src_compile
 *   boost-build-1.34.1.ebuild, line   63:  Called die
 * The specific snippet of code:
 *   	LIBS="${LDFLAGS}" CC=$(tc-getCC) ./build.sh ${toolset} $(use_with python) || die "building bjam failed"
 *  The die message:
 *   building bjam failed

As you can see, the problem lies here:

x86_64-pc-linux-gnu-gcc: : No such file or directory

    "x86_64-pc-linux-gnu-gcc"   -o bin.linux/bjam -DNDEBUG [...]

The quotation marks shouldn't be there adn apparently they come from this line in the ebuild:

LIBS="${LDFLAGS}" CC=$(tc-getCC) ./build.sh ${toolset} $(use_with python) || die "building bjam failed"

Thus meaning that, probably, there is a problem with the tc-getCC function in toolchain-funcs.eclass

Reproducible: Always

Steps to Reproduce:
1.emerge boost-build
Actual Results:  
[COMPILE] bin.linux/bjam
x86_64-pc-linux-gnu-gcc: : No such file or directory

    "x86_64-pc-linux-gnu-gcc"   -o bin.linux/bjam -DNDEBUG -DOPT_HEADER_CACHE_EXT -DOPT_GRAPH_DEBUG_EXT -DOPT_SEMAPHORE -DOPT_AT_FILES -DOPT_FIX_TARGET_VARIABLES_EXT -DOPT_IMPROVED_PATIENCE_EXT -DYYSTACKSIZE=5000 -O2 -pipe -march=athlon64 -fno-strict-aliasing -O "" command.c compile.c debug.c expand.c glob.c hash.c hcache.c headers.c hdrmacro.c jam.c jambase.c jamgram.c lists.c make.c make1.c newstr.c option.c parse.c regexp.c rules.c scan.c search.c subst.c w32_getreg.c timestamp.c variable.c modules.c strings.c filesys.c builtins.c pwd.c class.c native.c modules/set.c modules/path.c modules/regex.c modules/property-set.c modules/sequence.c modules/order.c execunix.c fileunix.c pathunix.c

...failed [COMPILE] bin.linux/bjam...
...failed updating 1 target...
...updated 1 target...
 * 
 * ERROR: dev-util/boost-build-1.34.1 failed.
 * Call stack:
 *                   ebuild.sh, line 1701:  Called dyn_compile
 *                   ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *                   ebuild.sh, line   44:  Called src_compile
 *   boost-build-1.34.1.ebuild, line   63:  Called die
 * The specific snippet of code:
 *   	LIBS="${LDFLAGS}" CC=$(tc-getCC) ./build.sh ${toolset} $(use_with python) || die "building bjam failed"
 *  The die message:
 *   building bjam failed

Expected Results:  
Successful merge
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2008-02-13 17:46:34 UTC
emerge --info output, please.
Comment 2 Stéphane Bisinger 2008-02-13 17:48:19 UTC
(In reply to comment #1)
> emerge --info output, please.
> 

If you feel like it matters here it is:

Portage 2.1.3.19 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.20-gentoo-r8 x86_64)
=================================================================
System uname: 2.6.20-gentoo-r8 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5600+
Timestamp of tree: Wed, 13 Feb 2008 15:16:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=athlon64"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=athlon64"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/ http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources/ http://mirror.switch.ch/ftp/mirror/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/ "
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LINGUAS="en fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X aac acl acpi alsa amd64 apache2 berkdb bitmap-fonts bzip2 cddb cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread exif firefox flac fortran gdbm gif gpgme gpm gtk hal iconv ipv6 isdnlog jpeg jpeg2k lcms mad mbox midi mmx mp3 mpeg mplayer mudflap ncurses nls nptl nptlonly nsplugin nvidia ogg openal opengl openmp pam pcre pdf perl png pppd python quicktime readline reflection sdl session spl sse sse2 ssl startup-notification svg tcpd threads truetype truetype-fonts type1-fonts unicode usb v4l vim-syntax wma xml xml2 xorg xosd xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" ELIBC="glibc" FOO2ZJS_DEVICES="hp1020" INPUT_DEVICES="keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en fr" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2008-02-13 17:57:51 UTC
Yeah I indeed feel like it matters since it works perfectly fine here and for lots of other people.
Comment 4 Sergey Belyashov 2008-02-13 18:06:32 UTC
I have same problem.

emerge --info:
Portage 2.1.3.19 (default-linux/amd64/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r8 x86_64)
=================================================================
System uname: 2.6.23-gentoo-r8 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4600+
Timestamp of tree: Wed, 13 Feb 2008 17:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/init.d /etc/pam.d /etc/revdep-rebuild /etc/ssh /etc/ssl /etc/terminfo /etc/udev /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch prelink sandbox sfperms strict unmerge-orphans userfetch"
LANG="ru_RU.UTF-8"
LINGUAS="ru en"
MAKEOPTS="-j3 -s"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi additions aiglx alsa amd64 arts artswrappersuid audacious bash-completion bitmap-fonts branding bzip2 cairo cdr cg cli cmake cracklib crypt cvs dbus devil diet disk-partition dri dts dvd dvdr dvdread emboss encode esd evo fam ffmpeg firefox flac fortran gif glitz gnome gpm graphviz gstreamer gtk hal hddtemp iconv imagemagick isdnlog java jpeg kde kdeenablefinal kqemu lcms libnotify lm_sensors logrotate mad mbox midi mikmod mmap mmx mng modplug mp3 mpeg mplayer mudflap nas ncurses network-cron nls nptl nptlonly nsplugin nvidia ogg openal opengl openmp oss pam pch pcre pdf perl png pppd python qt3 qt3support qt4 quicktime readline reflection rtc sdl session shout skins slang speex spell spl sse sse2 ssl stream subversion svg tcpd theora threads tiff timidity truetype truetype-fonts type1-fonts unicode urandom usb vcd vim-syntax visualization vorbis wma wmf wxwindows xine xml xorg xosd xpm xulrunner xv xvid zlib" ALSA_CARDS="emu10k1x" ALSA_PCM_PLUGINS="shm" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard" KERNEL="linux" LINGUAS="ru en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 5 Joshua Doll 2008-02-13 18:07:48 UTC
I am also having the same issue.


emerge --info output

Portage 2.1.3.19 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo x86_64)
=================================================================
System uname: 2.6.24-gentoo x86_64 Intel(R) Pentium(R) D CPU 2.80GHz
Timestamp of tree: Wed, 13 Feb 2008 16:30:06 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ "
LINGUAS="en_US en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/musicbrainz /usr/portage/local/layman/desktop-effects"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac aalib acl acpi alsa amarok amd64 ao bash-completion berkdb bitmap-fonts bzip2 cairo ccache cddb cdinstall cdr cdrom cdrw cli console cracklib crypt css cups dbus dga directfb divx doc dri dvd dvdr dvdread dvdrw encode esd exif expat ffmpeg firefox flac fortran gdbm gif gimp glitz gnome gphoto2 gpm gstreamer gtk gtk2 hal hddtemp iconv imagemagick ipod isdnlog joystick jpeg jpeg2k libnotify lm_sensors mad midi mikmod mmx modplug mp3 mp4 mpeg mudflap musepack musicbrainz ncurses net nls nptl nptlonly nsplugin ogg opengl openmp optimisememory oss pam pcre pdf perl png ppds pppd python qt3 qt4 quicktime rar raw readline reflection session spell spl sse sse2 sse3 ssl svg tcpd theora threads tiff toolbar truetype truetype-fonts type1 type1-fonts unicode usb visualization vorbis wxwindows xcomposite xine xorg xscreensaver xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en" USERLAND="GNU" VIDEO_CARDS="i810 nv nvidia vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 6 Manfred Knick 2008-02-13 18:08:51 UTC
(In reply to comment #3)
> Yeah I indeed feel like it matters since it works perfectly fine here and for
> lots of other people.
> 


    Not for me, too.

    Thus you might be interested being provided another example ?

    # emerge --info
    Portage 2.1.3.19 (default-linux/amd64/2007.0/desktop, gcc-4.1.2,
    glibc-2.6.1-r0, 2.6.24-gentoo-r2 x86_64)
    =================================================================
    System uname: 2.6.24-gentoo-r2 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor
    5200+
    Timestamp of tree: Wed, 13 Feb 2008 16:46:01 +0000
    ccache version 2.4 [enabled]
    app-shells/bash:     3.2_p17-r1
    dev-java/java-config: 1.3.7, 2.0.33-r1
    dev-lang/python:     2.4.4-r6
    dev-python/pycrypto: 2.0.1-r6
    dev-util/ccache:     2.4-r7
    sys-apps/baselayout: 1.12.10-r5
    sys-apps/sandbox:    1.2.18.1-r2
    sys-devel/autoconf:  2.13, 2.61-r1
    sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
    sys-devel/binutils:  2.18-r1
    sys-devel/gcc-config: 1.4.0-r4
    sys-devel/libtool:   1.5.24
    virtual/os-headers:  2.6.24
    ACCEPT_KEYWORDS="amd64"
    CBUILD="x86_64-pc-linux-gnu"
    CFLAGS="-march=athlon64 -O2 -pipe -mno-tls-direct-seg-refs "
    CHOST="x86_64-pc-linux-gnu"
    CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config
    /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/bind"
    CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf
    /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/
    /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo
    /etc/udev/rules.d"
    CXXFLAGS="-march=athlon64 -O2 -pipe -mno-tls-direct-seg-refs "
    DISTDIR="/usr/portage/distfiles"
    FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms
    strict unmerge-orphans userfetch"
    GENTOO_MIRRORS="ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo"
    LANG="de_DE.utf8"
    LC_ALL="de_DE.utf8"
    LINGUAS="de"
    MAKEOPTS="-j3"
    PKGDIR="/usr/portage/packages"
    PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress
    --force --whole-file --delete --delete-after --stats --timeout=180
    --exclude=/distfiles --exclude=/local --exclude=/packages
    --filter=H_**/files/digest-*"
    PORTAGE_TMPDIR="/var/tmp"
    PORTDIR="/usr/portage"
    SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
    USE="X acl acpi alsa amd64 apache2 arts berkdb bitmap-fonts cairo cdr cli
    cracklib crypt cups dbus doc dri dvb dvd dvdr dvdread eds emboss encode esd evo
    examples fam fax firefox foomaticdb fortran gdbm gif gimp gimpprint gnome
    gphoto2 gpm gstreamer gtk hal hbci hvm iconv ioemu ipv6 isdnlog java jpeg
    kbanking kde kerberos kvm ldap libvirt libwww lirc mad maildir mailwrapper mbox
    midi mikmod mmx mp3 mpeg mudflap mysql ncurses nls nptl nptlonly ogg opengl
    openmp oss pam pcre pdf perl php png ppds pppd python qt qt3 qt3support qt4
    quicktime readline reflection samba scanner screen sdl session snmp spell spl
    sse sse2 ssl svg tcpd tiff truetype truetype-fonts type1-fonts unicode usb
    vorbis xml xorg xv zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem
    bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel
    intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
    ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file
    hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route
    share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest
    authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default
    authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs
    dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter
    headers ident imagemap include info log_config logio mem_cache mime mime_magic
    negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite
    setenvif so speling status unique_id userdir usertrack vhost_alias"
    ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad
    cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de"
    USERLAND="GNU" VIDEO_CARDS="nvidia"
    Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS,
    PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS,
    PORTDIR_OVERLAY

Comment 7 Randall Wald 2008-02-13 18:29:14 UTC
Same problem here:

Portage 2.1.3.19 (default-linux/amd64/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo-r2 x86_64)
=================================================================
System uname: 2.6.24-gentoo-r2 x86_64 Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz
Timestamp of tree: Wed, 13 Feb 2008 17:46:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://open-systems.ufl.edu/mirrors/gentoo http://www.gtlib.gatech.edu/pub/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo http://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://gentoo.osuosl.org/ "
LANG="en_US.UTF-8"
LINGUAS="en ja"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/portage/local/layman/mabi /usr/portage/local/layman/roslin /usr/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="64bit 7zip X a52 aac aalib acl acpi aim alsa amd64 animgif anthy arts audacious bash-completion berkdb bitmap-fonts bittorrent bluetooth branding bzip2 cairo cdaudio cdda cddb cdparanoia cdr cjk cli console cpudetection cracklib crypt css cups dbus dict directfb divx djvu dri dvd dvdnav dvdr dvdread dvi eds emboss encode esd evo exif fam fat fbcon fbsplash ffmpeg firefox flac fortran ftp gdbm gif gimp gimpprint glsa gmail gpm gs gstreamer gtk hal hdaps hddtemp hfs ibmacpi iconv icq idea ieee1394 imagemagick ipv6 ipw4965 isdnlog jabber java javascript jingle john jpeg kerberos lame latex ldap libcaca lm_sensors lua mad md5sum midi mikmod mmx mng mono mp3 mpeg mplayer msn mtp mudflap mysql ncurses nethack nls nptlonly nsplugin ntfs offensive ogg opengl openmp openssl opensslcrypt openvpn oss pam pcmcia pcre pdf perl pidgin png pop pppd prediction python qt3support quicktime rar raw readline realmedia reflection reiserfs sdl server session spell spl sse sse2 ssl ssse3 svg tcpd thunderbird tiff timidity tracker truetype truetype-fonts type1-fonts uim unicode usb vim-syntax vim-with-x visualization vorbis wav wifi wma wmp wordperfect xcomposite xml xorg xscreensaver xv xvid yahoo zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ja" USERLAND="GNU" VIDEO_CARDS="vesa vga i810 intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 8 Konrad Karczewski 2008-02-13 18:30:12 UTC
(In reply to comment #3)
> Yeah I indeed feel like it matters since it works perfectly fine here and for
> lots of other people.
> 

I believe this got broken when new keyword appeared without new revision:

# emerge -vuND world

These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild   R   ] dev-util/boost-build-1.34.1  USE="python%*" 0 kB 

The same issue appears on 2 other 'amd64' machines - I can provide outputs
for them as well, but this output is for 'plain' x86 and ppc:

>>> Emerging (1 of 1) dev-util/boost-build-1.34.1 to /
 * boost_1_34_1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                   [ ok
]
 * checking ebuild checksums ;-) ...                                      [ ok
]
 * checking auxfile checksums ;-) ...                                     [ ok
]
 * checking miscfile checksums ;-) ...                                    [ ok
]
 * checking boost_1_34_1.tar.bz2 ;-) ...                                  [ ok
]
>>> Unpacking source...
>>> Unpacking boost_1_34_1.tar.bz2 to /var/tmp/portage/dev-util/boost-build-1.34
.1/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/dev-util/boost-build-1.34.1/work/boost_
1_34_1/tools ...
###
### Using 'cc' toolset.
###
rm -rf bootstrap
mkdir bootstrap
i686-pc-linux-gnu-gcc -o bootstrap/jam0 -O2 -pipe -fno-strict-aliasing
command.c
 compile.c debug.c execunix.c expand.c fileunix.c glob.c hash.c hdrmacro.c
heade
rs.c jam.c jambase.c jamgram.c lists.c make.c make1.c newstr.c option.c parse.c 
pathunix.c pathvms.c regexp.c rules.c scan.c search.c subst.c timestamp.c
variab
le.c modules.c strings.c filesys.c builtins.c pwd.c class.c native.c
w32_getreg.
c modules/set.c modules/path.c modules/regex.c modules/property-set.c
modules/se
quence.c modules/order.c execnt.c filent.c
./bootstrap/jam0 -f build.jam --toolset=cc --toolset-root= clean
...found 1 target...
...updating 1 target...
...updated 1 target...
./bootstrap/jam0 -f build.jam --toolset=cc --toolset-root= --with-python
...found 45 targets...
...updating 2 targets...
[MKDIR] bin.linuxx86
[COMPILE] bin.linuxx86/bjam
i686-pc-linux-gnu-gcc: : No such file or directory

    "i686-pc-linux-gnu-gcc"   -o bin.linuxx86/bjam -DNDEBUG
-DOPT_HEADER_CACHE_E
XT -DOPT_GRAPH_DEBUG_EXT -DOPT_SEMAPHORE -DOPT_AT_FILES
-DOPT_FIX_TARGET_VARIABL
ES_EXT -DOPT_IMPROVED_PATIENCE_EXT -DYYSTACKSIZE=5000 -O2 -pipe
-fno-strict-alia
sing -O "" command.c compile.c debug.c expand.c glob.c hash.c hcache.c
headers.c
 hdrmacro.c jam.c jambase.c jamgram.c lists.c make.c make1.c newstr.c option.c
p
arse.c regexp.c rules.c scan.c search.c subst.c w32_getreg.c timestamp.c
variabl
e.c modules.c strings.c filesys.c builtins.c pwd.c class.c native.c
modules/set.
c modules/path.c modules/regex.c modules/property-set.c modules/sequence.c
modul
es/order.c execunix.c fileunix.c pathunix.c

...failed [COMPILE] bin.linuxx86/bjam...
...failed updating 1 target...
...updated 1 target...
# emerge --info
Portage 2.1.3.19 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.6.1-r0,
2.6.23-gentoo-r3 i686)
=================================================================
System uname: 2.6.23-gentoo-r3 i686 Genuine Intel(R) CPU T2600 @ 2.16GHz
Timestamp of tree: Wed, 13 Feb 2008 14:16:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config
/usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf
/etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/
/etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo
/etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict
unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirror.icis.pcz.pl/gentoo/"
LINGUAS="en pl jp"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress
--force --whole-file --delete --delete-after --stats --timeout=180
--exclude=/distfiles --exclude=/local --exclude=/packages
--filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://mirror.icis.pcz.pl/gentoo-portage"
USE="X X509 aac accessibility acl acpi activefilter adns alsa amr amrnb amrwb
apache2 avahi bdf berkdb bitmap-fonts bzip2 cdda cddb cdio cdparanoia cdrom
chroot cli cracklib crypt cups curl daap dbus dga doc dri dts dv dvb dvd dvdr
dvdread emacs enca encode enscript erandom examples expat fame ffmpeg fftw flac
flexresp fontconfig fortran fpx ftp gcj gdbm ggi gif glut gps gsm gtk guile hal
iconv idea imagemagick imlib ipod ipv6 isdnlog jabber jack java javascript jbig
jikes joystick jpeg jpeg2k kpathsea ladspa lcms ldap leim libcaca libsamplerate
live lzo mad matroska md5sum midi mjpeg mmx mmxext mng mono motif mp2 mp3 mpeg
mudflap musepack musicbrainz mysql nas ncurses nethack network nls no-suexec
nptl nptlonly nsplugin nvidia objc odbc ogg openal opengl openmp pam pcmcia
pcre pdf perl php pic plotutils png pnm postgres pppd pvr python quicktime
radio rar readline real reflection rle rtc rtsp sdl session shout skey slang
sndfile snmp snortsam speex spell spl sqlite srt sse sse2 ssl stream svg tcl
tcpd tetex tga theora tiff timidity tk tlen truetype truetype-fonts type1-fonts
unicode userlocales utempter v4l v4l2 vcd vhosts vidix vorbis wavpack
win32codecs wma wmf x86 xanim xinerama xml xorg xosd xpm xv xvid xvmc zlib"
ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare
dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw
multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias
auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm
authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache
dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache
filter headers include info log_config logio mem_cache mime mime_magic
negotiation rewrite setenvif speling status unique_id userdir usertrack
vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse joystick
synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780
lb216 lcdm001 mtxorb ncurses text" LINGUAS="en pl jp" USERLAND="GNU"
VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL,
LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS,
PORTDIR_OVERLAY

for ppc:

[COMPILE] bin.linuxppc/bjam
powerpc-unknown-linux-gnu-gcc: : No such file or directory

    "powerpc-unknown-linux-gnu-gcc"   -o bin.linuxppc/bjam -DNDEBUG
-DOPT_HEADER_CACHE_EXT -DOPT_GRAPH_DEBUG_EXT -DOPT_SEMAPHORE -DOPT_AT_FILES
-DOPT_FIX_TARGET_VARIABLES_EXT -DOPT_IMPROVED_PATIENCE_EXT -DYYSTACKSIZE=5000
-mcpu=7450 -mtune=7450 -O2 -pipe -maltivec -mabi=altivec -fomit-frame-pointer
-fno-strict-aliasing -fno-strict-aliasing -O "" command.c compile.c debug.c
expand.c glob.c hash.c hcache.c headers.c hdrmacro.c jam.c jambase.c jamgram.c
lists.c make.c make1.c newstr.c option.c parse.c regexp.c rules.c scan.c
search.c subst.c w32_getreg.c timestamp.c variable.c modules.c strings.c
filesys.c builtins.c pwd.c class.c native.c modules/set.c modules/path.c
modules/regex.c modules/property-set.c modules/sequence.c modules/order.c
execunix.c fileunix.c pathunix.c

...failed [COMPILE] bin.linuxppc/bjam...
...failed updating 1 target...
...updated 1 target...

# emerge --info
Portage 2.1.3.19 (default-linux/ppc/ppc32/2007.0/G4/Pegasos, gcc-4.1.2,
glibc-2.6.1-r0, 2.6.23-gentoo-r3 ppc)
=================================================================
System uname: 2.6.23-gentoo-r3 ppc 7447/7457, altivec supported
Timestamp of tree: Wed, 13 Feb 2008 17:17:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="ppc"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-mcpu=7450 -mtune=7450 -O2 -pipe -maltivec -mabi=altivec
-fomit-frame-pointer -fno-strict-aliasing"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config
/usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf
/etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/
/etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo
/etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-mcpu=7450 -mtune=7450 -O2 -pipe -maltivec -mabi=altivec
-fomit-frame-pointer -fno-strict-aliasing"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict
unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirror.icis.pcz.pl/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress
--force --whole-file --delete --delete-after --stats --timeout=180
--exclude=/distfiles --exclude=/local --exclude=/packages
--filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/xeno/ebuilds /home/xeno/doc/portage"
SYNC="rsync://mirror.icis.pcz.pl/gentoo-portage"
USE="X X509 a52 aac aalib accessibility acl activefilter adns adplug alsa
altivec amr amrnb amrwb avahi bdf berkdb bitmap-fonts bzip2 cdda cddb
cdparanoia cdrom chardet chroot cli cracklib crypt dbus doc dri dts dv dvb dvd
dvdread emacs encode erandom expat extrafilters fame ffmpeg flac flexresp
fortran ftp gdbm ggi gif gmp gpm gps graphviz gsm gtk guile hal iconv idea
imagemagick imlib ipod ipv6 isdnlog jabber jack jbig jikes joystick jpeg jpeg2k
kpathsea lcms leim libcaca libsamplerate lzo mad matroska midi mjpeg mng
modplug mono mp2 mp3 mpeg mudflap musepack musicbrainz mysql ncurses nethack
network nls nptl nptlonly nsplugin objc odbc ogg openal openexr opengl openmp
pcmcia pcre perl php pic png pnm portaudio postgres ppc pppd pulseaudio python
qt3 qt3support qt4 quicktime readline reflection rtc rtsp sdl sdl-image session
shout sid skey slang sndfile snmp snortsam speex spell spl sqlite ssl svg tcl
tcpd tetex tga theora tiff timidity tk tlen truetype truetype-fonts tta
type1-fonts unicode usb userlocales utempter v4l v4l2 vcd vidix vorbis wavpack
wma wmf x264 xanim xcb xml xorg xosd xv xvid zlib" ALSA_CARDS="via82xx"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file
hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route
share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias
authn_anon authn_dbm authn_default authn_file authz_dbm authz_default
authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs
dav_lock deflate dir disk_cache env expires ext_filter file_cache filter
headers include info log_config logio mem_cache mime mime_magic negotiation
rewrite setenvif speling status unique_id userdir usertrack vhost_alias"
ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse joystick" KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses
text" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL,
LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS,
PORTAGE_RSYNC_EXTRA_OPTS
Comment 9 Stéphane Bisinger 2008-02-13 18:41:14 UTC
I found where the problem lies, it is not tc-getCC's fault:

"x86_64-pc-linux-gnu-gcc"   -o bin.linux/bjam -DNDEBUG
-DOPT_HEADER_CACHE_EXT -DOPT_GRAPH_DEBUG_EXT -DOPT_SEMAPHORE -DOPT_AT_FILES
-DOPT_FIX_TARGET_VARIABLES_EXT -DOPT_IMPROVED_PATIENCE_EXT -DYYSTACKSIZE=5000
-O2 -pipe -march=athlon64 -fno-strict-aliasing -O "" [cfiles]

Notice that -O ""? This is what causes the problem.
Comment 10 Jeff Mitchell 2008-02-13 19:27:28 UTC
Broken here too with the same symptoms, ever since "Added python USE-flag. Adding LDFLAGS to LIBS to fix bug #209794 (see ebuild for more info)." appeared in the ChangeLog.

emerge --info:

Portage 2.1.3.19 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r3 i686)
=================================================================
System uname: 2.6.23-gentoo-r3 i686 Intel(R) Pentium(R) 4 CPU 3.40GHz
Timestamp of tree: Wed, 13 Feb 2008 15:30:04 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium4 -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -mcpu=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LINGUAS="en en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
USE="16bit 4kstacks 7zip X Xaw3d a52 aac aalib acl acpi ada addbookmarks adns aiglx aim alias alisp alsa amr ao aotuv apache2 asf asm audiofile autoipd autoreplace avahi bash-completion bcmath bcp berkdb bidi bitmap-fonts bjam bluetooth bogofilter bonjour bonobo bookmarks branding browserplugin bzip2 bzlib cairo calendar cardbus ccache cdda cddb cdio cdparanoia cdr cdrom cgi chm clearcase cli codecs commercial connectionstatus console contactnotes contentcache corba cpudetection cracklib cran crypt css ctype cups curl curlwrappers cvs d daap dbus dga dio disassembler divx divx4linux djvu dmi dnd dri dts dvb dvd dvdr dvdread effects elf emacs emboss enca encode esd exif expat exscalibar extensions extrafilters fam fame fastcgi fat fb ffmpeg fftw firefox flac fltk font-server fontconfig foomaticdb force-cgi-redirect fortran fpx freetype ftp fuse gadu galago gd gdbm gg ggi gif gimpprint glib glitz glsa glut gmail gmedia gmp gnome gnome-print gphoto2 gpm graphviz groupwise gs gsm gstreamer gtk gtkhtml h323 hal hash haskell hbci hdri highlight history howl-compat hpn httpd iconv icq icu id3 idn ieee1394 imagemagick imap imlib inkjar inode inquisitio ipf-transparent ipod ipv6 irc isdnlog jabber jack jack-tmpfs java javascript jbig jce jikes jit joystick jpeg jpeg2k kde kdeenablefinal kdrive kerberos keyring kqemu krb4 ladspa lame largeterminal lash latex lcms ldap lesstif libcaca libnotify libsamplerate live lm_sensors logitech-mouse logrotate lua lzo lzw mad maildir math matroska mbox md5sum mdnsresponder-compat meanwhile memlimit mhash midi mikmod mime mjpeg mmap mmx mmxext mng mod mono motif mozbranding mozdevelop mozilla mozsvg mozxmlterm mp3 mp4 mp4live mpeg mpeg2 mpi mplayer msn multiuser musepack musicbrainz mysql mysqli nas ncurses neXt nethack netjack network network-cron new-login nfs nls nntp nowlistening nptl nptlonly nsplugin ntlm numeric nvidia nxclient offensive ofx ogg ole on-the-fly-crypt openal openexr opengl openmp oscar oss paludis pam pam_timestamp pascal paste64 pch pcntl pcre pdf pdo-external perforce perl php physfs player plotutils plugin png pnp portaudio posix postfix postscript povray ppds pppd prediction profile pyste python qa qemu-fast qq qt3 qt3support qt4 quicktime quotes rar rdesktop readline real realmedia reflection reiserfs remote resolvconf restrict rpm rrdtool rss rtsp ruby rubytests samba sametime sasl scanner screen screenshot sdl sdl-image sdl-sound sdlaudio sensord session sharedext sharedmem shorten shout silc simplexml skey skins slp smime sms smux sndfile snmp soap sockets socks5 sound soundex speedo speex spell spl sql sqlite sqlite3 srt sse sse2 ssl startup-notification statistics stencil-buffer stream subversion svg svga sysfs sysvipc tcl tcltk tcpd tetex texteffect theora threads tidy tiff tk tokenizer toolbar tools transcode translator truetype truetype-fonts type1 type1-fonts unicode usb utempter utf8 utils v4l v4l2 vcd vhosts vidix vim vim-pager vim-syntax vim-with-x visualization vlm vorbis webdav webpresence wifi win32codecs winpopup wmf wmp wxgtk1 wxwindows x264 x86 xanim xattr xcb xchatnogtk xchattext xcomposite xface xforms xine xinerama xkb xml xmlreader xmlrpc xmlwriter xmp xorg xosd xpm xprint xscreensaver xsl xv xvid xvmc yahoo yv12 zephyr zeroconf zip zlib zsh-completion" ALSA_CARDS="intel8x0 usb-audio echo3g" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon directory" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="ati radeon vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2008-02-13 20:27:51 UTC
*** Bug 210044 has been marked as a duplicate of this bug. ***
Comment 12 Mike Nerone 2008-02-13 20:31:17 UTC
I think you probably have enough 'emerge --info' output, so I'll just say "me too".
Comment 13 Jens Mueller 2008-02-13 20:44:15 UTC
Yeah, me2.
Comment 14 George 2008-02-13 20:48:22 UTC
Same issue here.
Comment 15 James C. Georgas 2008-02-13 21:07:37 UTC
me3
Comment 16 Jakub Moc (RETIRED) gentoo-dev 2008-02-13 21:22:29 UTC
*** Bug 210050 has been marked as a duplicate of this bug. ***
Comment 17 Jaak Ristioja 2008-02-13 21:57:04 UTC
On amd64 and ~i686 machines.
Comment 18 merwan kashouty 2008-02-13 22:12:05 UTC
same here on ~i686 
Comment 19 Jeroen Roovers gentoo-dev 2008-02-13 22:14:44 UTC
Setting something innocent like LDFLAGS="--verbose" magically fixes the problem.
Comment 20 Daniel Pielmeier gentoo-dev 2008-02-13 22:30:41 UTC
Created attachment 143456 [details, diff]
corrected boost-build patch

What about the patch http://bugs.gentoo.org/attachment.cgi?id=143448 from bug #210050. I mean it works but is it the right thing to do?

PS: You have to turn the patch around, see attachment!
Comment 21 R Bar-On 2008-02-13 22:42:06 UTC
patch makes it all better!

(ie it works now)
Comment 22 David D. Huff Jr. 2008-02-14 03:06:35 UTC
What's the threshold requirement 100 bug requests? This thing never would have passed testing. It's a syntax error.
Comment 23 Mark Loeser (RETIRED) gentoo-dev 2008-02-14 03:24:07 UTC
(In reply to comment #20)
> What about the patch http://bugs.gentoo.org/attachment.cgi?id=143448 from bug
> #210050. I mean it works but is it the right thing to do?

Its better than what we have, so thanks! :)  I applied a slightly modified version of your fix.

(In reply to comment #22)
> What's the threshold requirement 100 bug requests? This thing never would have
> passed testing. It's a syntax error.
> 

Everyone makes mistakes, please have some patience.  Comments like this don't help resolve the problem.  Thanks for your understanding.
Comment 24 Seblu 2008-02-14 03:59:53 UTC
when i run emerge -NDavu --with-bdeps=y world, emerge try to rebuild boost-build and i have the same error.
Comment 25 Oldrich Jedlicka 2008-02-14 07:57:30 UTC
(In reply to comment #23)
> (In reply to comment #20)
> > What about the patch http://bugs.gentoo.org/attachment.cgi?id=143448 from bug
> > #210050. I mean it works but is it the right thing to do?
> 
> Its better than what we have, so thanks! :)  I applied a slightly modified
> version of your fix.

Not fixed, setting LIBS to empty string (LDFLAGS is empty in my case) generates the same error. The original patch correctly tested LDFLAGS for emptiness. I cannot reopen the bug, so please do it; otherwise I will create new bug report.
Comment 26 Oldrich Jedlicka 2008-02-14 08:06:55 UTC
(In reply to comment #25)
> Not fixed, setting LIBS to empty string (LDFLAGS is empty in my case) generates
> the same error. The original patch correctly tested LDFLAGS for emptiness. I
> cannot reopen the bug, so please do it; otherwise I will create new bug report.
> 

Sorry, I have to sync first. I synced slightly before the fix got commited. Now it works for me.
Comment 27 Jakub Moc (RETIRED) gentoo-dev 2008-02-15 14:37:14 UTC
*** Bug 210243 has been marked as a duplicate of this bug. ***
Comment 28 Jason McGuiness 2008-05-05 14:40:35 UTC
Why isn't this fix in portage? ALso note that on my Opteron system, v1.35 of boost-build seems to suffer from the same bug.
Comment 29 Jason McGuiness 2008-05-05 14:43:07 UTC
(In reply to comment #28)
> Why isn't this fix in portage? ALso note that on my Opteron system, v1.35 of
> boost-build seems to suffer from the same bug.
> 

Note, I re-sync'd today, and still have the issue. I also tried it on my x86-based laptop, and get the same bug. Why am I not downloading the fixed version?
Comment 30 Jason McGuiness 2008-05-05 15:16:51 UTC
Created attachment 151937 [details]
Build log on x86 of boost-build v1.34

An example of the output from my build log when trying to build boost-build..
Comment 31 Jason McGuiness 2008-05-05 15:22:18 UTC
ford ~ # emerge --info
Portage 2.1.4.4 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-tuxonice-r4 i686)
=================================================================
System uname: 2.6.24-tuxonice-r4 i686 mobile AMD Athlon(tm) XP 1600+
Timestamp of tree: Mon, 05 May 2008 14:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O3 -pipe -momit-leaf-frame-pointer 	-fomit-frame-pointer -fprefetch-loop-arrays -ffast-math 	-funroll-all-loops -funit-at-a-time -fpeel-loops -ftracer 	-funswitch-loops"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon-xp -O3 -pipe -momit-leaf-frame-pointer 	-fomit-frame-pointer -fprefetch-loop-arrays -ffast-math 	-funroll-all-loops -funit-at-a-time -fpeel-loops -ftracer 	-funswitch-loops"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict strip unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://ftp.kaist.ac.kr/pub/gentoo/ ftp://pandemonium.tiscali.de/pub/gentoo/"
LDFLAGS="-Wl,-O3 -Wl,--enable-new-dtags -Wl,--sort-common 	-Wl,--strip-all"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://eddie/gentoo-portage"
USE="3dnow 3dnowext X a52 ac3 acpi alsa ati bash-completion berkdb bzip2 cairo calendar cddb cdr cli cpudetection cpufreq cracklib crypt cups dbus dga dio dri dvd dvdread exif gdbm gif glx gpm gtk gtk2 hal hpn iconv ieee1394 imagemagick isdnlog jpeg lame latex libnotify lm_sensors loop-aes lzo midi mime mjpeg mmap mmx mmxext mp3 mpeg mplayer mtrr mudflap ncurses nls nonfsv4 nptl nptlonly ntfs ogg oggvorbis opengl openmp pam panel-plugin pch pcmcia pcre pda pdf perl pmu png posix ppds pppd python qt3 radeon rar readline real reflection rtc samba sdk sdl sensord server session sharedmem snmp sockets spell spl sse sse-filters ssl startup-notification symlink synaptics sysfs tetex thunar-vfs truetype type1 unicode utempter vorbis x86 xattr xcomposite xfce4 xine xorg xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 32 Jeroen Roovers gentoo-dev 2008-05-05 17:46:18 UTC
(In reply to comment #29)
> Note, I re-sync'd today, and still have the issue. I also tried it on my
> x86-based laptop, and get the same bug. Why am I not downloading the fixed
> version?

You did get the fixed version, only it only fixed an LDFLAGS with a single argument. With your (ridiculous) LDFLAGS (and ridiculous CFLAGS but that may be safely ignored until the next bug) another bug is triggered. It's fixed in this way (because when setting a variable like this, you don't need the quotation marks because it is not passed on the command line as an argument):

Index: boost-build-1.34.1.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.34.1.ebuild,v
retrieving revision 1.13
diff -u -B -r1.13 boost-build-1.34.1.ebuild
--- boost-build-1.34.1.ebuild   15 Mar 2008 13:45:12 -0000      1.13
+++ boost-build-1.34.1.ebuild   5 May 2008 17:42:33 -0000
@@ -64,7 +64,7 @@
                CC=$(tc-getCC) ./build.sh ${toolset} $(use_with python) \
                        || die "building bjam failed"
        else
-               LIBS="${LDFLAGS}" CC=$(tc-getCC) ./build.sh ${toolset} \
+               LIBS=${LDFLAGS} CC=$(tc-getCC) ./build.sh ${toolset} \
                        $(use_with python) || die "building bjam failed"
        fi
 }
Index: boost-build-1.35.0.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.35.0.ebuild,v
retrieving revision 1.1
diff -u -B -r1.1 boost-build-1.35.0.ebuild
--- boost-build-1.35.0.ebuild   24 Apr 2008 14:55:19 -0000      1.1
+++ boost-build-1.35.0.ebuild   5 May 2008 17:42:33 -0000
@@ -63,7 +63,7 @@
                CC=$(tc-getCC) ./build.sh ${toolset} $(use_with python) \
                        || die "building bjam failed"
        else
-               LIBS="${LDFLAGS}" CC=$(tc-getCC) ./build.sh ${toolset} \
+               LIBS=${LDFLAGS} CC=$(tc-getCC) ./build.sh ${toolset} \
                        $(use_with python) || die "building bjam failed"
        fi
 }
Comment 33 Jeroen Roovers gentoo-dev 2008-05-05 17:51:14 UTC
I committed those changes I suggested. Should be finally fixed now.
Comment 34 Jason McGuiness 2008-05-06 21:51:59 UTC
(In reply to comment #33)
> I committed those changes I suggested. Should be finally fixed now.
> 

After an "emerge --sync", and verifying that the modified ebuild had been downloaded, and verifying the contents against the comitted diff, I get exactly the same error.
Comment 35 Jason McGuiness 2008-05-06 21:53:31 UTC
(In reply to comment #34)
> (In reply to comment #33)
> > I committed those changes I suggested. Should be finally fixed now.
> > 
> 
> After an "emerge --sync", and verifying that the modified ebuild had been
> downloaded, and verifying the contents against the comitted diff, I get exactly
> the same error.
> 

Looks like my "ridiculous" LDFLAGS and CFLAGS are useful test cases...
Comment 36 Steven Elling 2008-05-07 02:59:57 UTC
Created attachment 152193 [details]
emerge info output

This still fails after performing an 'emerge --sync' today.  However, if I comment out LDFLAGS in my /etc/make.conf, boost-build-1.34.1 builds successfully.

Here is the error for completeness:

rm -rf bootstrap
mkdir bootstrap
x86_64-pc-linux-gnu-gcc -o bootstrap/jam0 -O2 -march=nocona -finline-functions -mmmx -msse -msse2 -msse3 -mfpmath=sse -w -pipe -fno-strict-aliasing -Wl,-z,now -Wl,-O1 -Wl,--sort-common -Wl,--as-needed command.c compile.c debug.c execunix.c expand.c fileunix.c glob.c hash.c hdrmacro.c headers.c jam.c jambase.c jamgram.c lists.c make.c make1.c newstr.c option.c parse.c pathunix.c pathvms.c regexp.c rules.c scan.c search.c subst.c timestamp.c variable.c modules.c strings.c filesys.c builtins.c pwd.c class.c native.c w32_getreg.c modules/set.c modules/path.c modules/regex.c modules/property-set.c modules/sequence.c modules/order.c execnt.c filent.c
./bootstrap/jam0 -f build.jam --toolset=cc --toolset-root= clean
...found 1 target...
...updating 1 target...
...updated 1 target...
./bootstrap/jam0 -f build.jam --toolset=cc --toolset-root= --with-python
...found 45 targets...
...updating 2 targets...
[MKDIR] bin.linux
[COMPILE] bin.linux/bjam
x86_64-pc-linux-gnu-gcc: : No such file or directory

    "x86_64-pc-linux-gnu-gcc"   -o bin.linux/bjam -DNDEBUG -DOPT_HEADER_CACHE_EXT -DOPT_GRAPH_DEBUG_EXT -DOPT_SEMAPHORE -DOPT_AT_FILES -DOPT_FIX_TARGET_VARIABLES_EXT -DOPT_IMPROVED_PATIENCE_EXT -DYYSTACKSIZE=5000 -O2 -march=nocona -finline-functions -mmmx -msse -msse2 -msse3 -mfpmath=sse -w -pipe -fno-strict-aliasing -O "" "-Wl,-z,now" "-Wl,-O1" "-Wl,--sort-common" "-Wl,--as-needed" command.c compile.c debug.c expand.c glob.c hash.c hcache.c headers.c hdrmacro.c jam.c jambase.c jamgram.c lists.c make.c make1.c newstr.c option.c parse.c regexp.c rules.c scan.c search.c subst.c w32_getreg.c timestamp.c variable.c modules.c strings.c filesys.c builtins.c pwd.c class.c native.c modules/set.c modules/path.c modules/regex.c modules/property-set.c modules/sequence.c modules/order.c execunix.c fileunix.c pathunix.c

...failed [COMPILE] bin.linux/bjam...
...failed updating 1 target...
...updated 1 target...
Comment 37 Jeroen Roovers gentoo-dev 2008-05-07 16:12:01 UTC
Why does your emerge --info say that LDFLAGS looks like this?

LDFLAGS="-Wl,-O3 -Wl,--enable-new-dtags -Wl,--sort-common      
-Wl,--strip-all"

Is there a newline in there in your make.conf?
Comment 38 Jason McGuiness 2008-05-09 07:02:07 UTC
(In reply to comment #36)
> Created an attachment (id=152193) [edit]
> emerge info output
> 
> This still fails after performing an 'emerge --sync' today.  However, if I
> comment out LDFLAGS in my /etc/make.conf, boost-build-1.34.1 builds
> successfully.

1. I tried totally commenting out my LDFLAGS and the package installed.
2. I tried putting anything at all in my LDFLAGS, e.g. just "--strip-all", and I got the response:

cc1: error: unrecognized command line option "-fstrip-all"

and the build failed.
Comment 39 Steven Elling 2008-05-21 06:02:35 UTC
For comment #38, you should add "-Wl,--strip-all" to LDFLAGS not "--strip-all".

# man gcc

-Wl,option
  Pass option as an option to the linker.  If option contains commas, it is split into multiple options at the commas.
-----