Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 209931 - net-im/pidgin-2.3.1: empty protocol list, when adding account
Summary: net-im/pidgin-2.3.1: empty protocol list, when adding account
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-12 22:05 UTC by Michał Ochman
Modified: 2008-02-13 17:47 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Pidgin output (pidgin_output.txt,5.72 KB, text/plain)
2008-02-12 22:06 UTC, Michał Ochman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Ochman 2008-02-12 22:05:18 UTC
After emerging Pidgin, I wanted to add an account. Unfortunatelly a protocol list is empty, so I cannot do that.

Reproducible: Always

Steps to Reproduce:
1. Go to manage account.
2. Add account.
3. Look at protocol list.
Actual Results:  
No protocols to select from.

Expected Results:  
See protocols to select from.

michoch@byq ~ $ emerge --info
Portage 2.1.4.4 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.7-r1, 2.6.24-gentoo-r2 i686)
=================================================================
System uname: 2.6.24-gentoo-r2 i686 AMD Sempron(tm)
Timestamp of tree: Tue, 12 Feb 2008 11:46:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r7, 2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="x86 ~x86"
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol"
ANT_HOME="/usr/share/ant-core"
APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status userdir unique_id usertrack vhost_alias"
ARCH="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CCACHE_DIR="/usr/ccache"
CCACHE_SIZE="3G"
CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CLASSPATH="."
CLEAN_DELAY="5"
COLORTERM="gnome-terminal"
CONFIG_PROTECT="/etc /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CVS_RSH="ssh"
CXXFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
DBUS_SESSION_BUS_ADDRESS="unix:abstract=/tmp/dbus-tkGzmFpfnb,guid=b66ecc51eca333c37ac6403a47b17152"
DESKTOP_SESSION="gnome"
DESKTOP_STARTUP_ID=""
DISPLAY=":0.0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/usr/bin/vim"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--ask --verbose"
EMERGE_WARNING_DELAY="10"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
FETCHCOMMAND="/usr/bin/wget -t 5 -T 60 --passive-ftp -O ${DISTDIR}/${FILE} ${URI}"
GCC_SPECS=""
GDK_USE_XFT="1"
GDMSESSION="gnome"
GDM_LANG="pl_PL.UTF-8"
GDM_XSERVER_LOCATION="local"
GENERATION="2"
GENTOO_MIRRORS="http://src.gentoo.pl http://gentoo.mirror.pw.edu.pl/ http://gentoo.prz.rzeszow.pl http://gentoo.zie.pg.gda.pl http://gentoo.supp.name/ http://gentoo.mirror.web4u.cz/ http://gentoo.po.opole.pl"
GNOME_DESKTOP_SESSION_ID="Default"
GNOME_KEYRING_SOCKET="/tmp/keyring-NE39y6/socket"
GTK_MODULES="gnomebreakpad"
GTK_RC_FILES="/etc/gtk/gtkrc:/home/michoch/.gtkrc-1.2-gnome2"
GUILE_LOAD_PATH="/usr/share/guile/1.8"
HOME="/home/michoch"
INFOPATH="/usr/share/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.18/info:/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/info"
INPUT_DEVICES="evdev keyboard mouse joystick"
JAVAC="/home/michoch/.gentoo/java-config-2/current-user-vm/bin/javac"
JAVA_HOME="/home/michoch/.gentoo/java-config-2/current-user-vm"
JDK_HOME="/home/michoch/.gentoo/java-config-2/current-user-vm"
KDEDIRS="/usr:/usr/local:/usr/kde/4.0"
KERNEL="linux"
LANG="pl_PL.UTF-8"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LC_ALL="pl_PL.UTF-8"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LIBGL_DRIVERS_PATH="/usr/lib/dri"
LINGUAS="pl"
LOGNAME="michoch"
LS_COLORS="no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.svgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:"
MAKEOPTS="-j2"
MANPATH="/home/michoch/.gentoo/java-config-2/current-user-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/i686-pc-linux-gnu/2.18/man:/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/man:/opt/sun-jdk-1.4.2.15/man:/etc/java-config/system-vm/man/:/usr/lib/php5/man/:/usr/kde/4.0/share/man:/usr/qt/3/doc/man:/opt/opera/share/man"
OPENGL_PROFILE="xorg-x11"
PAGER="/usr/bin/less"
PATH="/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.2:/opt/sun-jdk-1.4.2.15/bin:/opt/sun-jdk-1.4.2.15/jre/bin:/opt/sun-jdk-1.4.2.15/jre/javaws:/usr/kde/4.0/bin:/usr/qt/3/bin:/usr/games/bin"
PKGDIR="/usr/portage/packages"
PKG_CONFIG_PATH="/usr/qt/3/lib/pkgconfig"
PORTAGE_ARCHLIST="ppc s390 amd64 x86 ppc64 x86-fbsd m68k arm sparc sh mips ia64 alpha ppc-macos hppa sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib/portage/bin"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="log warn error"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save_summary echo"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_IUSE="^(alpha|alsa_cards_aoa|alsa_cards_aoa-fabric-layout|alsa_cards_aoa-onyx|alsa_cards_aoa-soundbus|alsa_cards_aoa-soundbus-i2s|alsa_cards_aoa-tas|alsa_cards_aoa-toonie|alsa_cards_armaaci|alsa_cards_at91-soc|alsa_cards_at91-soc-eti-b1-wm8731|alsa_cards_au1x00|alsa_cards_harmony|alsa_cards_powermac|alsa_cards_pxa2xx-i2sound|alsa_cards_pxa2xx-soc|alsa_cards_pxa2xx-soc-corgi|alsa_cards_pxa2xx-soc-poodle|alsa_cards_pxa2xx-soc-spitz|alsa_cards_pxa2xx-soc-tosa|alsa_cards_sa11xx-uda1341ts|alsa_cards_sun-amd7930|alsa_cards_sun-cs4231|alsa_cards_sun-dbri|altivec|amd64|aqua|arm|bmp|bmpx|bootstrap|build|coreaudio|crosscompile_opts_.*|elibc_.*|elibc_Darwin|elibc_DragonFly|elibc_FreeBSD|elibc_NetBSD|elibc_OpenBSD|elibc_glibc|elibc_uclibc|emul-linux-x86|hppa|ia64|ibm|infopipe|kernel_.*|kernel_Darwin|kernel_FreeBSD|kernel_linux|m68k|mips|mplayer-bin|multilib|n32|n64|pam_console|pbbuttonsd|ppc|ppc-macos|ppc64|ppcsha1|s390|selinux|sh|sparc|sparc-fbsd|uclibc|ultra1|userland_.*|userland_BSD|userland_Darwin|userland_GNU|video_cards_impact|video_cards_newport|video_cards_sunbw2|video_cards_suncg14|video_cards_suncg3|video_cards_suncg6|video_cards_sunffb|video_cards_sunleo|video_cards_suntcx|vis|x86|x86-fbsd|xmms)$"
PORTAGE_PYM_PATH="/usr/lib/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_USE="elibc_glibc kernel_linux userland_GNU x86"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/overlay /usr/local/portage/xeffects/trunk"
PRELINK_PATH_MASK="/usr/lib/klibc"
PWD="/home/michoch"
PYTHONPATH="/usr/lib/portage/pym"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 5 -T 60 --passive-ftp -O ${DISTDIR}/${FILE} ${URI}"
ROOT="/"
ROOTPATH="/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.1.2:/opt/sun-jdk-1.4.2.15/bin:/opt/sun-jdk-1.4.2.15/jre/bin:/opt/sun-jdk-1.4.2.15/jre/javaws:/usr/kde/4.0/sbin:/usr/kde/4.0/bin:/usr/qt/3/bin"
RPMDIR="/usr/portage/rpm"
SESSION_MANAGER="local/byq:/tmp/.ICE-unix/6850"
SHELL="/bin/bash"
SHLVL="1"
SSH_AGENT_PID="6936"
SSH_AUTH_SOCK="/tmp/ssh-ycWarX6850/agent.6850"
STAGE1_USE="nptl nptlonly unicode"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
TERM="xterm"
USE="3dnow 3dnowext X a52 aac accessibility acl acpi alsa apm arts avi bash-completion berkdb bitmap-fonts branding bzip2 cairo cdr cli cracklib crypt ctype cups dbus dri dvd dvdr dvdread ffmpeg firefox gdbm gif gnome gstreamer gtk hal iconv isdnlog java jpeg kde libnotify mad midi mime mmx mmxext mp3 mpeg mplayer mudflap ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre perl png pppd python qt qt4 quicktime readline reflection samba sasl session spl sse ssl svg tcpd theora truetype truetype-fonts type1 type1-fonts unicode vorbis x86 xml xorg xpm xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status userdir unique_id usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" USERLAND="GNU" VIDEO_CARDS="radeon vesa fglrx"
USER="michoch"
USERLAND="GNU"
USERNAME="michoch"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS APACHE2_MODULES APACHE2_MPMS CAMERAS CROSSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS INPUT_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal:env.d"
VIDEO_CARDS="radeon vesa fglrx"
VMHANDLE="sun-jdk-1.4"
WINDOWID="35654752"
WINDOWPATH="7"
XAUTHORITY="/home/michoch/.Xauthority"
XDG_DATA_DIRS="/usr/share:/usr/kde/4.0/share:/usr/local/share"
XERCESC_NLS_HOME="/usr/share/xerces-c/msg"
_="/usr/bin/emerge"
Comment 1 Michał Ochman 2008-02-12 22:06:34 UTC
Created attachment 143367 [details]
Pidgin output

Output of:
- pidgin --version
- pidgin --debug
Comment 2 nikos roussos 2008-02-12 22:54:23 UTC
i just upgrade pidgin to 2.3.1 but i can see a full protocols list to "add account" menu.

what pidgin use flags did you enable?
Comment 3 Michał Ochman 2008-02-13 13:07:19 UTC
(In reply to comment #2)
> i just upgrade pidgin to 2.3.1 but i can see a full protocols list to "add
> account" menu.
> 
> what pidgin use flags did you enable?

Pidgin USE flags are as follows:
USE="dbus gadu gstreamer gtk ncurses nls perl sasl spell -bonjour -debug -doc -eds -gnutls -groupwise -meanwhile -networkmanager -prediction -qq -silc -tcl -tk -zephyr"

Additionally, this problem also exists in 2.2.1 (stable) and 2.2.2.
Comment 4 Olivier Crete (RETIRED) gentoo-dev 2008-02-13 14:44:42 UTC
I see a segfault in the log, please post a backtrace.. And dont build with  -fomit-frame-pointer .. and try purging pidgin and re-merging it, there is something very strange on your system
Comment 5 Michał Ochman 2008-02-13 16:39:35 UTC
(In reply to comment #4)
> I see a segfault in the log, please post a backtrace.. And dont build with 
> -fomit-frame-pointer .. and try purging pidgin and re-merging it, there is
> something very strange on your system

This segfault occured after trying to add an account without protocol selected (because there were no one).

After removing all files connected to libpurple and pidgin, and then reemerging Pidgin, problem with empty protocol list disappeared and Pidgin seems to work correctly.
I thought about "ABI version mismatch 2.3.x (need 2.1.x)" and i realised, that last version of Pidgin I used was 2.1.x. I suppose old libs were not deleted when unmerging Pidgin and caused this issue.
The question is: Why emerging new version of Pidgin, these files were not overwritten by a new ones?

Anyway, thanks for help.
Comment 6 Olivier Crete (RETIRED) gentoo-dev 2008-02-13 16:58:44 UTC
They should have been overwritten, I have no idea what could have caused that (disk full maybe?)...
Comment 7 Michał Ochman 2008-02-13 17:47:13 UTC
(In reply to comment #6)
> They should have been overwritten, I have no idea what could have caused that
> (disk full maybe?)...

I have no idea, disk had a lot of free space when emerging. Pidgin compiled from source (found on pidgin.im, not from portage) worked perfectly.

I am marking this bug as closed (and also I have changed resolution to invalid.)