Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 209381 - sys-fs/lvm2-2.02.33 build fails with DM_READ_AHEAD_AUTO undeclared
Summary: sys-fs/lvm2-2.02.33 build fails with DM_READ_AHEAD_AUTO undeclared
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Doug Goldstein
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-08 19:28 UTC by Tiger!P
Modified: 2008-02-09 06:57 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info of my system (emerge_info.txt,3.93 KB, text/plain)
2008-02-08 19:53 UTC, Tiger!P
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tiger!P 2008-02-08 19:28:00 UTC
When I tried to emerge lvm2-2.02.33 I got an error during compilation:

x86_64-pc-linux-gnu-gcc -c -I../include -I/var/tmp/portage/sys-fs/lvm2-2.02.33/work/LVM2.2.02.33//include -DHAVE_CONFIG_H -march=athlon64 -O3 -pipe -march=athlon64 -O3 -pipe -fPIC -Wall -Wundef -Wshadow -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -Wmissing-noreturn -Wformat-security -O2 -march=athlon64 -O3 -pipe -fPIC -Wall -Wundef -Wshadow -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -Wmissing-noreturn -Wformat-security -O2 datastruct/btree.c -o datastruct/btree.o
x86_64-pc-linux-gnu-gcc -c -I../include -I/var/tmp/portage/sys-fs/lvm2-2.02.33/work/LVM2.2.02.33//include -DHAVE_CONFIG_H -march=athlon64 -O3 -pipe -march=athlon64 -O3 -pipe -fPIC -Wall -Wundef -Wshadow -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -Wmissing-noreturn -Wformat-security -O2 -march=athlon64 -O3 -pipe -fPIC -Wall -Wundef -Wshadow -Wcast-align -Wwrite-strings -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -Wmissing-noreturn -Wformat-security -O2 datastruct/list.c -o datastruct/list.o
commands/toolcontext.c: In function ‘_process_config’:
commands/toolcontext.c:213: error: ‘DM_READ_AHEAD_AUTO’ undeclared (first use in this function)
commands/toolcontext.c:213: error: (Each undeclared identifier is reported only once
commands/toolcontext.c:213: error: for each function it appears in.)
commands/toolcontext.c:215: error: ‘DM_READ_AHEAD_NONE’ undeclared (first use in this function)
make[1]: *** [commands/toolcontext.o] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/portage/sys-fs/lvm2-2.02.33/work/LVM2.2.02.33/lib'
make: *** [lib] Error 2
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2008-02-08 19:43:22 UTC
emerge --info please
Comment 2 Tiger!P 2008-02-08 19:53:22 UTC
Created attachment 143004 [details]
emerge --info of my system

The emerge --info that I used during the emerging of lvm2.
I also tried without the MAKEOPTS=-j2, but that didn't make any difference.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2008-02-08 20:11:05 UTC
Noone will notice if you don't reopen the bug.
Comment 4 Doug Goldstein gentoo-dev 2008-02-08 20:36:40 UTC
hmm. Portage should have merged in a newer device-mapper first. Either way, I've updated the depend in lvm2.
Comment 5 Tiger!P 2008-02-08 20:50:03 UTC
I did a `emerge --sync&& emerge -av world`, but I don't see a new sys-fs/device-mapper in the list.
I see that there is a new (1.02.24) sys-fs/device-mapper when I do a `emerge -s device-mapper`.
So I hope that your change in the ebuild will add the new device-mapper to the list when I do a `emerge -av world`.
When it does I will close the bug.
Comment 6 Doug Goldstein gentoo-dev 2008-02-08 20:57:17 UTC
emerge -auDNv world, should always use deep depends.
Comment 7 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2008-02-08 23:48:12 UTC
yeah, it should have been in the DEPEND. Sorry.
Comment 8 Tiger!P 2008-02-09 06:57:10 UTC
The change in the ebuild fixed the problem indeed.
Bug closed.