Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 208949 - app-misc/mc-4.6.1-r4 fails on ppc64 due to umode_t clash
Summary: app-misc/mc-4.6.1-r4 fails on ppc64 due to umode_t clash
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: PPC64 Linux
: High normal (vote)
Assignee: ppc64 architecture team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-04 23:38 UTC by GES
Modified: 2009-08-05 11:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/usr/tmp/portage/app-misc/mc-4.6.1-r4/work/mc-4.6.1/config.log (config.log,177.90 KB, text/plain)
2008-02-04 23:51 UTC, GES
Details
/var/log/portage/app-misc_mc-4.6.1-r4_20080217-223157.log (app-misc_mc-4.6.1-r4_20080217-223157.log,34.40 KB, text/plain)
2008-02-17 22:47 UTC, GES
Details
/var/tmp/portage/app-misc/mc-4.6.1-r4/temp/environment (environment,92.42 KB, text/plain)
2008-02-17 23:08 UTC, GES
Details

Note You need to log in before you can comment on or make changes to this bug.
Description GES 2008-02-04 23:38:55 UTC
When I'm emerging app-misc/mc-4.6.1-r4 then doesn't emerged it.

Reproducible: Always

Steps to Reproduce:
# emerge mc -atv
Actual Results:  
These are the packages that would be merged, in reverse order:
Calculating dependencies... done!
[ebuild   R   ] app-misc/mc-4.6.1-r4  USE="gpm ncurses nls pam samba* slang unicode -7zip -X" 0 kB
Total: 1 package (1 reinstall), Size of downloads: 0 kB
Would you like to merge these packages? [Yes/No]

Expected Results:  
In file included from dcigettext.c:27:
../config.h:638:1: warning: "_GNU_SOURCE" redefined
dcigettext.c:23:1: warning: this is the location of the previous definition
In file included from /usr/include/asm/elf.h:5,
                 from /usr/include/asm/sigcontext.h:12,
                 from /usr/include/bits/sigcontext.h:28,
                 from /usr/include/signal.h:333,
                 from dcigettext.c:78:
/usr/include/asm/types.h:20: error: two or more data types in declaration specifiers
make[2]: *** [dcigettext.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/app-misc/mc-4.6.1-r4/work/mc-4.6.1/intl'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-misc/mc-4.6.1-r4/work/mc-4.6.1'
make: *** [all] Error 2
 *
 * ERROR: app-misc/mc-4.6.1-r4 failed.
 * Call stack:
 *            ebuild.sh, line 1701:  Called dyn_compile
 *            ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *            ebuild.sh, line   44:  Called src_compile
 *   mc-4.6.1-r4.ebuild, line  114:  Called die
 * The specific snippet of code:
 *      emake || die "emake failed"
 *  The die message:
 *   emake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/app-misc:mc-4.6.1-r4:20080204-231823.log'.
 *

 * Messages for package app-misc/mc-4.6.1-r4:

 *
 * ERROR: app-misc/mc-4.6.1-r4 failed.
 * Call stack:
 *            ebuild.sh, line 1701:  Called dyn_compile
 *            ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *            ebuild.sh, line   44:  Called src_compile
 *   mc-4.6.1-r4.ebuild, line  114:  Called die
 * The specific snippet of code:
 *      emake || die "emake failed"
 *  The die message:
 *   emake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/app-misc:mc-4.6.1-r4:20080204-231823.log'.
 *

huinfoppc64 / # emerge --info
Portage 2.1.3.19 (default-linux/ppc/ppc64/2007.0/64bit-userland/power5, gcc-4.1.2, glibc-2.6.1-r0, 2.6.19-gentoo-r5-ibm ppc64)
=================================================================
System uname: 2.6.19-gentoo-r5-ibm ppc64 POWER5 (gr)
Timestamp of tree: Mon, 04 Feb 2008 01:47:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p17-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.61-r1
sys-devel/automake:  1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="ppc64"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol"
APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias"
ARCH="ppc64"
AUTOCLEAN="yes"
CBUILD="powerpc64-unknown-linux-gnu"
CDEFINE_ppc64="__powerpc64__"
CFLAGS="-O2 -pipe -mcpu=power5 -mtune=power5"
CFLAGS_ppc64="-m64"
CHOST="powerpc64-unknown-linux-gnu"
CHOST_ppc64="powerpc64-unknown-linux-gnu"
CLEAN_DELAY="5"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CVS_RSH="ssh"
CXXFLAGS="-O2 -pipe -mcpu=power5 -mtune=power5"
DEFAULT_ABI="ppc64"
DISTDIR="/usr/portage/distfiles"
EDITOR="/bin/nano"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="-atv"
EMERGE_WARNING_DELAY="10"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
FETCHCOMMAND="/usr/bin/wget -t 5 -T 60 --passive-ftp -O ${DISTDIR}/${FILE} ${URI}"
GCC_SPECS=""
GENTOO_MIRRORS="http://gentoo.inf.elte.hu/ http://gentoo.inode.at/ http://gentoo.osuosl.org/"
HISTCONTROL="ignorespace"
HOME="/root"
HTTP_PROXY="http://localhost:5865"
INFOPATH="/usr/share/info:/usr/share/binutils-data/powerpc64-unknown-linux-gnu/2.18/info:/usr/share/gcc-data/powerpc64-unknown-linux-gnu/4.1.2/info"
INPUT_DEVICES="keyboard mouse evdev"
KERNEL="linux"
LANG="hu_HU.UTF-8"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LC_ALL="hu_HU.UTF-8"
LDFLAGS_ppc64="-m elf64ppc"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LIBDIR_ppc64="lib64"
LINGUAS="hu en"
LOGNAME="root"
LS_COLORS="no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:"
MAKEOPTS="-j5"
MANPATH="/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/powerpc64-unknown-linux-gnu/2.18/man:/usr/share/gcc-data/powerpc64-unknown-linux-gnu/4.1.2/man:/usr/lib64/php5/man/"
MC_SID="6301"
MC_TMPDIR="/tmp/mc-root"
MULTILIB_ABIS="ppc64"
MULTILIB_STRICT_DENY="64-bit.*shared object"
MULTILIB_STRICT_DIRS="/lib /usr/lib /usr/kde/*/lib /usr/qt/*/lib /usr/X11R6/lib"
MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|eclipse-3)"
OLDPWD="/bin"
PAGER="/usr/bin/less"
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/powerpc64-unknown-linux-gnu/gcc-bin/4.1.2"
PKGDIR="/usr/portage/packages"
PORTAGE_ARCHLIST="ppc s390 amd64 x86 ppc64 x86-fbsd m68k arm sparc sh mips ia64 alpha ppc-macos hppa sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib64/portage/bin"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="log warn error"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save_summary echo"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_PYM_PATH="/usr/lib64/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PORT_LOGDIR="/var/log/portage"
PWD="/"
PYTHONPATH="/usr/lib64/portage/pym"
RESUMECOMMAND="/usr/bin/wget -c -t 5 -T 60 --passive-ftp -O ${DISTDIR}/${FILE} ${URI}"
ROOT="/"
ROOTPATH="/opt/bin:/usr/powerpc64-unknown-linux-gnu/gcc-bin/4.1.2"
RPMDIR="/usr/portage/rpm"
SHELL="/bin/bash"
SHLVL="4"
SSH_CLIENT="172.16.3.205 1516 22"
SSH_CONNECTION="172.16.3.205 1516 172.16.3.240 22"
SSH_TTY="/dev/pts/0"
STAGE1_USE="unicode nptl nptlonly"
STY="6272.pts-0.huinfoppc64"
SYMLINK_LIB="yes"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
TERM="screen"
TERMCAP="SC|screen|VT 100/ANSI X3.64 virtual terminal:\
        :DO=\E[%dB:LE=\E[%dD:RI=\E[%dC:UP=\E[%dA:bs:bt=\E[Z:\
        :cd=\E[J:ce=\E[K:cl=\E[H\E[J:cm=\E[%i%d;%dH:ct=\E[3g:\
        :do=^J:nd=\E[C:pt:rc=\E8:rs=\Ec:sc=\E7:st=\EH:up=\EM:\
        :le=^H:bl=^G:cr=^M:it#8:ho=\E[H:nw=\EE:ta=^I:is=\E)0:\
        :li#45:co#126:am:xn:xv:LP:sr=\EM:al=\E[L:AL=\E[%dL:\
        :cs=\E[%i%d;%dr:dl=\E[M:DL=\E[%dM:dc=\E[P:DC=\E[%dP:\
        :im=\E[4h:ei=\E[4l:mi:IC=\E[%d@:ks=\E[?1h\E=:\
        :ke=\E[?1l\E>:vi=\E[?25l:ve=\E[34h\E[?25h:vs=\E[34l:\
        :ti=\E[?1049h:te=\E[?1049l:us=\E[4m:ue=\E[24m:so=\E[3m:\
        :se=\E[23m:mb=\E[5m:md=\E[1m:mr=\E[7m:me=\E[m:ms:\
        :Co#8:pa#64:AF=\E[3%dm:AB=\E[4%dm:op=\E[39;49m:AX:\
        :vb=\Eg:G0:as=\E(0:ae=\E(B:\
        :ac=\140\140aaffggjjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~..--++,,hhII00:\
        :po=\E[5i:pf=\E[4i:Z0=\E[?3h:Z1=\E[?3l:k0=\E[10~:\
        :k1=\EOP:k2=\EOQ:k3=\EOR:k4=\EOS:k5=\E[15~:k6=\E[17~:\
        :k7=\E[18~:k8=\E[19~:k9=\E[20~:k;=\E[21~:F1=\E[23~:\
        :F2=\E[24~:F3=\E[2P:F4=\E[2Q:F5=\E[2R:F6=\E[2S:\
        :F7=\E[15;2~:F8=\E[17;2~:F9=\E[18;2~:FA=\E[19;2~:kb=^H:\
        :K2=\EOE:kB=\E[Z:kF=\E[1;2B:kR=\E[1;2A:*4=\E[3;2~:\
        :*7=\E[1;2F:#2=\E[1;2H:#3=\E[2;2~:#4=\E[1;2D:%c=\E[6;2~:\
        :%e=\E[5;2~:%i=\E[1;2C:kh=\E[1~:@1=\E[1~:kH=\E[4~:\
        :@7=\E[4~:kN=\E[6~:kP=\E[5~:kI=\E[2~:kD=\E[3~:ku=\EOA:\
        :kd=\EOB:kr=\EOC:kl=\EOD:km:"
USE="acl apache2 bash-completion berkdb bitmap-fonts bzip2 cdinstall cli cracklib crypt ctype dedicated dri fortran gd gdbm gpm ibm iconv ipv6 isdnlog kerberos ldap midi mudflap mysql ncurses nls nptl nptlonly odbc openmp pam pcre perl php postgres ppc64 pppd python readline reflection samba session slang spl sqlite sqlite3 ssl swat tcpd threads truetype-fonts type1-fonts unicode vhosts xml xorg zip zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="hu en" USERLAND="GNU" VIDEO_CARDS="dummy fbdev mach64 mga nv r128 radeon vega"
USER="root"
USERLAND="GNU"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS APACHE2_MODULES APACHE2_MPMS CAMERAS CROSSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS INPUT_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal:env.d"
VIDEO_CARDS="dummy fbdev mach64 mga nv r128 radeon vega"
WINDOW="0"
XARGS="xargs -r"
_="/usr/bin/emerge"

huinfoppc64 / # uname -a
Linux huinfoppc64 2.6.19-gentoo-r5-ibm #1 SMP Tue May 8 23:42:19 UTC 2007 ppc64 POWER5 (gr) CHRP IBM,9111-520 GNU/Linux
Comment 1 GES 2008-02-04 23:51:15 UTC
Created attachment 142690 [details]
/usr/tmp/portage/app-misc/mc-4.6.1-r4/work/mc-4.6.1/config.log
Comment 2 SpanKY gentoo-dev 2008-02-17 09:59:01 UTC
please post a full build log as an attachment
Comment 3 GES 2008-02-17 22:47:57 UTC
Created attachment 143829 [details]
/var/log/portage/app-misc_mc-4.6.1-r4_20080217-223157.log
Comment 4 GES 2008-02-17 23:08:23 UTC
Created attachment 143830 [details]
/var/tmp/portage/app-misc/mc-4.6.1-r4/temp/environment
Comment 5 SpanKY gentoo-dev 2008-02-18 05:17:42 UTC
only shows up on ppc64 due to how its kernel headers pull things in

mc should be smarter about umode_t detection
Comment 6 SpanKY gentoo-dev 2008-02-18 09:38:55 UTC
it just happens to currently trigger on ppc64 ... it could easily show up on other arches at other times

mc needs to clean up its handling of umode_t
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2008-02-18 09:51:11 UTC
(In reply to comment #6)
> it just happens to currently trigger on ppc64 ... it could easily show up on
> other arches at other times

This thing lacks a manintainer; if ppc64 folks are not interested in fixing it, it's going to end up rotting in bugzilla. Shrug.
Comment 8 GES 2008-03-05 22:40:56 UTC
This already your case, I am not skilled at this. 
If I can help with something call me.
Comment 9 Ulenrich 2008-04-04 17:36:02 UTC
(In reply to comment #8)
This file will compile - proofed on ps3/cell:
http://ftp.gnu.org/gnu/mc/mc-4.6.2-pre1.tar.gz

In the TODO the maintainers writing a lot of future 64bit support
Comment 10 GES 2008-06-05 08:44:24 UTC
(In reply to comment #9)
Unstable app-misc/mc-4.6.2_pre1 good work!
According to me stable on the ppc64!
Thx!
Comment 11 Samuli Suominen gentoo-dev 2008-12-15 22:13:22 UTC
ppc64, you can stable 4.6.2_pre1 but be noted that it also comes with a huge patchset uploaded into our mirrors, and I still have a lot of bugs unreviewed. upstream is missing in action.

so if you do mark this version stable, i'll simply do a revision bump when i'm reviewed and applied the other patches pending..
Comment 12 Samuli Suominen gentoo-dev 2009-04-30 14:17:34 UTC
Reassign to arch team.. please do since you need it asap..
Comment 13 Samuli Suominen gentoo-dev 2009-08-02 14:40:11 UTC
4.7.0_pre1 is in tree finally, managed to drop the huge patchset, ...

let's aim for that in 30 days