Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 208703 - app-office/openoffice-2.3.1-r1 fails emerge with error; You need a patched ICU with this function public:
Summary: app-office/openoffice-2.3.1-r1 fails emerge with error; You need a patched IC...
Status: RESOLVED DUPLICATE of bug 208699
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-03 08:46 UTC by Robert Golding
Modified: 2008-02-03 09:57 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Golding 2008-02-03 08:46:16 UTC
My machine though AMD64 is compiled to 32bit (i686)
When updating after emerge --sync, openoffice-2.3.1-r1 required new package dev-libs/icu and then update OOo from 2.3.1 to 2.3.1-r1.  I could see in the ebuilds ChangeLog to explain requiring these Unicode components to be external from bug#208001

The emerge failed at the second part of install, when checking validity of external patches, the stopped on message;
>You need a patched ICU with this function public:<

Q? Is this really part of Bug# 208001?  Search didn't bring that bug up, I only found it when checking the Chnagelog




Reproducible: Always

Steps to Reproduce:
1.emerge -auv openoffice
2.emerge fails on needed patch?
3.

Actual Results:  
checking for gencmn... /usr/sbin/gencmn
checking ICU version... OK
checking whether setBreakType is public... configure: error: no. You need a patched ICU with this function public:
make: *** [stamp/build] Error 1
 * 
 * ERROR: app-office/openoffice-2.3.1-r1 failed.
 * Call stack:
 *               ebuild.sh, line   46:  Called src_compile
 *             environment, line 5357:  Called die
 * The specific snippet of code:
 *       make || die "Build failed"
 *  The die message:
 *   Build failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-office/openoffice-2.3.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/openoffice-2.3.1-r1/temp/environment'.
 * 
!!! When you file a bug report, please include the following information:
GENTOO_VM=sun-jdk-1.4  CLASSPATH="" JAVA_HOME="/opt/sun-jdk-1.4.2.16"
JAVACFLAGS="-source 1.4 -target 1.4" COMPILER=""
and of course, the output of emerge --info

Expected Results:  
Updated OOo

one rob # emerge --info
Portage 2.1.4.1 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo i686)
=================================================================
System uname: 2.6.24-gentoo i686 AMD Athlon(tm) 64 X2 Dual Core Processor 5600+
Timestamp of tree: Sat, 02 Feb 2008 21:30:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.isp.net.au/ftp/pub/gentoo http://ftp.swin.edu.au/gentoo http://distfiles.gentoo.org http://gentoo.osuosl.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_AU.UTF-8"
LC_ALL="en_AU.UTF-8"
LINGUAS="en en_AU"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/gfxboot_overlay /usr/portage/local/layman/armagetron /usr/portage/local/layman/gimpel /usr/portage/local/layman/voyageur /usr/portage/local/layman/berkano /usr/portage/local/layman/desktop-effects"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib acl alsa arts asf audacious avi bash-completion berkdb bitmap-fonts bonobo browserplugin bzip2 bzlib cairo cdparanoia cdr cli cracklib crypt cups dca dlloader dri dv dvd dvdr dvdread eds emboss encode esd fam ffmpeg firefox flac fortran freetype gdbm gif gimp glitz gnome gpm gstreamer gtk gtk2 hal iconv imlib imlib2 isdnlog java javascript jpeg kde ldap libg++ mad midi mikmod mjpeg mmx mmxext mp3 mpeg mpg mplayer mudflap ncurses nls nptl nptlonly nsplugin nvidia offensive ogg opengl openmp oss pam pcre pdf pdflib perl png ppds pppd print python qt3 qt4 quicktime readline real reflection remote sane scanner sdl session smp spell spl sse ssl svg svga tcpd tga tiff totem truetype truetype-fonts type1-fonts udev unicode usb v4l v4l2 vcd vorbis win32codecs wmf wmv x86 xine xml xorg xsane xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_AU" USERLAND="GNU" VIDEO_CARDS="nvidia nv v4l vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2008-02-03 08:47:38 UTC
Do not mix unstable ebuilds with stable deps.

*** This bug has been marked as a duplicate of bug 208699 ***
Comment 2 Robert Golding 2008-02-03 09:57:12 UTC
(In reply to comment #1)
> Do not mix unstable ebuilds with stable deps.
Sorry, didn't realise (totally forgot) OOo was keyworded. 

> 
> *** This bug has been marked as a duplicate of bug 208699 ***
>