Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 208691 - media-libs/{libdvdread,xine-lib} can't play DVDs with DVD-Movie-Protect
Summary: media-libs/{libdvdread,xine-lib} can't play DVDs with DVD-Movie-Protect
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: media-video herd
URL: http://tobias.rautenkranz.ch/libdvdre...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-03 04:15 UTC by Sebastian Krueger
Modified: 2012-01-28 04:49 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fixes xine-lib (xine-lib-1.1.10-libdvdread_udf.patch,3.45 KB, patch)
2008-02-03 04:18 UTC, Sebastian Krueger
Details | Diff
fixes libdvdread (libdvdread-0.9.7_udf.patch,3.28 KB, patch)
2008-02-03 04:19 UTC, Sebastian Krueger
Details | Diff
fixes libdvdnav (libdvdnav-0.1.10-udf.patch,2.64 KB, patch)
2008-10-23 17:17 UTC, Peter Große
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Krueger 2008-02-03 04:15:56 UTC
There are some DVDs which can not be played by a DVD player using libdvdread, like e.g. VLC. This is due to the defective UDF file system produced by the copy protection DVD-Movie-Protect.

Reproducible: Always

Steps to Reproduce:
1.start xine
2. try to play a DVD-Movie-Protect'ed move
3. xine will crash




As this is german-based copy protection, this will only apply to very few dvds, but never the less, should be fixed.

see: http://tobias.rautenkranz.ch/libdvdread_ifo.html
Comment 1 Sebastian Krueger 2008-02-03 04:18:26 UTC
Created attachment 142570 [details, diff]
fixes xine-lib
Comment 2 Sebastian Krueger 2008-02-03 04:19:38 UTC
Created attachment 142572 [details, diff]
fixes libdvdread

taken directly from:
http://tobias.rautenkranz.ch/libdvdread_ifo.html
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2008-02-03 07:56:30 UTC
Have you submitted those patches upstream?
Comment 4 Sebastian Krueger 2008-02-03 11:29:01 UTC
no, I only attached them to this bug report.
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2008-03-19 15:05:34 UTC
Finally! I've waited for such patches for quite a while now.
Applied both patches to latest ~x86 packages in portage and they seem to work. I was able to watch Disney's "Ratatouille" (german version) and "7 Zwerge - der Wald ist nicht genug" with these patches in VLC and kaffeine (xine-lib).
Sebastian, IIRC Gentoo policy says to send such patches to the corresponding upstream maintainers and wait for their approval before they get included into portage. Could you try to do that? Maybe it's not even necessary regarding the patch from debian.
Comment 6 Peter Große 2008-10-23 17:17:27 UTC
Created attachment 169596 [details, diff]
fixes libdvdnav

the attachted patch fixes the libdvdread included in libdvdnav used by players like VLC
Comment 7 Lars Wendler (Polynomial-C) gentoo-dev 2008-12-19 21:11:27 UTC
Unfortunately, libdvd{nav,read}-4.1.3 still suffer from the same problem and judging from a quick try, the patches submitted here don't apply anymore. Has someone worked on updated patches?
Comment 8 Daniel Pinto dos Santos 2009-05-04 22:18:16 UTC
Just found this bug-report, as I'm having the same problems, I think.
Could someone just describe how to easily apply the patches to the sources?
Couldn't someone write an ebuild, that users could at least download from here?

Thanks!
Comment 9 Samuli Suominen gentoo-dev 2012-01-28 04:49:52 UTC
Try libdvdread-4.2.0, libdvdnav-4.2.0, xine-lib-1.2.0. Reopen if this is still a issue.