Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 208643 - gnustep-libs/rigs-0.2.2.20050714-r1 symbol lookup error
Summary: gnustep-libs/rigs-0.2.2.20050714-r1 symbol lookup error
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gnustep herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-02 21:55 UTC by M. Edward Borasky
Modified: 2008-02-18 23:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (info.txt,4.12 KB, text/plain)
2008-02-02 21:56 UTC, M. Edward Borasky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description M. Edward Borasky 2008-02-02 21:55:43 UTC
I just installed gnustep-libs/rigs-0.2.2.20050714-r1. I tried to run the example, /usr/GNUstep/System/Library/Documentation/RIGS/Examples/Base/Simple.rb. I had to edit the first line to point to the right Ruby interpreter, but it crashes like this:

$ ruby Simple.rb 
ruby: symbol lookup error: /usr/lib64/ruby/site_ruby/1.8/x86_64-linux/librigs.so: undefined symbol: _gnu_process_args

I'm guessing this is upstream, but it might be a missing dependency in the rigs ebuild.

emerge --info will be attached shortly.
Comment 1 M. Edward Borasky 2008-02-02 21:56:24 UTC
Created attachment 142542 [details]
emerge --info
Comment 2 Bernard Cafarelli gentoo-dev 2008-02-07 17:02:03 UTC
I've added rigs-0.2.2.20061009 (despite the snapshot date difference, there was only one commit in the SVN tree in the meantime). This solves the "undefined symbol" problem, but:

Rigs Version : 0.2.2
zsh: abort      ruby Simple.rb

This one is probably for upstream now
Comment 3 Bernard Cafarelli gentoo-dev 2008-02-18 23:46:42 UTC
The undefined symbol problem is solved, closing this one.