Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 208641 - media-video/mplayer X-Protect patch
Summary: media-video/mplayer X-Protect patch
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-02 21:28 UTC by Tim Taubert
Modified: 2008-02-15 17:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
mplayer-1.0_rc2_p24929-r3.ebuild (mplayer-1.0_rc2_p24929-r3.ebuild,15.28 KB, text/plain)
2008-02-02 21:31 UTC, Tim Taubert
Details
mplayer-1.0_rc2_p24929-movie-protect.patch (mplayer-1.0_rc2_p24929-movie-protect.patch,2.70 KB, patch)
2008-02-02 21:32 UTC, Tim Taubert
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Taubert 2008-02-02 21:28:41 UTC
I tried to watch the dvd "Bourne Ultimatum" with mplayer but didn't succeed because it's protected by Universal's "Movie Protect" (or "X-Protect"). After some google research I found a patch that does it for me. Couldn't that one be included? :)

Reproducible: Always
Comment 1 Tim Taubert 2008-02-02 21:31:23 UTC
Created attachment 142539 [details]
mplayer-1.0_rc2_p24929-r3.ebuild

The new adapted ebuild.
Comment 2 Tim Taubert 2008-02-02 21:32:23 UTC
Created attachment 142540 [details, diff]
mplayer-1.0_rc2_p24929-movie-protect.patch

The patch for "Movie Protect".
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2008-02-02 21:34:28 UTC
Such patches generally belong upstream, not to distributions. Also please do not attach huge ebuilds if all you changed is one line, we have unified diffs for that. ;)