Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 208626 - media-tv/mythtv-0.20.2_p15634 fails to build because of --as-needed
Summary: media-tv/mythtv-0.20.2_p15634 fails to build because of --as-needed
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Television related Applications in Gentoo's Portage
Depends on:
Blocks: as-needed
  Show dependency tree
Reported: 2008-02-02 19:35 UTC by Patrizio Bassi
Modified: 2008-02-04 04:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

build log (build.log,655.93 KB, text/plain)
2008-02-02 19:37 UTC, Patrizio Bassi

Note You need to log in before you can comment on or make changes to this bug.
Description Patrizio Bassi 2008-02-02 19:35:40 UTC
as i'm seeing lots of bug report for mythtv svn build, does it make sense to have in ~ branch?

g++ -c -pipe -march=nocona -Wall -W -O3 -Wall -Wno-switch -fomit-frame-pointer -D_REENTRANT  -DMMX -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr\" -DLIBDIR=\"/usr/lib64\" -DUSING_XV -DUSING_XVMC -DUSING_XVMC_VLD -DUSING_XRANDR -DUSING_OPENGL_VSYNC -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/qt/3/mkspecs/linux-g++ -I/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/work/mythtv-0.20.2/programs/mythfrontend -I/usr/include -I/usr/X11R6/include -I../.. -I../../libs -I../../libs/libmyth -I../../libs/libmythtv -I../../libs/libavutil -I../../libs/libavformat -I../../libs/libavcodec -I../../libs/libmythupnp -I../../libs/libmythui -I../../libs/libmythlivemedia -I/usr/qt/3/include -I/usr/X11R6/include -I/usr/X11R6/include -o moc_manualbox.o moc_manualbox.cpp
g++ -c -pipe -march=nocona -Wall -W -O3 -Wall -Wno-switch -fomit-frame-pointer -D_REENTRANT  -DMMX -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr\" -DLIBDIR=\"/usr/lib64\" -DUSING_XV -DUSING_XVMC -DUSING_XVMC_VLD -DUSING_XRANDR -DUSING_OPENGL_VSYNC -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/qt/3/mkspecs/linux-g++ -I/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/work/mythtv-0.20.2/programs/mythfrontend -I/usr/include -I/usr/X11R6/include -I../.. -I../../libs -I../../libs/libmyth -I../../libs/libmythtv -I../../libs/libavutil -I../../libs/libavformat -I../../libs/libavcodec -I../../libs/libmythupnp -I../../libs/libmythui -I../../libs/libmythlivemedia -I/usr/qt/3/include -I/usr/X11R6/include -I/usr/X11R6/include -o moc_playbackbox.o moc_playbackbox.cpp
g++ -Wl,-O1 -Wl,--sort-common -Wl,--enable-new-dtags -Wl,--as-needed -Wl,--hash-style=both -o mythbackend version.o autoexpire.o encoderlink.o filetransfer.o httpstatus.o main.o mainserver.o playbacksock.o scheduler.o server.o housekeeper.o upnpcdstv.o upnpcdsmusic.o upnpcdsvideo.o mediaserver.o mythxml.o moc_mainserver.o moc_server.o   -L/usr/qt/3/lib64 -L../../libs/libmyth -L../../libs/libmythtv -L../../libs/libavutil -L../../libs/libavcodec -L../../libs/libavformat -L../../libs/libmythfreemheg -L../../libs/libmythui -L../../libs/libmythupnp -L../../libs/libmythlivemedia -lmythtv-0.20.2 -lmythavformat-0.20.2 -lmythavutil-0.20.2 -lmythavcodec-0.20.2 -lmythfreemheg-0.20.2 -lmythupnp-0.20.2 -lmythlivemedia-0.20.2 -lmyth-0.20.2 -lmythui-0.20.2 -lfreetype -lmp3lame -lasound -ljack -L/usr/X11R6/lib64 -lXinerama -lXv -lXxf86vm -lXrandr -lXvMCW -lXvMC -lsensors -lqt-mt -lGLU -lGL -lXmu -lXext -lX11 -lm -lpthread
g++ -c -pipe -march=nocona -Wall -W -O3 -Wall -Wno-switch -fomit-frame-pointer -D_REENTRANT  -DMMX -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr\" -DLIBDIR=\"/usr/lib64\" -DUSING_XV -DUSING_XVMC -DUSING_XVMC_VLD -DUSING_XRANDR -DUSING_OPENGL_VSYNC -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/qt/3/mkspecs/linux-g++ -I/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/work/mythtv-0.20.2/programs/mythfrontend -I/usr/include -I/usr/X11R6/include -I../.. -I../../libs -I../../libs/libmyth -I../../libs/libmythtv -I../../libs/libavutil -I../../libs/libavformat -I../../libs/libavcodec -I../../libs/libmythupnp -I../../libs/libmythui -I../../libs/libmythlivemedia -I/usr/qt/3/include -I/usr/X11R6/include -I/usr/X11R6/include -o moc_viewscheduled.o moc_viewscheduled.cpp
make[2]: Leaving directory `/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/work/mythtv-0.20.2/programs/mythbackend'
g++ -c -pipe -march=nocona -Wall -W -O3 -Wall -Wno-switch -fomit-frame-pointer -D_REENTRANT  -DMMX -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr\" -DLIBDIR=\"/usr/lib64\" -DUSING_XV -DUSING_XVMC -DUSING_XVMC_VLD -DUSING_XRANDR -DUSING_OPENGL_VSYNC -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/qt/3/mkspecs/linux-g++ -I/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/work/mythtv-0.20.2/programs/mythfrontend -I/usr/include -I/usr/X11R6/include -I../.. -I../../libs -I../../libs/libmyth -I../../libs/libmythtv -I../../libs/libavutil -I../../libs/libavformat -I../../libs/libavcodec -I../../libs/libmythupnp -I../../libs/libmythui -I../../libs/libmythlivemedia -I/usr/qt/3/include -I/usr/X11R6/include -I/usr/X11R6/include -o moc_manualschedule.o moc_manualschedule.cpp
g++ -c -pipe -march=nocona -Wall -W -O3 -Wall -Wno-switch -fomit-frame-pointer -D_REENTRANT  -DMMX -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr\" -DLIBDIR=\"/usr/lib64\" -DUSING_XV -DUSING_XVMC -DUSING_XVMC_VLD -DUSING_XRANDR -DUSING_OPENGL_VSYNC -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/qt/3/mkspecs/linux-g++ -I/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/work/mythtv-0.20.2/programs/mythfrontend -I/usr/include -I/usr/X11R6/include -I../.. -I../../libs -I../../libs/libmyth -I../../libs/libmythtv -I../../libs/libavutil -I../../libs/libavformat -I../../libs/libavcodec -I../../libs/libmythupnp -I../../libs/libmythui -I../../libs/libmythlivemedia -I/usr/qt/3/include -I/usr/X11R6/include -I/usr/X11R6/include -o moc_programrecpriority.o moc_programrecpriority.cpp
g++ -c -pipe -march=nocona -Wall -W -O3 -Wall -Wno-switch -fomit-frame-pointer -D_REENTRANT  -DMMX -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr\" -DLIBDIR=\"/usr/lib64\" -DUSING_XV -DUSING_XVMC -DUSING_XVMC_VLD -DUSING_XRANDR -DUSING_OPENGL_VSYNC -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/qt/3/mkspecs/linux-g++ -I/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/work/mythtv-0.20.2/programs/mythfrontend -I/usr/include -I/usr/X11R6/include -I../.. -I../../libs -I../../libs/libmyth -I../../libs/libmythtv -I../../libs/libavutil -I../../libs/libavformat -I../../libs/libavcodec -I../../libs/libmythupnp -I../../libs/libmythui -I../../libs/libmythlivemedia -I/usr/qt/3/include -I/usr/X11R6/include -I/usr/X11R6/include -o moc_channelrecpriority.o moc_channelrecpriority.cpp
g++ -c -pipe -march=nocona -Wall -W -O3 -Wall -Wno-switch -fomit-frame-pointer -D_REENTRANT  -DMMX -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr\" -DLIBDIR=\"/usr/lib64\" -DUSING_XV -DUSING_XVMC -DUSING_XVMC_VLD -DUSING_XRANDR -DUSING_OPENGL_VSYNC -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/qt/3/mkspecs/linux-g++ -I/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/work/mythtv-0.20.2/programs/mythfrontend -I/usr/include -I/usr/X11R6/include -I../.. -I../../libs -I../../libs/libmyth -I../../libs/libmythtv -I../../libs/libavutil -I../../libs/libavformat -I../../libs/libavcodec -I../../libs/libmythupnp -I../../libs/libmythui -I../../libs/libmythlivemedia -I/usr/qt/3/include -I/usr/X11R6/include -I/usr/X11R6/include -o moc_statusbox.o moc_statusbox.cpp
g++ -c -pipe -march=nocona -Wall -W -O3 -Wall -Wno-switch -fomit-frame-pointer -D_REENTRANT  -DMMX -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr\" -DLIBDIR=\"/usr/lib64\" -DUSING_XV -DUSING_XVMC -DUSING_XVMC_VLD -DUSING_XRANDR -DUSING_OPENGL_VSYNC -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/qt/3/mkspecs/linux-g++ -I/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/work/mythtv-0.20.2/programs/mythfrontend -I/usr/include -I/usr/X11R6/include -I../.. -I../../libs -I../../libs/libmyth -I../../libs/libmythtv -I../../libs/libavutil -I../../libs/libavformat -I../../libs/libavcodec -I../../libs/libmythupnp -I../../libs/libmythui -I../../libs/libmythlivemedia -I/usr/qt/3/include -I/usr/X11R6/include -I/usr/X11R6/include -o moc_networkcontrol.o moc_networkcontrol.cpp
g++ -Wl,-O1 -Wl,--sort-common -Wl,--enable-new-dtags -Wl,--as-needed -Wl,--hash-style=both -o mythfrontend version.o main.o manualbox.o playbackbox.o viewscheduled.o globalsettings.o manualschedule.o programrecpriority.o channelrecpriority.o statusbox.o networkcontrol.o moc_manualbox.o moc_playbackbox.o moc_viewscheduled.o moc_manualschedule.o moc_programrecpriority.o moc_channelrecpriority.o moc_statusbox.o moc_networkcontrol.o   -L/usr/qt/3/lib64 -L../../libs/libmyth -L../../libs/libmythtv -L../../libs/libavutil -L../../libs/libavcodec -L../../libs/libavformat -L../../libs/libmythfreemheg -L../../libs/libmythui -L../../libs/libmythupnp -L../../libs/libmythlivemedia -lmythtv-0.20.2 -lmythavformat-0.20.2 -lmythavutil-0.20.2 -lmythavcodec-0.20.2 -lmythfreemheg-0.20.2 -lmythupnp-0.20.2 -lmythlivemedia-0.20.2 -lmyth-0.20.2 -lmythui-0.20.2 -lfreetype -lmp3lame -lasound -ljack -L/usr/X11R6/lib64 -lXinerama -lXv -lXxf86vm -lXrandr -lXvMCW -lXvMC -lqt-mt -lGLU -lGL -lXmu -lXext -lX11 -lm -lpthread
make[2]: Leaving directory `/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/work/mythtv-0.20.2/programs/mythfrontend'
make[1]: Leaving directory `/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/work/mythtv-0.20.2/programs'
make: *** [sub-programs] Error 2
 * ERROR: media-tv/mythtv-0.20.2_p15634 failed.
 * Call stack:
 *     , line   46:  Called src_compile
 *             environment, line 2946:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed";
 *  The die message:
 *   emake failed
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/temp/build.log'.
 * The ebuild environment file is located at '/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/temp/environment'.

 * Messages for package media-tv/mythtv-0.20.2_p15634:

 * You enabled the 'xvmc' USE flag, you must have a GeForce 4 or
 * greater to use this. Otherwise, you'll have crashes with MythTV
 * ERROR: media-tv/mythtv-0.20.2_p15634 failed.
 * Call stack:
 *     , line   46:  Called src_compile
 *             environment, line 2946:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed";
 *  The die message:
 *   emake failed
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/temp/build.log'.
 * The ebuild environment file is located at '/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/temp/environment'.
 * GNU info directory index is up-to-date.
Comment 1 Patrizio Bassi 2008-02-02 19:37:22 UTC
Created attachment 142529 [details]
build log

Portage (default-linux/amd64/2007.0, gcc-4.2.2, glibc-2.7-r1, 2.6.24 x86_64)
System uname: 2.6.24 x86_64 Intel(R) Core(TM)2 CPU 6300 @ 1.86GHz
Timestamp of tree: Fri, 01 Feb 2008 17:15:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O3 -pipe -march=nocona -mtune=nocona -fomit-frame-pointer -mmmx -msse -msse2 -msse3 -mfpmath=sse"
CONFIG_PROTECT="/etc /etc/mail/dspam /opt/openjms/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/mozilla/defaults/pref /usr/share/config /var/lib/hsqldb /var/run/dspam"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/eselect/compiler /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O3 -pipe -march=nocona -mtune=nocona -fomit-frame-pointer -mmmx -msse -msse2 -msse3 -mfpmath=sse"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--enable-new-dtags -Wl,--as-needed -Wl,--hash-style=both"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="64bit 7zip X X509 Xaw3d a52 aac aalib accessibility ace acl acpi activefilter addbookmarks adns aiglx aio alias alsa amd amd64 amr amrr amuled ao aoss apache2 arj asf aspnet2 async atk audacious audiofile authfile automount autoreplace bash-completion berkdb bidi binary-drivers bitmap-fonts bittorrent blas bootsplash browserplugin bzip2 cairo calendar caps cdda cddb cdio cdparanoia cdr cgi charconv chardet chroot ciao clamav clearcase cli client codecs connectionstatus contactnotes corba cracklib crypt cscope css ctype cups curl cvs daemon dar64 dba dbus depth32 dga dhcp dio directfb diskio divx djbfft dmi dri dvd dvdr dvdread edl encode ethereal exif expat extraengine faac faad fam fastbuild fbcon ffmpeg fftw firefox flac flash foreign-package fortran ftp gcj gd gdbm geometry ggi gif gimp gimpprint glibc-omitfp glitz glut glx gnokii gnome gnutls gphoto2 gpm graphviz gs gtk gtk2 gtkhtml h264 hal hddtemp highlight history iconv idea idn imagemagick imap innodb ipod ipv6 irc irda irmc isdnlog jack java java5 javamail javascript jikes jit joystick jpeg jpeg2k junit justify kde kdeenablefinal kdehiddenvisibility kerberos kqemu lame lapack lcd lcms ldap libcaca libclamav libgda libusb lirc live lm_sensors lua lzo mad mailwrapper matroska md5sum mdb mhash midi mikmod mime mmx mmx2 mmxext mng mono mozcalendar mozdevelop mozilla mozsvg mozxmlterm mp3 mp4 mp4live mpeg mpeg2 mpeg4 mplayer mpm-prefork msn msnextras mudflap musepack mysql mysqli mythtv nagios-dns nagios-ntp nagios-ping nagios-ssh ncurses neXt network ngui nls nntp no_wxgtk1 nobsh nopie nossp noxalan nptl nptlonly nsplugin nv nvidia oav odbc ogg openal opengl openmp openssl operanom2 pam pcre pda pdf pdo pear perl php pmu png pnp postgres pppd pthreads pulseaudio python qemu-fast qhull qt3 qt3support qt4 quicktime quotas readline reflection rrdtool rtc ruby samba sametime scanner sdl server session sftplogging sguil slang slp smp snortsam soap sockets socks5 softmmu softquota spamassassin speex spell spl sqlite3 sse sse2 sse3 ssl ssse3 subject-rewrite svg tao tcltk tcpd tetex texteffect tga theora tiff tk tokenizer translator truetype truetype-fonts trusted type1-fonts unicode usb userlocales vorbis webpresence winpopup wma wmf wmv wsconvert wxwindows x264 xanim xchatdccserver xchattext xcomposite xine xinerama xml xml2 xmlrpc xorg xosd xpm xprint xsl xv xvid xvm xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="fbdev vesa vga nv nvidia"
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2008-02-02 19:41:45 UTC
Pasting the real error...

g++ -c -pipe -march=nocona -Wall -W -O3 -Wall -Wno-switch -fomit-frame-pointer -D_REENTRANT  -DMMX -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr\" -DLIBDIR=\"/usr/lib64\" -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/qt/3/mkspecs/linux-g++ -I/mnt/Dati/Gentoo/tmp/portage/media-tv/mythtv-0.20.2_p15634/work/mythtv-0.20.2/programs/mythcommflag -I/usr/include -I/usr/X11R6/include -I../.. -I../../libs -I../../libs/libmyth -I../../libs/libmythtv -I../../libs/libavutil -I../../libs/libavformat -I../../libs/libavcodec -I../../libs/libmythupnp -I../../libs/libmythui -I../../libs/libmythlivemedia -I/usr/qt/3/include -I/usr/X11R6/include -I/usr/X11R6/include -o CommDetector2.o CommDetector2.cpp
../../../libs/libavcodec/ undefined reference to `XvMCFlushSurface'
../../../libs/libavcodec/ undefined reference to `XvMCLoadQMatrix'
../../../libs/libavcodec/ undefined reference to `XvMCBeginSurface'
../../../libs/libavcodec/ undefined reference to `XvMCSyncSurface'
collect2: ld returned 1 exit status
make[2]: *** [mythreplex] Error 1
Comment 3 Patrizio Bassi 2008-02-02 19:55:39 UTC
yes you're right, the Makefile doesn't stop immediatly on the linking issue.

seems this is a regression as, with same flags, it compiled file some svn revision ago (last 2 are broken for sure)
Comment 4 Doug Goldstein (RETIRED) gentoo-dev 2008-02-02 22:57:29 UTC
Upstream bug related to --as-needed usage.

Tone down the LDFLAGS and it will compile fine.
Comment 5 Patrizio Bassi 2008-02-03 17:26:19 UTC
it's for sure a regression as it worked in the i add in the meta bug dependency
Comment 6 Doug Goldstein (RETIRED) gentoo-dev 2008-02-04 04:44:08 UTC
MythTV upstream does not officially support --as-needed. It worked for a long time because I took quite a while to work through their build system to figure out the problems and write up a patch. One which was submitted upstream and answered with "we don't support --as-needed". An upstream developer recently reopened that bug and pursued it, cleaning up some of the build issues. Since he changed the build system my patch no longer applies. However, he has applied it and as been working through the issues as found. That being said, Gentoo does not patch the MythTV builds any longer as per requests by upstream, so this is going to be an upstream issue.