Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 208342 - media-video/mplayer-1.0_rc2_p24929-r1 infinite loop on ASF stream
Summary: media-video/mplayer-1.0_rc2_p24929-r1 infinite loop on ASF stream
Status: VERIFIED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-31 19:45 UTC by Imre Péntek
Modified: 2008-02-06 18:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Imre Péntek 2008-01-31 19:45:25 UTC
Having this mplayer installed:
[ebuild   R   ] media-video/mplayer-1.0_rc2_p24929-r1  USE="X alsa arts cdparanoia dvd encode esd gif iconv ipv6 jpeg mad mmx mp3 opengl oss png quicktime sdl sse sse2 truetype unicode vorbis xv -3dnow -3dnowext -a52 -aac -aalib (-altivec) -amrnb -amrwb -bidi -bindist -bl -cddb -cdio -cpudetection -custom-cflags -debug -dga -directfb -doc -dts -dv -dvb -enca -fbcon -ftp -ggi -gtk -jack -joystick -ladspa -libcaca -lirc -live -livecd -lzo -md5sum -mmxext -mp2 -musepack -nas -nemesi -openal -pnm -pulseaudio -radio -rar -real -rtc -samba -speex -srt -ssse3 (-svga) -teletext -tga -theora -tivo -v4l -v4l2 (-vidix) (-win32codecs) -x264 -xanim -xinerama -xvid -xvmc -zoran" VIDEO_CARDS="-mga -s3virge -tdfx -vesa" 0 kB

I get this output:
imi@boborjan ~ $ LANG=en_US.UTF-8 mplayer 'http://video.hirado.hu/videok/modernkepmesek/20080124/kepmesek17_080124.wmv'
MPlayer dev-SVN-rUNKNOWN-4.1.2 (C) 2000-2007 MPlayer Team
CPU: Mobile AMD Athlon(tm) 64 Processor 3000+ (Family: 15, Model: 4, Stepping: 10)
3DNow supported but disabled
3DNowExt supported but disabled
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
x86-os CPU - a következő kiterjesztésekkel: MMX MMX2 SSE SSE2

http://video.hirado.hu/videok/modernkepmesek/20080124/kepmesek17_080124.wmv lejátszása.
video.hirado.hu feloldása erre: AF_INET...
Csatlakozás a(z) video.hirado.hu[195.70.55.209] szerverhez: 80...
Cache méret beállítva 320 KByte-ra


http://video.hirado.hu/videok/modernkepmesek/20080124/kepmesek17_080124.wmv?MSWMExt=.asf lejátszása.
video.hirado.hu feloldása erre: AF_INET...
Csatlakozás a(z) video.hirado.hu[195.70.55.209] szerverhez: 80...
Cache méret beállítva 320 KByte-ra


http://video.hirado.hu/videok/modernkepmesek/20080124/kepmesek17_080124.wmv?MSWMExt=.asf lejátszása.
video.hirado.hu feloldása erre: AF_INET...
Csatlakozás a(z) video.hirado.hu[195.70.55.209] szerverhez: 80...
Cache méret beállítva 320 KByte-ra


and so on...

Reproducible: Always
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2008-01-31 19:48:34 UTC
Sorry, but my Hungarian is non-existant. Either re-emerge mplayer with LINGUAS="en" or provide a translation.
Comment 2 Imre Péntek 2008-01-31 20:07:50 UTC
as I have LINGUAS="hu en_GB en" I suppose mplayer not to support LINGUAS setting. Providing a translation:

imi@boborjan ~ $ LANG=en_US.UTF-8 mplayer
'http://video.hirado.hu/videok/modernkepmesek/20080124/kepmesek17_080124.wmv'
MPlayer dev-SVN-rUNKNOWN-4.1.2 (C) 2000-2007 MPlayer Team
CPU: Mobile AMD Athlon(tm) 64 Processor 3000+ (Family: 15, Model: 4, Stepping:
10)
3DNow supported but disabled
3DNowExt supported but disabled
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
x86 CPU - with the following extensions: MMX MMX2 SSE SSE2

playing http://video.hirado.hu/videok/modernkepmesek/20080124/kepmesek17_080124.wmv

resolving video.hirado.hu (AF_INET)...
connecting to server video.hirado.hu[195.70.55.209] : 80...
Cache size set to 320 KByte


playing http://video.hirado.hu/videok/modernkepmesek/20080124/kepmesek17_080124.wmv

resolving video.hirado.hu (AF_INET)...
connecting to server video.hirado.hu[195.70.55.209] : 80...
Cache size set to 320 KByte


playing http://video.hirado.hu/videok/modernkepmesek/20080124/kepmesek17_080124.wmv

resolving video.hirado.hu (AF_INET)...
connecting to server video.hirado.hu[195.70.55.209] : 80...
Cache size set to 320 KByte


and so on...
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2008-01-31 20:17:59 UTC
(In reply to comment #2)
> as I have LINGUAS="hu en_GB en" I suppose mplayer not to support LINGUAS
> setting. Providing a translation:

It will use the very first value of LINGUAS, whatever it is. If you dislike this lack of proper gettext support, voice you concerns upstream.
Comment 4 Reimar Döffinger 2008-02-01 22:26:17 UTC
This is because the file you give to mplayer is a playlist file that references itself as first entry.
This works with the windows media player since it only needs to support its own crap, but is not easily fixable in MPlayer.
Use "mms://" or "mmshttp://" instead of "http://" and it will play.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2008-02-01 22:28:38 UTC
Closing wrt the above comment.
Comment 6 Imre Péntek 2008-02-03 14:40:02 UTC
(In reply to comment #4)
As it is possible to do some workaround on the command line, the above media (with the above URL) is a part of a webpage, so the workaround wouldn't help this way. So I'd like a real solution also.
At this location: http://www.mtv.hu/videotar/?id=16656
Comment 7 Reimar Döffinger 2008-02-06 17:53:37 UTC
mplayerplug-in or whatever can parse the playlist and fix it. It does know that it is supposed to emulate Windows Media Player and thus http:// actually means mms over http.
MPlayer can _not_ know that (it can know for asx playlists and there the substitution is done, but not for this common .ini format).
In this special case loop detection would not be too hard but in the general case that would be a lot of messy code and still not work usually.
If you do not care about proper HTML streaming, -user-agent NSPlayer/4.1.0.3856 is a fixes it as well.
Comment 8 Imre Péntek 2008-02-06 18:56:34 UTC
anyways this media cannot be played as a part of the mentioned website, I still consider this as a bug, have a look at it please.
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2008-02-06 18:58:52 UTC
(In reply to comment #8)

Wrong place for this, if you dislike it then take your complaints upstream.