Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 207645 - =net-wireless/bluez-hcidump-1.30 doesn't build due to error in hci.c:742: 'sniff_subrate_cp' undeclared, mark 1.42 stable
Summary: =net-wireless/bluez-hcidump-1.30 doesn't build due to error in hci.c:742: 'sn...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Petteri Räty (RETIRED)
Depends on: CVE-2008-2374
  Show dependency tree
Reported: 2008-01-27 03:15 UTC by Muelli
Modified: 2009-04-08 21:39 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Muelli 2008-01-27 03:15:24 UTC
I tried to build =net-wireless/bluez-hcidump-1.30 but it fails.

Reproducible: Always

Steps to Reproduce:
1.emerge =net-wireless/bluez-hcidump-1.30

Actual Results:  
 * bluez-hcidump-1.30.tar.gz RMD160 SHA1 SHA256 size ;-) ...              [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking bluez-hcidump-1.30.tar.gz ;-) ...                             [ ok ]
>>> Unpacking source...
>>> Unpacking bluez-hcidump-1.30.tar.gz to /mnt/ramdisk/portage/net-wireless/bluez-hcidump-1.30/work
>>> Source unpacked.
>>> Compiling source in /mnt/ramdisk/portage/net-wireless/bluez-hcidump-1.30/work/bluez-hcidump-1.30 ...
 * disabling confcache, binary cannot be found
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --build=i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether i686-pc-linux-gnu-gcc accepts -g... yes
checking for i686-pc-linux-gnu-gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of i686-pc-linux-gnu-gcc... gcc3
checking whether i686-pc-linux-gnu-gcc accepts -fPIE... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for i686-pc-linux-gnu-ranlib... i686-pc-linux-gnu-ranlib
checking how to run the C preprocessor... i686-pc-linux-gnu-gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking bluetooth/bluetooth.h usability... yes
checking bluetooth/bluetooth.h presence... yes
checking for bluetooth/bluetooth.h... yes
checking for hci_open_dev in -lbluetooth... yes
checking for sdp_connect in -lbluetooth... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating parser/Makefile
config.status: creating config.h
config.status: executing depfiles commands
make  all-recursive
make[1]: Entering directory `/mnt/ramdisk/portage/net-wireless/bluez-hcidump-1.30/work/bluez-hcidump-1.30'
Making all in parser
make[2]: Entering directory `/mnt/ramdisk/portage/net-wireless/bluez-hcidump-1.30/work/bluez-hcidump-1.30/parser'
if i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..    -I/usr/include -O3 -march=athlon-xp -fomit-frame-pointer -pipe -m3dnow -msse -mmmx -fprefetch-loop-arrays -D_FORTIFY_SOURCE=2 -MT parser.o -MD -MP -MF ".deps/parser.Tpo" \
          -c -o parser.o `test -f 'parser.c' || echo './'`parser.c; \
        then mv -f ".deps/parser.Tpo" ".deps/parser.Po"; \
        else rm -f ".deps/parser.Tpo"; exit 1; \
if i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..    -I/usr/include -O3 -march=athlon-xp -fomit-frame-pointer -pipe -m3dnow -msse -mmmx -fprefetch-loop-arrays -D_FORTIFY_SOURCE=2 -MT lmp.o -MD -MP -MF ".deps/lmp.Tpo" \
          -c -o lmp.o `test -f 'lmp.c' || echo './'`lmp.c; \
        then mv -f ".deps/lmp.Tpo" ".deps/lmp.Po"; \
        else rm -f ".deps/lmp.Tpo"; exit 1; \
if i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..    -I/usr/include -O3 -march=athlon-xp -fomit-frame-pointer -pipe -m3dnow -msse -mmmx -fprefetch-loop-arrays -D_FORTIFY_SOURCE=2 -MT hci.o -MD -MP -MF ".deps/hci.Tpo" \
          -c -o hci.o `test -f 'hci.c' || echo './'`hci.c; \
        then mv -f ".deps/hci.Tpo" ".deps/hci.Po"; \
        else rm -f ".deps/hci.Tpo"; exit 1; \
if i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..    -I/usr/include -O3 -march=athlon-xp -fomit-frame-pointer -pipe -m3dnow -msse -mmmx -fprefetch-loop-arrays -D_FORTIFY_SOURCE=2 -MT l2cap.o -MD -MP -MF ".deps/l2cap.Tpo" \
          -c -o l2cap.o `test -f 'l2cap.c' || echo './'`l2cap.c; \
        then mv -f ".deps/l2cap.Tpo" ".deps/l2cap.Po"; \
        else rm -f ".deps/l2cap.Tpo"; exit 1; \
hci.c: In function ‘sniff_subrate_dump’:
hci.c:742: error: ‘sniff_subrate_cp’ undeclared (first use in this function)
hci.c:742: error: (Each undeclared identifier is reported only once
hci.c:742: error: for each function it appears in.)
hci.c:742: error: ‘cp’ undeclared (first use in this function)
hci.c: In function ‘write_link_supervision_timeout_dump’:
hci.c:965: error: ‘write_link_supervision_timeout_cp’ has no member named ‘link_sup_to’
hci.c: In function ‘command_dump’:
hci.c:1131: error: ‘OCF_SNIFF_SUBRATE’ undeclared (first use in this function)
hci.c: In function ‘read_link_supervision_timeout_dump’:
hci.c:1490: error: ‘read_link_supervision_timeout_rp’ has no member named ‘link_sup_to’
hci.c: In function ‘cmd_complete_dump’:
hci.c:1754: error: ‘OCF_SNIFF_SUBRATE’ undeclared (first use in this function)
hci.c: In function ‘sniff_subrate_event_dump’:
hci.c:2374: error: ‘evt_sniff_subrate’ undeclared (first use in this function)
hci.c:2374: error: ‘evt’ undeclared (first use in this function)
hci.c: In function ‘event_dump’:
hci.c:2575: error: ‘EVT_SNIFF_SUBRATE’ undeclared (first use in this function)
hci.c: In function ‘sco_dump’:
hci.c:2618: warning: ignoring return value of ‘write’, declared with attribute warn_unused_result
make[2]: *** [hci.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/mnt/ramdisk/portage/net-wireless/bluez-hcidump-1.30/work/bluez-hcidump-1.30/parser'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/mnt/ramdisk/portage/net-wireless/bluez-hcidump-1.30/work/bluez-hcidump-1.30'
make: *** [all] Error 2
 * ERROR: net-wireless/bluez-hcidump-1.30 failed.
 * Call stack:
 *         , line 1701:  Called dyn_compile
 *         , line 1039:  Called qa_call 'src_compile'
 *         , line   44:  Called src_compile
 *   bluez-hcidump-1.30.ebuild, line   19:  Called die
 * The specific snippet of code:
 *      emake || die "emake failed"
 *  The die message:
 *   emake failed
 * If you need support, post the topmost build error, and the call stack if relevant.

Portage (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r3 i686)
System uname: 2.6.23-gentoo-r3 i686 AMD Athlon(tm) XP 2400+
Timestamp of tree: Fri, 25 Jan 2008 19:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
CFLAGS="-O3 -march=athlon-xp -fomit-frame-pointer -pipe -m3dnow -msse -mmmx -fprefetch-loop-arrays"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/rc.d /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d /etc/wget"
CXXFLAGS="-O3 -march=athlon-xp -fomit-frame-pointer -pipe -m3dnow -msse -mmmx -fprefetch-loop-arrays"
FEATURES="autoaddcvs ccache confcache distcc distlocks metadata-transfer parallel-fetch sandbox sfperms splitdebug strict unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common"
LINGUAS="de en_GB eo"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="3dnow 3dnowext X X509 a52 aac accessibility acl acpi ada adns aiglx alsa amarok amr amuled async auctex audacious audiofile authfile avahi bash-completion bindist bitmap-fonts bittorrent bl blender-game bluetooth bonjour branding browserplugin buttons bzip2 cairo ccache cdb cdda cddb cdinstall cdio cdparanoia cdr cli cracklib crypt css csv curl cyrus d dbase dbus devhelp disk-partition divx divx4linux djvu drac dri dts dvb dvd dvdnav dvdr dvdread dvi dynagraph eds effects emboss emerald encode enscript escreen ethereal evo exif extrafilters extras fasttrack ffmpeg firefox flac fuse gajim galago garmin gd gdbm gedit geldkarte ggi gif gkrellm glade glitz glsa glut gmedia gmp gnokii gnome gnuplot gnustep gnutella gnutls gpg gpgme gpm graphviz gs gsm gstreamer gtalk gtk gtk2 gtkhtml hal hbci hddtemp html http iconv id3 idn imagemagick imlib inherit-graph ipv6 irc irda isdnlog jabber javascript jingle joystick jpeg jpeg2k junit justify keyring lame latex libcaca libnotify libsexy libwww logrotate logwatch lzo mad madwifi matroska midi mikmod mmx mmxext mng mod mod_muc mod_pubsub moneyplex mono mozdevelop mozilla moznoirc moznomail mozsvg mp3 mp4 mp4live mpe mpeg mpeg2 mpeg4 mplayer mudflap multiuser musepack musicbrainz mythtv nautilus ncurses net nls nntp nogg nptl nptlonly nvidia nvtv offensive ofx ogg ole on-the-fly-crypt opengl openmp openssl oss pam pcre pdf perl plugin plugins png postscript pppd pulseaudio python pyx qt3 qt3support qt4 quicktime rar readline real realmedia recode reflection reiser4 reiserfs remote replytolist restrict-javascript rss rtsp ruby sasl screen sdl sendfile sensord session sftp shaper shorten shout skins slang sms socks5 softquota sourceview speech speedo speex spell spl sqlite sqlite3 srv sse sse2 ssl stream stroke subversion svg svga symlink tcl tcpd tetex tga theora thesaurus thumbnail thumbnailing thunderbird tiff tk tordns tos tracker trayicon truetype truetype-fonts type1-fonts unicode upnp usb utf8 uuencode v4l v4l2 valgrind vcd videos vidix visual visualization vnc vorbis win32codecs wma wmf wmp x264 x86 xanim xchat xcomposite xemacs xforms xine xml xorg xulrunner xv xvid xvmc zeroconf zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en_GB eo" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"
Comment 1 Petteri Räty (RETIRED) gentoo-dev 2008-02-03 18:18:28 UTC
1.41 probably works. Will need to see to getting a new set of bluetooth stack stable. for now you can use package.keywords to keyword the new versions as workaround 
Comment 2 Kobboi 2008-11-09 20:27:43 UTC
Same problem, tried 1.42 and that works.
Comment 3 Jérôme Poulin 2009-02-22 20:30:53 UTC
I can confirm 1.30 fails to build and that 1.42 works here too, I guess 1.30 should now be masked as it is less stable than unstable.
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2009-03-06 02:28:34 UTC
Stable for HPPA.
Comment 5 Markus Meier gentoo-dev 2009-03-08 01:38:04 UTC
amd64/x86 stable
Comment 6 Joe Jezak (RETIRED) gentoo-dev 2009-03-24 22:33:16 UTC
Marked ppc stable.
Comment 7 Friedrich Oslage (RETIRED) gentoo-dev 2009-04-08 21:39:45 UTC
sparc stable, closing since we're last