Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 207537 - sys-fs/dazuko - 2.6.24 - does not compile
Summary: sys-fs/dazuko - 2.6.24 - does not compile
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL: https://savannah.nongnu.org/support/i...
Whiteboard:
Keywords:
: 217891 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-26 11:35 UTC by Alon Bar-Lev
Modified: 2009-02-22 13:31 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dazuko ebuild (dazuko-2.3.4.ebuild,2.05 KB, text/plain)
2008-02-09 12:02 UTC, emerald
Details
Kernel Bug thrown by antivir when trying to use dazuko with redirfs (dazuko.failed,2.61 KB, text/plain)
2008-03-16 18:47 UTC, Dustin Polke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alon Bar-Lev gentoo-dev 2008-01-26 11:35:24 UTC
Waiting for upstream
Comment 1 emerald 2008-02-09 12:02:08 UTC
Created attachment 143032 [details]
dazuko ebuild

I've changed the ebuild to use syscall hooks (which still works) so it's at least usable with kernel 2.6.24. The ebuild uses the System.map file in the kernel sources directory. From informations from dazuko.org this System.map must be the current one for the kernel which will load the dazuko module, which will be the case if everything is set up correctly.
Comment 2 Alon Bar-Lev gentoo-dev 2008-02-23 00:33:13 UTC
Hi!
Upstream is against this kind of solution.
Thanks.
Comment 3 Alon Bar-Lev gentoo-dev 2008-02-23 10:35:10 UTC
Added new pre-release, support via redirfs.
Masked as redirfs is none stable.
Comment 4 Alon Bar-Lev gentoo-dev 2008-02-23 11:31:07 UTC
DO NOT use this, as it makes some file corrupt.
Comment 5 Dustin Polke 2008-03-16 18:46:05 UTC
Hi alonbl!

I'd love to update my system to 2.6.24-gentoo-r3 stable kernel. However, I need dazuko for antivir and 2.3.5_pre1 and redirfs-0.2-r1 are in p.mask. After reading comment #4, I will definitely not use both with p.unmasked.

I already tried to use antivir with dazuko-2.3.5_pre1 and redifs-0.2-r1. But the module throws a kernel bug, which I will attach as it might help to get this working.

I was thinking as well to use dazuko without redirfs and syscall hooks as emerald suggested. Could you be a bit elaborative about why upstream is against this kind of solution? Is there any regression using this kind of configuration compared to dazuko-2.3.4 with kernel <2.6.24? For the meantime this sounds like a solution until dazuko with redirfs is stable enough to be used on productive systems.

BR and thanks for your work

Dustin
Comment 6 Dustin Polke 2008-03-16 18:47:22 UTC
Created attachment 146331 [details]
Kernel Bug thrown by antivir when trying to use dazuko with redirfs
Comment 7 Alon Bar-Lev gentoo-dev 2008-03-16 19:21:22 UTC
Hello,
The syscall interface was removed from 2.6.24, although it can be still hacked.
Can you please send this error to dazuko mailing list? It will be better if you discuss it with upstream directly.
Thanks,
Comment 8 Dustin Polke 2008-03-17 08:45:32 UTC
Okay. I will go looking for my bugzilla log-in for dazuko...
I will attach upstream URL of the bug for reference as soon as I have filed one.

One question though: Since security capability is not as module available any more in 2.6.24, is it required to compile security capabilities into the kernel or is it not needed? I'd like to check, whether I configured the kernel properly before filing a bug.

Thanks.
Dustin
Comment 9 Dustin Polke 2008-03-17 12:28:48 UTC
For reference, URL of upstream bug for kernel BUG described in comment 5 is https://savannah.nongnu.org/bugs/index.php?22640
Comment 10 Dustin Polke 2008-03-26 14:54:57 UTC
alonbl: John Ogness has released a patch against the kernel to compile dazuko statically into the kernel.

URL to this patch is: http://www.dazuko.org/files/patch-linux26-dazuko-2.3.5-pre1.tar.gz

The archive contains a README file explaining how to patch the kernel tree. Basically, it adds config options to the menu and adds the dazuko code into the tree. With this patch, dazuko can be used without relying on security capability built as kernel module and redirfs.

I will test the patch against the actual stable 2.6.24 kernel on x86 and see how it works.

Is this solution an acceptable option to be persued by Gentoo?
I know this will include some coordination with the kernel team, maybe you could talk with Daniel if you deem this the right way to go.

BR,
Dustin
Comment 11 Dustin Polke 2008-03-26 15:06:13 UTC
And for completeness, the announcement can be found on the mailing list at: http://lists.gnu.org/archive/html/dazuko-devel/2008-03/msg00014.html
Comment 12 Alon Bar-Lev gentoo-dev 2008-03-26 17:09:39 UTC
Hi!
I am afraid that kernel patch will not be accepted by kernel herd.
And I am not willing to maintain branched sources.
So we have to wait for out of kernel solution.
Alon.
Comment 13 Jeroen Roovers gentoo-dev 2008-04-16 14:54:52 UTC
*** Bug 217891 has been marked as a duplicate of this bug. ***
Comment 14 Łukasz Damentko (RETIRED) gentoo-dev 2008-05-27 13:34:00 UTC
alonbl was retired (#147110), reassigning remaining bugs.
Comment 15 Carsten Lohrke (RETIRED) gentoo-dev 2009-02-22 13:31:11 UTC
dazuko-2.3.6_pre2 is in cvs. It's supposed to be the last 2.x version.