Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 206686 - dvtm-0.3 - dynamic virtual terminal manager (new ebuild)
Summary: dvtm-0.3 - dynamic virtual terminal manager (new ebuild)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard:
Keywords: EBUILD, InOverlay, REVIEWED
: 293549 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-19 18:41 UTC by Christoph Dibak
Modified: 2010-05-04 15:50 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dvtm-0.3 ebuild (dvtm-0.3.ebuild,468 bytes, text/plain)
2008-01-19 18:45 UTC, Christoph Dibak
Details
fixed dvtm-0.3 ebuild (dvtm-0.3.ebuild,578 bytes, text/plain)
2008-01-19 19:33 UTC, Christoph Dibak
Details
dvtm-0.3.ebuild with the right prefix (dvtm-0.3.ebuild,592 bytes, text/plain)
2008-01-19 19:55 UTC, Christoph Dibak
Details
use savedconfig.eclass, ! strip, fix CFLAGS and LDFLAGS (dvtm-0.4.ebuild,1.26 KB, text/plain)
2008-02-20 10:44 UTC, Jonas Bernoulli
Details
live build (dvtm-9999.ebuild,1.19 KB, text/plain)
2008-02-20 10:45 UTC, Jonas Bernoulli
Details
change copyright to gentoo (dvtm-9999.ebuild,1.19 KB, text/plain)
2008-02-20 10:51 UTC, Jonas Bernoulli
Details
and add $Header (dvtm-9999.ebuild,1.20 KB, text/plain)
2008-02-20 10:52 UTC, Jonas Bernoulli
Details
app-misc/dvtm/dvtm-0.4.ebuild (dvtm-0.4.ebuild,1.61 KB, text/plain)
2008-03-15 23:03 UTC, Tiziano Müller
Details
dvtm-0.4.1.ebuild (dvtm-0.4.1.ebuild,1.29 KB, text/plain)
2008-12-12 15:13 UTC, MATSUU Takuto (RETIRED)
Details
dvtm-0.4.1.ebuild (dvtm-0.4.1.ebuild,1.29 KB, text/plain)
2008-12-12 15:17 UTC, MATSUU Takuto (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Dibak 2008-01-19 18:41:07 UTC
dvtm isn't in portage yet. I've written an ebuild for dvtm-0.3

Reproducible: Always
Comment 1 Christoph Dibak 2008-01-19 18:45:20 UTC
Created attachment 141318 [details]
dvtm-0.3 ebuild

It's my first ebuild. Just to say that.
Comment 2 Christoph Dibak 2008-01-19 19:33:49 UTC
Created attachment 141323 [details]
fixed dvtm-0.3 ebuild
Comment 3 Christoph Dibak 2008-01-19 19:34:19 UTC
Comment on attachment 141318 [details]
dvtm-0.3 ebuild

sry.. this doesn't work
Comment 4 Christoph Dibak 2008-01-19 19:54:20 UTC
Comment on attachment 141323 [details]
fixed dvtm-0.3 ebuild

ok.. finaly the prefix is wrong
Comment 5 Christoph Dibak 2008-01-19 19:55:34 UTC
Created attachment 141324 [details]
dvtm-0.3.ebuild with the right prefix

It installs now in /usr/bin/. This should be better than installing it into /usr/local/bin/
Comment 6 Jonas Bernoulli 2008-02-20 10:44:16 UTC
Created attachment 144064 [details]
use savedconfig.eclass, ! strip, fix CFLAGS and LDFLAGS
Comment 7 Jonas Bernoulli 2008-02-20 10:45:14 UTC
Created attachment 144066 [details]
live build
Comment 8 Jonas Bernoulli 2008-02-20 10:51:02 UTC
Created attachment 144068 [details]
change copyright to gentoo
Comment 9 Jonas Bernoulli 2008-02-20 10:52:10 UTC
Created attachment 144069 [details]
and add $Header
Comment 10 Tiziano Müller gentoo-dev 2008-03-15 23:02:13 UTC
Ok, reviewed the ebuild and added some lines to handle unicode plus changed the sed-expressions. The ebuild is now also in the Gentoo Sunrise User Overlay. Christoph or Jonas: you can take over maintenance there if you want. Please visit http://overlays.gentoo.org/proj/sunrise/wiki for more information.
Comment 11 Tiziano Müller gentoo-dev 2008-03-15 23:03:02 UTC
Created attachment 146253 [details]
app-misc/dvtm/dvtm-0.4.ebuild
Comment 12 MATSUU Takuto (RETIRED) gentoo-dev 2008-12-12 15:13:34 UTC
Created attachment 175105 [details]
dvtm-0.4.1.ebuild

version bump
Comment 13 MATSUU Takuto (RETIRED) gentoo-dev 2008-12-12 15:17:56 UTC
Created attachment 175107 [details]
dvtm-0.4.1.ebuild

fixed typo
Comment 14 Chí-Thanh Christopher Nguyễn gentoo-dev 2010-05-04 15:44:39 UTC
*** Bug 293549 has been marked as a duplicate of this bug. ***
Comment 15 Chí-Thanh Christopher Nguyễn gentoo-dev 2010-05-04 15:50:30 UTC
Fixed in CVS.