Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 206613 - --pretend option should check if the given packages can be installed with current config
Summary: --pretend option should check if the given packages can be installed with cur...
Status: RESOLVED DUPLICATE of bug 2272
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-19 04:44 UTC by David Carlos Manuelda
Modified: 2008-01-19 04:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Carlos Manuelda 2008-01-19 04:44:52 UTC
I was thinking in a feature for the upcoming kuroo, and I wanted to share it as I think it could be good for portage.

The idea is to improve pretend option to do all checks, as many people (like me) uses pretend before emerging (or even, improve ask option too).

For example, I realized of this while I was installing stage3, after installing nvidia-drivers and xorg and layman. I tried to emerge kde (svn version of 4.0) in kde's overlay, and before, I did a pretend in order to unmask apropiate things.
It tried to pull more than 100 packages, and I let it all night running, but when I saw it, it halted due to a check: it was requesting qt4 to be built with qt3 support USE enabled.
I think as when you do a pretend, it already has digraph available, it could also check one by one, the USE dependencies and warn if some are not satisfied.

This way, you ensure emerge won't halt becuase of this trivial things.

This could be applied to kernel config checks, and so on..

What do you think?

Reproducible: Always
Comment 1 Zac Medico gentoo-dev 2008-01-19 04:59:20 UTC

*** This bug has been marked as a duplicate of bug 2272 ***