Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 206078 - Enhanced app-arch/file-roller dependencies
Summary: Enhanced app-arch/file-roller dependencies
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-16 12:29 UTC by Nguyen Thai Ngoc Duy (RETIRED)
Modified: 2008-01-18 11:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
file-roller-2.21.1.patch (file-roller-2.21.1.patch,1.15 KB, patch)
2008-01-16 12:29 UTC, Nguyen Thai Ngoc Duy (RETIRED)
Details | Diff
file-roller-2.21.1.patch (file-roller-2.21.1.patch,1.16 KB, patch)
2008-01-16 12:31 UTC, Nguyen Thai Ngoc Duy (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2008-01-16 12:29:19 UTC
The following patch add additional PDEPENDs to app-arch/file-roller-2.21.1. For some file types such as iso and jar, it is difficult to know what package is needed, so let's document it in ebuild.

For the record, I don't know what package "ar" belongs to. binutils?
Comment 1 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2008-01-16 12:29:45 UTC
Created attachment 141040 [details, diff]
file-roller-2.21.1.patch
Comment 2 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2008-01-16 12:31:22 UTC
Created attachment 141041 [details, diff]
file-roller-2.21.1.patch
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2008-01-16 14:27:34 UTC
Can you *please* move it to (already existing) pkg_postinst() elog stuff? This is an abuse of USE flags plus a nightmare wrt keywording; already debated once in Bug 144627.
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-01-16 15:26:43 UTC
this is indeed an abuse of use flags but I don't want to list a kiloton of packages like say the git ebuild. It is already said in the current ebuild to check the website, if somebody as a brilliant idea, I'd be glad to hear about it but otherwise, this is a wontfix for me.
Comment 5 Nguyen Thai Ngoc Duy (RETIRED) gentoo-dev 2008-01-16 16:11:26 UTC
Well I thought some deps were not really obvious (iso for example). Will make it pkg_postinst if you guys agree (and no fileroller.sf.net does not have any information about this).
Comment 6 Rémi Cardona (RETIRED) gentoo-dev 2008-01-18 11:16:09 UTC
Fixed in CVS. I added a few elog comments, leaving out the obvious ones, like tar, gz and bz2 that everyone should already have as part of the base system.

Changes also propagated to the overlay for 2.21.1

Thanks