Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 20572 - emerge -C mm-sources seg faults, restarting it a couple of times crashes konsole
Summary: emerge -C mm-sources seg faults, restarting it a couple of times crashes konsole
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Nicholas Jones (RETIRED)
Depends on:
Reported: 2003-05-07 06:24 UTC by Rutger Hendriks
Modified: 2011-10-30 22:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Rutger Hendriks 2003-05-07 06:24:42 UTC
When I try to unmerge mm-sources it seems to work okay and is removing files,
but after a while it ends with a Segmentation fault.
Restarting the 'emerge -C mm-sources' works just like normal at first and then
crashes again. Restarting it a couple of times might seem to make it crashes
faster and faster (that is after removing less and less files) and then it even
crashes my konsole
Here is the output of the command:
CP10860-b loial # emerge -Cp mm-sources

>>> These are the packages that I would unmerge:

    selected: 2.5.67-r1
   protected: none
     omitted: none

>>> Packages in red are slated for removal.
>>> Packages in green will not be removed.

CP10860-b loial # emerge -C mm-sources

    selected: 2.5.67-r1
   protected: none
     omitted: none

>>> Packages in red are slated for removal.
>>> Packages in green will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging sys-kernel/mm-sources-2.5.67-r1...
No package files given... Grabbing a set.
--- !found obj /usr/src/linux-2.5.67-mm1/usr/initramfs_data.scr
--- !found obj /usr/src/linux-2.5.67-mm1/usr/gen_init_cpio.c
--- !found obj /usr/src/linux-2.5.67-mm1/usr/Makefile
--- !found obj /usr/src/linux-2.5.67-mm1/sound/usb/usbquirks.h
--- !found obj /usr/src/linux-2.5.67-mm1/arch/ppc64/oprofile/init.c
--- !found obj /usr/src/linux-2.5.67-mm1/arch/ppc64/oprofile/Makefile
--- !found obj /usr/src/linux-2.5.67-mm1/arch/ppc64/oprofile/Kconfig
--- !found obj /usr/src/linux-2.5.67-mm1/arch/ppc64/mm/numa.c
--- !found obj /usr/src/linux-2.5.67-mm1/arch/ppc64/mm/init.c
--- !found obj /usr/src/linux-2.5.67-mm1/arch/ppc64/mm/imalloc.c
<<<        obj /usr/src/linux-2.5.67-mm1/arch/ppc64/mm/fault.c
<<<        obj /usr/src/linux-2.5.67-mm1/arch/ppc64/mm/extable.c
<<<        obj /usr/src/linux-2.5.67-mm1/arch/ppc64/mm/Makefile
<<<        obj /usr/src/linux-2.5.67-mm1/arch/ppc64/lib/string.S
<<<        obj /usr/src/linux-2.5.67-mm1/arch/ppc64/lib/strcase.c
<<<        obj /usr/src/linux-2.5.67-mm1/arch/ppc/syslib/ppc4xx_pm.c
<<<        obj /usr/src/linux-2.5.67-mm1/arch/ppc/syslib/ppc4xx_pic.c
<<<        obj /usr/src/linux-2.5.67-mm1/arch/ppc/syslib/ppc4xx_kgdb.c
<<<        obj /usr/src/linux-2.5.67-mm1/arch/ppc/syslib/ppc4xx_dma.c
<<<        obj /usr/src/linux-2.5.67-mm1/arch/ppc/syslib/ppc405_pci.c
Segmentation fault
CP10860-b loial #

So far mm-sources has been the only thing that has had this problem.
I have recently changed my konsole history settings from 2000 lines to
Unlimited. I have no idea if this has anything to do with it, I doubt it because
running 'ls -la /usr/bin' after the Segmentation fault also generates a lot of
lines and doesn't crash konsole.

Reproducible: Always
Steps to Reproduce:
1. emerge -C mm-sources
2. emerge -C mm-sources

Actual Results:  
Segmentation fault

Expected Results:  
not crash ;-)
Comment 1 Nicholas Jones (RETIRED) gentoo-dev 2003-05-12 04:50:32 UTC

emerge -V
Try >=48_pre5
Comment 2 Rutger Hendriks 2003-05-12 05:14:40 UTC
I have done as you requested:
CP10860-b loial # emerge -V
Portage 2.0.48_pre5 (default-x86-1.4, gcc-3.2.2, glibc-2.3.2-r1)

CP10860-b loial #

It still seg faults though.
Running the command on one of my virtual consoles (i.e. not in konsole) also crashes, so I guess you can forget about my konsole history remark.
I'm not sure how often I can still type emerge -C mm-sources. It must be getting nearer to completion now ;-)
Comment 3 Nicholas Jones (RETIRED) gentoo-dev 2003-05-14 22:07:43 UTC
Can you strace this for me?

strace -f -o portage-mmsources-segv.strace emerge -C mm-sources
bzip2 it and upload it, if you would. (Minimally, the last 100k of it)
Comment 4 Rutger Hendriks 2003-05-15 03:33:56 UTC
Okay, aargh

I did as you asked, but guess what, emerge -C mm-sources didn't crashed when straced *duh*
After a while I decided that it wasn't going to crash and killed the strace. Then I started a regular emerge -C mm-sources and that output 20 lines and then the emerge command completed *groan*

So I thought, let's try the latest mm-sources and I installed it. When it finished I immediately ran emerge -C mm-sources and miracle of miracles, it segfaulted! (Along with mozilla, in which I was just typing you a message similar to this one:( )

Then I decided to perform some strace magic on it and... it didn't crash; it just completed like it is supposed to.

I will try to run an strace on it a couple of times and see if it will crash, but I doubt it. I will report back if it does though.

btw here are my CFLAGS, I heard someone mention them (was it the docs?) as being as far as he would go without compromising system integrity:

CP10860-b root # emerge --info
  Portage 2.0.48_pre6 (default-x86-1.4, gcc-3.2.2, glibc-2.3.2-r1)
System uname: 2.4.20-openmosix-r4 i686 Pentium III (Coppermine)
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config /usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 oss 3dnow apm avi crypt encode gif jpeg mikmod mmx mpeg ncurses nls pdflib png quicktime spell truetype xml2 xmms xv zlib gdbm berkdb slang readline arts svga java X sdl gpm pam libwww ssl perl python esd imlib oggvorbis gtk qt kde motif opengl aalib cdr cups dga directfb doc fbcon ggz -gnome gphoto2 imap -libg++ mbox mozilla oav pic plotutils sse -tcpd tetex tiff wmf tcltk"
CFLAGS="-O3 -mcpu=pentium3 -march=pentium3 -fforce-addr -fomit-frame-pointer -funroll-loops -frerun-cse-after-loop -frerun-loop-opt -falign-functions=4 -pipe"
CXXFLAGS="-O3 -mcpu=pentium3 -march=pentium3 -fforce-addr -fomit-frame-pointer -funroll-loops -frerun-cse-after-loop -frerun-loop-opt -falign-functions=4 -pipe"
FEATURES="sandbox distcc ccache"

CP10860-b root #
Comment 5 Nicholas Jones (RETIRED) gentoo-dev 2003-06-29 19:23:38 UTC
I don't suppose this is still a problem?
Comment 6 Rutger Hendriks 2003-06-30 05:50:53 UTC
I'm sorry to have to disappoint you, but it is still a problem. I have just tried to uninstall 
an older version of the development-sources and the same thing happened, which is 
that it started to remove files like it is supposed to, but then after a few seconds it 
segfaults. Running the same command once more made my konsole disappear :( 
I'm not having stability problems when not using emerge -C 
Comment 7 Rutger Hendriks 2003-06-30 06:14:03 UTC
If I run strace on it, it completes normally. It takes quite a while, but it doesn't crash... Maybe I can run a debug version of emerge to try and find the problem?
Comment 8 Rutger Hendriks 2003-07-01 01:33:37 UTC
I lied.
I said I didn't have any stability problems when not using emerge -C, but that's not true. Today I tried to install openoffice-1.0.3-r1 and it crashed during the compilation part. I restarted it and after a while it must have crashed again and it took konsole with it. I'm starting to think strange things now.
Comment 9 Rutger Hendriks 2003-08-05 15:34:05 UTC
Okay, i finally figured it out.
It must have been a kernel problem. I installed the gentoo-kernel and all crashes vanished. Seems like i'm rock-solid again ;-)
I was using the openmosix-kernel (2.4.20-openmosix-r6). I had turned off automatic migration of processes tho, so it shouldn't have had any influence, but apparently it did...
Comment 10 SpanKY gentoo-dev 2003-08-05 21:07:29 UTC
sounds good :)