Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 20571 - Subversion (CVS replacement) does not compile
Summary: Subversion (CVS replacement) does not compile
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Infrastructure
Classification: Unclassified
Component: CVS/SVN/Git (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-07 03:29 UTC by François Dupoux
Modified: 2011-10-30 22:47 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description François Dupoux 2003-05-07 03:29:57 UTC
emerge dev-util/subversion 
Compilation fails: 
It depend on Berkeley DB, but the dependance was not installed before ! 
--------------------------------- 
checking for Apache module support via DSO through APXS... found at 
/var/tmp/portage/subversion-0.10_pre1/work/tmpinstall_httpd/bin/apxs 
checking for Berkeley DB in 
/var/tmp/portage/subversion-0.10_pre1/work/tmpinstall_db-4.0.14... no 
configure: error: Could not find Berkeley DB 4.0.14. 
 
!!! ERROR: dev-util/subversion-0.10_pre1 failed. 
!!! Function src_compile_svn, Line 145, Exitcode 1 
!!! ./configure of subversion failed 

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Patrick Kursawe (RETIRED) gentoo-dev 2003-05-07 09:40:50 UTC
Still compiling, but seems it has passed the configure part. The Berkeley DB is no normal dependency, it is extracted and compiled during emerge (not installed as a package). Could you please sync again and retry? If it still fails, please provide a bit more information (like emerge info output).
Comment 2 Patrick Kursawe (RETIRED) gentoo-dev 2003-05-07 10:03:13 UTC
Compiling went fine, on my system the installation is the problem - the apache files can't be copied.

cp bails out saying:

cp: failed to preserve ownership for /var/tmp/portage/subversion-0.10_pre1/image//usr/svn/lib/libapr.so.0: No such file or directory
cp: failed to preserve ownership for /var/tmp/portage/subversion-0.10_pre1/image//usr/svn/lib/libaprutil.so.0: No such file or directory
cp: failed to preserve ownership for /var/tmp/portage/subversion-0.10_pre1/image//usr/svn/lib/libaprutil.so: No such file or directory
cp: failed to preserve ownership for /var/tmp/portage/subversion-0.10_pre1/image//usr/svn/lib/libapr.so: No such file or directory

Could you please try if the ~x86 versions are more stable? :-)
Comment 3 François Dupoux 2003-05-07 11:23:40 UTC
Sorry, it still stops: (after "emerge sync") 
checking for Berkeley DB in 
/var/tmp/portage/subversion-0.10_pre1/work/tmpinstall_db-4.0.14... no 
configure: error: Could not find Berkeley DB 4.0.14. 
 
!!! ERROR: dev-util/subversion-0.10_pre1 failed. 
!!! Function src_compile_svn, Line 145, Exitcode 1 
!!! ./configure of subversion failed 
 
Comment 4 Patrick Kursawe (RETIRED) gentoo-dev 2003-05-08 03:37:28 UTC
You still did not give the emerge info output...
Another question: Please run ebuild /path/to/subversion/ebuild compile and give the output of

ls /var/tmp/portage/subversion-0.10_pre1/work/tmpinstall_db-4.0.14/lib/

Comment 5 Alessandro Pisani 2003-05-08 05:26:05 UTC
don't use subversion-0.10.x : it's very old and broken.
try the new 0.21.0-r1 ebuild: it works fine (even if currently masked) and had ben recently (some days ago) subject to improvements and fixes
Comment 6 fdupoux 2003-05-08 05:40:19 UTC
Why do portage keep this old ebuild, and make it default ? 
Isn't it possible to delete it, and make the new version unmasked ? 
Comment 7 Patrick Kursawe (RETIRED) gentoo-dev 2003-05-08 05:47:57 UTC
Karl, I think this should be masked. Any comments?
Comment 8 Patrick Kursawe (RETIRED) gentoo-dev 2003-05-08 06:01:39 UTC
My problem in comment #2 is because of sandbox in FEATURES. cp -a does not work then.
Comment 9 Patrick Kursawe (RETIRED) gentoo-dev 2003-05-08 07:20:02 UTC
Since this version is stinking, I've set it to ~arch and have added a warning in the ChangeLog. Perhaps someone still wants to try this, so I won't delete it for now, but it definitely is not stable. If someone wants to fix it, feel free to do so.