Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 205558 - app-backup/boxbackup-0.11rc8 version bump
Summary: app-backup/boxbackup-0.11rc8 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: App-Backup Team
URL: http://lists.warhead.org.uk/pipermail...
Whiteboard:
Keywords:
: 231760 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-13 04:03 UTC by Rajiv Aaron Manglani (RETIRED)
Modified: 2010-11-22 02:00 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
boxbackup 0.11 rc2 ebuild (boxbackup-0.11_rc2.ebuild,2.26 KB, text/plain)
2008-09-22 02:25 UTC, David Kaufman
Details
boxbackup 0.11 rc2 gentoo patch (boxbackup-0.11_rc2-gentoo.patch,26.32 KB, text/plain)
2008-09-22 02:26 UTC, David Kaufman
Details
boxbackup 0.11 rc2 gentoo patch (boxbackup-0.11_rc2-gentoo.patch,26.72 KB, patch)
2008-09-22 03:00 UTC, David Kaufman
Details | Diff
166050: boxbackup 0.11 rc2 ebuild (boxbackup-0.11_rc2.ebuild,2.45 KB, text/plain)
2008-10-01 00:50 UTC, David Kaufman
Details
extended the patch, patches configure.ac (boxbackup-0.11_rc2-gentoo.patch,27.08 KB, patch)
2008-10-10 10:27 UTC, Martin Bürge
Details | Diff
boxbackup 0.11 rc2 gentoo patch (boxbackup-0.11_rc2-gentoo.patch,28.42 KB, patch)
2008-10-18 13:14 UTC, David Kaufman
Details | Diff
boxbackup 0.11 rc2 ebuild (boxbackup-0.11_rc2.ebuild,2.80 KB, text/plain)
2008-10-18 13:16 UTC, David Kaufman
Details
Fixed ebuild (boxbackup-0.11_rc8-r1.ebuild,1.75 KB, text/plain)
2010-08-25 22:54 UTC, Lars
Details
build.log of failed build (build.log,36.93 KB, text/plain)
2010-08-29 16:43 UTC, Lars
Details
This ebuild fixes the wrong installation of man pages (boxbackup-0.11_rc8-r1.ebuild,2.18 KB, text/plain)
2010-08-29 16:49 UTC, Lars
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rajiv Aaron Manglani (RETIRED) gentoo-dev 2008-01-13 04:03:44 UTC
[Box Backup] Announcing 0.11 Release Candidate 1
Chris Wilson boxbackup@ fluffy.co.uk
Sat, 12 Jan 2008 19:03:27 +0000 (GMT)


Hi all,

Nearly two years after the release of Box Backup 0.10, I'm pleased and 
proud to announce the first release candidate for Box Backup 0.11, also 
known as 0.11rc1.

I'd really appreciate it if you'd consider testing the release candidate 
for us. Please read the following Wiki pages before doing so:

* http://www.boxbackup.org/trac/wiki/BetaReleases
* http://www.boxbackup.org/trac/wiki/011 (Upgrading to 0.11)

You can download it from:

* http://www.boxbackup.org/svn/box/packages/boxbackup-0.11rc1.tgz
* http://www.boxbackup.org/svn/box/RELEASE/0.11rc1/ (SVN branch)

If no problems are reported in this release, I hope to make 0.11 final 
available around 14th February.

I've updated the website, www.boxbackup.org, to link to this release, as 
well as the wiki in various places. I hope that was the right thing to do, 
and that I haven't stepped on anybody's toes. Please feel free to pick 
over the changes and tell me if I did anything wrong. I also added 
developer and tester credits for 0.11, I hope I didn't miss anyone, but 
please tell me if I did.

Cheers, Chris.
-- 
_____ __     _
\  __/ / ,__(_)_  | Chris Wilson <0000 at qwirx.com> - Cambs UK |
/ (_/ ,\/ _/ /_ \ | Security/C/C++/Java/Perl/SQL/HTML Developer |
\ _/_/_/_//_/___/ | We are GNU-free your mind-and your software |
Comment 1 Fabian Groffen gentoo-dev 2008-01-15 12:46:37 UTC
@rajiv: I don't use boxbackup any more, so feel free to bump and/or take over maintenance of boxbackup.
Comment 2 David Kaufman 2008-09-22 02:25:43 UTC
Created attachment 166050 [details]
boxbackup 0.11 rc2 ebuild
Comment 3 David Kaufman 2008-09-22 02:26:36 UTC
Created attachment 166052 [details]
boxbackup 0.11 rc2 gentoo patch
Comment 4 David Kaufman 2008-09-22 02:31:22 UTC
The boxbackup team is now up to 0.11rc2. They say: "It would be great to have 0.11rc2 in Gentoo, as 0.10 is so outdated."

I took a shot at tweaking the ebuild to work for 0.11rc2, mostly a matter of handling an extra version component, and regenerating the patch that moves the default configuration directory to /etc/boxbackup and the install directory to /usr/sbin. The prior gcc41-noll patch doesn't appear to be necessary, upstream has incorporated the change.

I'm no expert at this stuff and would be very happy to have someone who is look over these changes.
Comment 5 David Kaufman 2008-09-22 03:00:25 UTC
Created attachment 166054 [details, diff]
boxbackup 0.11 rc2 gentoo patch

Patch was missing one clause, which I have fixed
Comment 6 David Kaufman 2008-10-01 00:50:23 UTC
Created attachment 166878 [details]
166050: boxbackup 0.11 rc2 ebuild

Added a warning about 0.11's impact on existing NotifyScripts, since emails saying "BACKUP PROBLEM" can be disturbing. Changed HOMEPAGE to point to the new boxbackup.org home page.
Comment 7 Anton 2008-10-03 10:41:47 UTC
I have updated my boxbackup-0.10 to the boxbackup-0.11rc2(2008-10-01 00:50) with patch (2008-09-22 03:00) with the following problems:

1. I have missed /etc/init.d/bbstored and /etc/init.d/bbackupd scripts. They were after fresh install (without configuring) from 0.10 ebuild, but are missing after update.

2. Box backup got compiled to use /etc/box, not the /etc/boxbackup directory. Therefore i need to use -c switch to run programs, or simply to use symlink from /etc/boxbackup to /etc/box
Comment 8 Fabian Groffen gentoo-dev 2008-10-03 10:52:30 UTC
Is there anyone here that would like to become a proxy maintainer?
Comment 9 David Kaufman 2008-10-03 12:49:27 UTC
(In reply to comment #7)
> 1. I have missed /etc/init.d/bbstored and /etc/init.d/bbackupd scripts.

I think you need to copy these from /usr/portage/app-backup/boxbackup/files/bb*.rc to /usr/local/portage/app-backup/boxbackup/files . I don't understand how this really works in Portage, I guess.

> 2. Box backup got compiled to use /etc/box, not the /etc/boxbackup directory.

Sounds like the patch didn't get properly applied, either. Do you have a log of the emerge output?

Thanks

Comment 10 Martin Bürge 2008-10-10 09:28:26 UTC
Hi there

I can't install boxbackup-0.11_rc2.

 * Failed Running aclocal !
 *                         
 * Include in your bugreport the contents of:
 *
 * /var/tmp/portage/app-backup/boxbackup-0.11_rc2/temp/aclocal-8523.out

***** aclocal *****
***** aclocal -I infrastructure/m4

configure.ac:286: error: AC_SUBST: `bindir_expanded sysconfdir_expanded localstatedir_expanded' is not a valid shell variable name
configure.ac:286: the top level
autom4te-2.63: /usr/bin/m4 failed with exit status: 1
aclocal-1.10: autom4te failed with exit status: 1

Any idea?
Comment 11 Martin Bürge 2008-10-10 10:27:35 UTC
Created attachment 167856 [details, diff]
extended the patch, patches configure.ac

Ok, i could solve it myself.
It's my first patch so can you have a lookt at it?
I could compile now boxbackup-0.11_rc2. :)
Comment 12 Junyx 2008-10-15 19:07:49 UTC
Did someone test compiling boxbackup-0.11_rc2 with gcc-4.3.2?
It throws several errors for me - not usable ATM.
Comment 13 David Kaufman 2008-10-18 11:06:02 UTC
(In reply to comment #12)
> Did someone test compiling boxbackup-0.11_rc2 with gcc-4.3.2?
> It throws several errors for me - not usable ATM.

Upstream has just checked in changes to allow compiling under gcc 4.3.2, but they're still only in svn. Perhaps the next release candidate will pick them up.
Comment 14 David Kaufman 2008-10-18 13:14:53 UTC
Created attachment 168918 [details, diff]
boxbackup 0.11 rc2 gentoo patch

(In reply to comment #7)
> 2. Box backup got compiled to use /etc/box, not the /etc/boxbackup directory.

The patch was wrong. (I had modified .h files that were getting generated from .h.in files, so of course my changes got overwritten.) I have fixed it, and was more thorough in my testing this time.

I also included Martin's change from comment #11.
Comment 15 David Kaufman 2008-10-18 13:16:47 UTC
Created attachment 168920 [details]
boxbackup 0.11 rc2 ebuild

0.11 has a bunch of new documentation, added it to the ebuild so it goes in /usr/share/doc.
Comment 16 Craig Servin 2009-03-17 17:10:37 UTC
How do you use the ebuilds attached to this bug report.  Sorry for the newbie question, but I just can't seem to figure it out.
Comment 17 Thilo Bangert (RETIRED) (RETIRED) gentoo-dev 2009-04-04 20:49:03 UTC
*** Bug 231760 has been marked as a duplicate of this bug. ***
Comment 18 Thilo Bangert (RETIRED) (RETIRED) gentoo-dev 2009-04-04 20:54:16 UTC
you can use the posted ebuild by putting the ebuild into
/usr/portage/app-backup/boxbackup
and the patch file into 
/usr/portage/app-backup/boxbackup/files
(i think)
Comment 19 Jeroen Roovers gentoo-dev 2010-05-07 06:26:39 UTC
app-backup/boxbackup-0.11rc8 is in the tree, with a nice patch to fix a
-D_FORTIFY_SOURCE=2 issue in the test suite.
Comment 20 Lars 2010-08-25 22:54:40 UTC
Created attachment 244615 [details]
Fixed ebuild

(In reply to comment #19)
> app-backup/boxbackup-0.11rc8 is in the tree

The ebuild does not work any more since executables will be moved by 
parcels/boxbackup-0.11rc8-backup-client-linux-gnu/install-backup-client 
The skript fails to do so when the executables are moved by portage.



diff boxbackup-0.11_rc8-r1.ebuild /usr/portage/app-backup/boxbackup/boxbackup-0.11_rc8.ebuild 
3c3
< # $Header: /var/cvsroot/gentoo-x86/app-backup/boxbackup/boxbackup-0.11_rc8-r1.ebuild,v 1.2 2010/06/07 12:53:19 flameeyes Exp $
---
> # $Header: /var/cvsroot/gentoo-x86/app-backup/boxbackup/boxbackup-0.11_rc8.ebuild,v 1.2 2010/06/07 12:53:19 flameeyes Exp $
46a47,50
> 
>       # move executables from /usr/bin to /usr/sbin, as configuration of
>       # this is unfortunately not optimal
>       mv "${D%/}${EPREFIX}/usr/bin" "${D%/}${EPREFIX}/usr/sbin" || die "could not move files from bin to sbin"
Comment 21 Lars 2010-08-29 16:43:36 UTC
Created attachment 245247 [details]
build.log of failed build

The build.log documents the former failure of moving binaries from bin to sbin.
Comment 22 Lars 2010-08-29 16:49:27 UTC
Created attachment 245248 [details]
This ebuild fixes the wrong installation of man pages

The former ebuild allows boxbackup to install its man pages to /usr/man/man5 and /usr/man/man8 resprectively. This ebuild corrects this by moving the man pages to /usr/share/man/man5 and /usr/share/man/man8 where sys-apps/man looks for them.
Comment 23 Thomas Capricelli 2010-11-22 01:51:59 UTC
er.. i dont understand. It seems i'm not alone having problem installing it, although this ticket is closed.. what's going on ? Should i open another ticket ? There's also/already ticket #299411 which describe the same problem as i have, which seems the same as several comments here ?
Comment 24 Thomas Capricelli 2010-11-22 02:00:58 UTC
mm, and actually, the ebuild boxbackup-0.11_rc8-r1.ebuild found here does work. Why isn't it in the tree ? It feels weird to have to use an attachement of a closed ticket to get the software installed.