Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 205139 - x11-drivers/linuxwacom-0.7.8_p3 doesn't compile w/ gcc-3.4.6
Summary: x11-drivers/linuxwacom-0.7.8_p3 doesn't compile w/ gcc-3.4.6
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High trivial (vote)
Assignee: X11 External Driver Maintainers
Depends on:
Reported: 2008-01-10 03:22 UTC by Alan Somers
Modified: 2008-02-24 23:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Alan Somers 2008-01-10 03:22:01 UTC
src/xdrv/ in linuxwacom adds -Wno-variadic-macros to the CFLAGS.  However, this option is not present in gcc-3.  AFAICT, the first gcc version to include it is gcc-4.0.0 (  gcc-3.4.6 certainly does not have it.

On my computer, linuxwacom-0.7.8_p3 compiles fine with gcc-4.2.2 but not with gcc-3.4.6

linuxwacom-0.7.4-3 does not use that option, and compiles with gcc-3.4.6 .

0.7.8_p3 appears to build fine if you remove that option.  It is, after all, only a warning.  However, I don't know how to properly create a patch and add it to the ebuild.

I think we should create such a patch, or at least put a dependency check in the ebuild.

Reproducible: Always

Steps to Reproduce:
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2008-01-10 05:37:50 UTC
If hardened wan't to fix it (no, dependency won't work)... noone else cares about gcc-3.4.x now.
Comment 2 solar (RETIRED) gentoo-dev 2008-01-10 20:17:45 UTC
Don't assign bugs to hardened simply cuz a pkg only compiles with gcc-4.x (We 
don't care) It's the maintainers job to make his/her pkg compatiable with the 
gcc's that gentoo supports. Hardened is far from the only one who uses gcc-3.x
Comment 3 Robert Buchholz (RETIRED) gentoo-dev 2008-02-08 21:50:09 UTC
I committed linuxwacom-0.7.8_p3-r1 which should take care of this. However, not having a gcc-3 system handy I cannot test.

Please report back whether it works now. 
Comment 4 Alan Somers 2008-02-10 01:27:28 UTC
I can successfully compile linuxwacom-0.7.8_p3-r1 with both gcc-3.4.6 and gcc-4.2.2
Comment 5 Robert Buchholz (RETIRED) gentoo-dev 2008-02-12 00:39:45 UTC
great, thanks.
Comment 6 Jan 2008-02-24 23:13:24 UTC
(In reply to comment #3)
> Please report back whether it works now. 

I ran into the same problem. Your version -r1 compiles without errors on my system (gcc-3.4.6).

Thanks for the patch. :)