Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 204945 - x11-libs/qt-gui-4.4-rc1: missing use flags gif jpg
Summary: x11-libs/qt-gui-4.4-rc1: missing use flags gif jpg
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Qt Bug Alias
Depends on:
Reported: 2008-01-08 20:08 UTC by Alexandre Bique
Modified: 2008-02-03 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Bique 2008-01-08 20:08:50 UTC
the splitted ebuild for qt 4.4-rc1 misses use flags for gif and jpg

Reproducible: Always
Comment 1 Alexandre Bique 2008-01-08 22:09:27 UTC
by the way, qt also need use flags exemples
Comment 2 Caleb Tennis (RETIRED) gentoo-dev 2008-01-08 22:11:46 UTC
we purposely got rid of those flags after previous discussion.  we couldn't come up with good cases where it made sense to use them.

as for examples, I'd love it if you were able to provide a patch.  this is a technical detail I haven't worked out yet and it's not trivial to solve.
Comment 3 Alexandre Bique 2008-01-08 22:15:29 UTC
At the moment, qt 4.4 doesn't displays jpg
So i can expect future ebuilds to enable jpg and gif by default ?
Comment 4 Caleb Tennis (RETIRED) gentoo-dev 2008-01-08 22:26:10 UTC

we pass -qt-gif -system-libpng -system-libjpeg by default

so it should be working.

did your configure fail on those for some reason?
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2008-02-03 01:52:58 UTC
Get back to us please... this is enabled unconditionally and just works for me (TM).
Comment 6 Alexandre Bique 2008-02-03 13:06:55 UTC
I reinstalled qt-4.4 and it worked this time.
Maybe it was a paludis bug ???

Sorry guys :'(