Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 204297 - www-misc/zoneminder-1.23.1 version bump
Summary: www-misc/zoneminder-1.23.1 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Web Application Packages Maintainers
URL:
Whiteboard:
Keywords: EBUILD
: 206348 (view as bug list)
Depends on: 204307
Blocks:
  Show dependency tree
 
Reported: 2008-01-04 17:39 UTC by Michele Schiavo
Modified: 2008-02-23 14:40 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
zm_mpeg.patch (zm_mpeg.patch,350 bytes, text/plain)
2008-01-04 17:41 UTC, Michele Schiavo
Details
zm_mpeg.patch (zm_mpeg.patch,350 bytes, text/plain)
2008-01-04 18:10 UTC, Michele Schiavo
Details
zoneminder-1.23.1.ebuild (zoneminder-1.23.1.ebuild,2.42 KB, text/plain)
2008-01-04 18:10 UTC, Michele Schiavo
Details
zm_create.sql.in.diff (zm_create.sql.in.diff,18.45 KB, text/plain)
2008-01-04 18:12 UTC, Michele Schiavo
Details
Makefile.am.patch (Makefile.am.patch,833 bytes, text/plain)
2008-01-04 18:13 UTC, Michele Schiavo
Details
PHP-Serialization-0.27.ebuild (PHP-Serialization-0.27.ebuild,519 bytes, text/plain)
2008-01-04 18:40 UTC, Michele Schiavo
Details
zm_mpeg_ofc.patch (zm_mpeg_ofc.patch,280 bytes, text/plain)
2008-01-04 18:51 UTC, Michele Schiavo
Details
zoneminder-1.23.1.ebuild (zoneminder-1.23.1.ebuild,2.44 KB, text/plain)
2008-01-04 18:53 UTC, Michele Schiavo
Details
postinstall-2.txt (postinstall-2.txt,643 bytes, text/plain)
2008-01-04 18:54 UTC, Michele Schiavo
Details
postupgrade.txt (postupgrade.txt,463 bytes, text/plain)
2008-01-04 18:55 UTC, Michele Schiavo
Details
init.d script file (init.d,360 bytes, text/plain)
2008-01-08 19:25 UTC, Michele Schiavo
Details
conf.d (conf.d,138 bytes, text/plain)
2008-01-08 19:27 UTC, Michele Schiavo
Details
zoneminder-1.23.1.ebuild (zoneminder-1.23.1.ebuild,2.52 KB, text/plain)
2008-01-22 21:59 UTC, INODE64 Sistemas
Details
zm_remote_camera.patch (zm_remote_camera.patch,1.31 KB, text/plain)
2008-02-06 08:49 UTC, Frank Eichentopf
Details
zoneminder-1.23.1.ebuild (zoneminder-1.23.1.ebuild,2.56 KB, text/plain)
2008-02-06 08:50 UTC, Frank Eichentopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michele Schiavo 2008-01-04 17:39:24 UTC
new ebuild with new patch for zoneminder-1.23.1

Reproducible: Always
Comment 1 Michele Schiavo 2008-01-04 17:41:38 UTC
Created attachment 140090 [details]
zm_mpeg.patch
Comment 2 Michele Schiavo 2008-01-04 18:10:27 UTC
Created attachment 140094 [details]
zm_mpeg.patch
Comment 3 Michele Schiavo 2008-01-04 18:10:45 UTC
Created attachment 140095 [details]
zoneminder-1.23.1.ebuild
Comment 4 Michele Schiavo 2008-01-04 18:12:20 UTC
Created attachment 140096 [details]
zm_create.sql.in.diff
Comment 5 Michele Schiavo 2008-01-04 18:13:39 UTC
Created attachment 140098 [details]
Makefile.am.patch
Comment 6 Michele Schiavo 2008-01-04 18:14:00 UTC
emerge zoneminder -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] www-misc/zoneminder-1.23.1  USE="apache2 mpeg vhosts -X10" 0 kB [1]
Comment 7 Michele Schiavo 2008-01-04 18:14:15 UTC
emerge --info
Portage 2.1.3.19 (default-linux/amd64/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r3 x86_64)
=================================================================
System uname: 2.6.23-gentoo-r3 x86_64 Intel(R) Pentium(R) D CPU 3.40GHz
Timestamp of tree: Thu, 03 Jan 2008 19:46:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -mtune=nocona -march=nocona -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/bind /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -mtune=nocona -march=nocona -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg collision-protect_ distcc_ distlocks maketest_ metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.rnl.ist.utl.pt/pub/gentoo/ ftp://ftp.gentoo.mesh-solutions.com/gentoo/ ftp://fido.online.kz/gentoo/pub http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LINGUAS="en en_GB es es_ES it it_IT"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="16bit 64bit X a52 aalib acpi ads aiglx aim alsa amd64 apache2 apm audiofile avi bacula-console bash-completion berkdb bidi bitmap-fonts bittorrent bluetooth bonobo browserplugin bzip2 cairo caps cdda cddb cdparanoia cdr cgi chroot cjk cli cracklib crypt css cups curl dbus divx dlloader dri dts dv dvd dvdr dvdread dvi dynamic eds em emboss encode esd ethereal evo evolution exif expat faillog fam fame fbsplash ffmpeg firefox flac flash fontconfig foomaticdb fortran fping freetds freetype gaim gd gdbm gdm geoip gif gimp gimpprint glitz glut gmail gmedia gmp gno gnome gnutls gphoto2 gpm gsm gstreamer gtk gtk2 gtkhtml guile hal hddtemp howl iconv idea idn imagemagick imap imlib ipod isdnlog ithreads java jpeg lcms libcaca libclamav libedit libnotify libwww live lm_sensors logrotate logwatch lzo lzw lzw-tiff mad maildir maildrop matroska mhash midi mikmod mime ming mjpeg mmx mng motif mozilla mozsvg mpeg mplayer mpm-prefork msn mudflap musicbrainz mysql nautilus ncurses new-login nfs ng nls nptl nptlonly nsplugin obex offensive oggvorbis opengl openmp opensslcrypt pam pcre pda pdf pdflib perl php png pop ppds pppd python qmail qt3support qt4 quicktime quotas readline realmedia recode reflection regex rtc samba scanner sdl server session simplexml slang smp sndfile sound sox spamassassin speex spell spl sse sse2 ssl ssse2 ssse3 subtitles svg symlink sysfs syslog tcltk tcpd tetex threads threadsafe tiff truetype truetype-fonts type1-fonts udev unicode usb v4l2 vcd vhosts vim-syntax vnc vorbis wifi winbind wmp wxgtk1 wxwindows xcomposite xml xml2 xmlreader xmlwriter xorg xpm xscreensaver xv xvid zip zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB es es_ES it it_IT" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 8 Michele Schiavo 2008-01-04 18:40:46 UTC
Created attachment 140101 [details]
PHP-Serialization-0.27.ebuild
Comment 9 Michele Schiavo 2008-01-04 18:51:24 UTC
Created attachment 140105 [details]
zm_mpeg_ofc.patch
Comment 10 Michele Schiavo 2008-01-04 18:53:46 UTC
Created attachment 140108 [details]
zoneminder-1.23.1.ebuild

add DEPEND of dev-perl/PHP-Serialization
Comment 11 Michele Schiavo 2008-01-04 18:54:46 UTC
Created attachment 140109 [details]
postinstall-2.txt
Comment 12 Michele Schiavo 2008-01-04 18:55:52 UTC
Created attachment 140111 [details]
postupgrade.txt
Comment 13 Michele Schiavo 2008-01-04 18:57:54 UTC
emerge without error on other pc


emerge zoneminder -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] www-misc/zoneminder-1.23.1  USE="apache2 mpeg vhosts -X10" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB




emerge --info 
Portage 2.1.3.19 (default-linux/amd64/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r5 x86_64)
=================================================================
System uname: 2.6.23-gentoo-r5 x86_64 Intel(R) Core(TM)2 Duo CPU E6300 @ 2.66GHz
Timestamp of tree: Thu, 03 Jan 2008 18:30:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -mtune=nocona -march=nocona -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/bind /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -mtune=nocona -march=nocona -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg collision-protect_ distcc distlocks maketest metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.linux.ee/pub/gentoo/distfiles/"
LANG="it_IT.UTF-8"
LINGUAS="en en_GB es es_ES it it_IT"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="16bit 64bit X a52 aac aalib acpi aiglx aim alsa amd64 amr amrnb amrwb apache2 apm audiofile avi bacula-console bash-completion beagle berkdb bidi bitmap-fonts bittorrent bluetooth bonobo branding browserplugin bzip2 cairo caps cdda cddb cdio cdparanoia cdr cgi chroot cjk cli cracklib crypt css cups curl dbus divx dlloader dri dts dv dvd dvdr dvdread dvi dynamic eds em emboss encode esd ethereal evo evolution exif expat faillog fam fame fbsplash ffmpeg firefox flac flash fontconfig foomaticdb fortran fping freetds freetype ftp gaim gd gdbm gdm geoip gif gimp gimpprint glitz glut gmail gmedia gmp gno gnome gnutls gphoto2 gpm gsm gstreamer gtk gtk2 gtkhtml guile hal hddtemp howl iconv idea idn ieee1394 imagemagick imap imlib ipod isdnlog ithreads java jpeg lame lcms libcaca libclamav libedit libnotify libwww live lm_sensors logrotate logwatch lzo lzw lzw-tiff mad maildir maildrop matroska mhash midi mikmod mime ming mjpeg mmx mng mono motif mozilla mozsvg mp3 mpeg mplayer mpm-prefork msn mudflap musicbrainz mysql nautilus ncurses network new-login nfs ng nls nptl nptlonly nsplugin nvidia obex offensive ogg oggvorbis openal opengl openmp opensslcrypt pam pcre pda pdf pdflib perl php png pop ppds pppd python qmail qt3support qt4 quicktime quotas readline realmedia recode reflection regex remote rtc samba scanner sdl server session simplexml slang smp sndfile sound sox spamassassin speex spell spl sse sse2 ssl ssse2 ssse3 subtitles svg symlink sysfs syslog tcltk tcpd tetex theora threads threadsafe tiff toolbar truetype truetype-fonts type1-fonts udev unicode usb v4l2 vcd vhosts vim-syntax vnc vorbis wifi wmf wmp wxgtk1 wxwindows x264 xanim xcomposite xml xml2 xmlreader xmlwriter xorg xpm xscreensaver xv xvid xvmc zip zlib" ALSA_CARDS="intel8x0 usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB es es_ES it it_IT" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Comment 14 Michele Schiavo 2008-01-04 19:04:55 UTC
zoneminder need PHP-Serialization

see http://bugs.gentoo.org/show_bug.cgi?id=204307
Comment 15 Renat Lumpau (RETIRED) gentoo-dev 2008-01-08 18:57:12 UTC
Thanks! I'll look at this when bug 204307 is ready.
Comment 16 Michele Schiavo 2008-01-08 19:25:53 UTC
Created attachment 140496 [details]
init.d script file
Comment 17 Michele Schiavo 2008-01-08 19:27:30 UTC
Created attachment 140497 [details]
conf.d
Comment 18 Jakub Moc (RETIRED) gentoo-dev 2008-01-17 17:34:53 UTC
*** Bug 206348 has been marked as a duplicate of this bug. ***
Comment 19 INODE64 Sistemas 2008-01-22 21:59:14 UTC
Created attachment 141605 [details]
zoneminder-1.23.1.ebuild

add flag debug
require libpcre and gnutls

- libpcre.a may be required for remote/network camera support
- gnutls-openssl.a is required for authenticated streaming
Comment 20 Frank Eichentopf 2008-02-06 08:49:00 UTC
Created attachment 142775 [details]
zm_remote_camera.patch

little patch for the latest zoneminder release to work with Sparklan 
CAS-861, Sparklan CAS-861W, Trendnet TV-IP301 and Trendnet TV-IP301W which 
send a wrong mimetype while fetching a image from the device
Comment 21 Frank Eichentopf 2008-02-06 08:50:41 UTC
Created attachment 142777 [details]
zoneminder-1.23.1.ebuild

modified ebuild for zm_remote_camera.patch
Comment 22 Benedikt Böhm (RETIRED) gentoo-dev 2008-02-23 14:40:51 UTC
in cvs, thanks