Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 204102 - >=sys-fs/e2fsprogs-1.40.4 doesn't build with uclibc
Summary: >=sys-fs/e2fsprogs-1.40.4 doesn't build with uclibc
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High minor with 1 vote (vote)
Assignee: Embedded Gentoo Team
URL:
Whiteboard:
Keywords:
: 211650 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-02 18:53 UTC by Stefan Hellermann
Modified: 2009-07-22 22:02 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
e2fsprogs-1.40.5-r1.patch (e2fsprogs-1.40.5-r1.patch,478 bytes, patch)
2008-02-09 15:46 UTC, Stefan Hellermann
Details | Diff
correct IUSE (e2fsprogs-libs-build-uclibc-IUSE.diff,441 bytes, patch)
2009-02-07 22:11 UTC, Bertrand Jacquin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Hellermann 2008-01-02 18:53:32 UTC
I've tried building e2fsprogs-1.40.4 on my uclibc buildhost:

making all in lib/uuid
	MKDIR elfshared
	CC clear.c
	CC compare.c
	CC copy.c
	CC gen_uuid.c
	CC isnull.c
	CC pack.c
	CC parse.c
	CC unpack.c
	CC unparse.c
	CC uuid_time.c
	GEN_LIB libuuid.a
	GEN_ELF_SOLIB libuuid.so.1.2
	CC tst_uuid.o
	LD tst_uuid
	LD uuid_time
../../lib/libuuid.so: undefined reference to `___tls_get_addr'
collect2: ld returned 1 exit status
make[2]: *** [uuid_time] Error 1
make[1]: *** [all-libs-recursive] Error 1
make: *** [all] Error 2

Probably an embedded/uclibc related problem, in e2fsprogs-1.40.4 the way uuids are generated has changed (http://e2fsprogs.sourceforge.net/e2fsprogs-release.html#1.40.4). e2fsprogs-1.40.3 works fine!

Reproducible: Always

Steps to Reproduce:




$ emerge --info
Portage 2.1.4_rc14 (uclibc/x86, gcc-4.2.2, uclibc-0.9.28.3-r2, 2.6.24-rc6-git2 i686)
=================================================================
System uname: 2.6.24-rc6-git2 i686 Pentium III (Coppermine)
Timestamp of tree: Wed, 02 Jan 2008 15:00:03 +0000
app-shells/bash:     3.2_p33
dev-lang/python:     2.5.1-r4
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.61-r1
sys-devel/automake:  1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i386-gentoo-linux-uclibc"
CFLAGS="-O2 -march=pentium3 -mtune=k8 -pipe -fomit-frame-pointer -mno-tls-direct-seg-refs"
CHOST="i386-gentoo-linux-uclibc"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium3 -mtune=k8 -pipe -fomit-frame-pointer -mno-tls-direct-seg-refs"
DISTDIR="/var/db/distfiles"
FEATURES="autoconfig distlocks metadata-transfer nodoc noinfo noman parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/"
LDFLAGS="-Wl,-z,relro"
MAKEOPTS="-j3 -s"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/db/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="minimal nocxx unicode x86" ELIBC="uclibc" KERNEL="linux" USERLAND="GNU"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Christoph Gysin 2008-01-30 06:50:03 UTC
Can confirm this, have the same issue here.
Comment 2 Luca Lesinigo 2008-01-31 13:10:35 UTC
I can confirm that too:
- uclibc/x86 profile
- CHOST="i686-gentoo-linux-uclibc"
- CFLAGS="-Os -march=c3-2 -pipe"
- USE="minimal savedconfig -mudflap"

Same error:
../../lib/libuuid.so: undefined reference to `___tls_get_addr'

temp workaround:
- echo '>=sys-fs/e2fsprogs-1.40.4' >> /etc/portage/package.mask
- 1.40.3 compiles and works fine
Comment 3 Stefan Hellermann 2008-01-31 13:55:43 UTC
same error with sys-fs/e2fsprogs-1.40.5-r1
Comment 4 Tavis Rudd 2008-01-31 19:37:37 UTC
I can confirm this as well on an old box that I'm trying to update.  

gcc 3.3.6, glibc 2.3.5-r1 CHOST="i686-pc-linux-gnu", CFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer"
/etc/make.profile -> ../usr/portage/profiles/default-linux/x86/2007.0/desktop/
Comment 5 Natanael Copa 2008-02-09 11:07:36 UTC
Adding  $(use_enable !elibc_uclibc tls) to econf fixes the problem.
Comment 6 Stefan Hellermann 2008-02-09 15:46:12 UTC
Created attachment 143042 [details, diff]
e2fsprogs-1.40.5-r1.patch

I can confirm this.

Tested-by: Stefan Hellermann <stefan@the2masters.de>
Comment 7 Habbit 2008-02-10 13:25:16 UTC
I have had the same problem: it's due to uclibc lacking TLS (i.e. thread local storage) support. The way to go would be to add a "tls" USE flag and keep it profile-disabled for uclibc systems. I see the current patch does something like that (i.e. disables TLS for uclibc), but it does not add a full-fledged USE flag. Is there a reason e2fsprogs can't be built without TLS in glibc?

Comment 8 Chris Allan 2008-02-17 17:02:12 UTC
Like #4, I'm having the same problem attempting to update to sys-fs/e2fsprogs-1.40.4 albeit on PPC.

emerge --info...

Portage 2.1.3.19 (default-linux/ppc/ppc32/2006.0, gcc-3.4.4, glibc-2.3.3.20040420-r2, 2.6.16-gentoo-r9 ppc)
=================================================================
System uname: 2.6.16-gentoo-r9 ppc 7450, altivec supported
Timestamp of tree: Sun, 10 Feb 2008 19:00:02 +0000
app-shells/bash:     3.2_p17-r1
dev-lang/python:     2.3.6-r4, 2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="ppc"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=750 -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -mcpu=750 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.blueyonder.co.uk/"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="alsa apache2 apm arts berkdb bitmap-fonts bonobo cdr cli cracklib crypt dri dvd eds emboss encode foomaticdb fortran gdbm gif gnome gpm gstreamer gtkhtml iconv imap imlib ipv6 isdnlog jpeg kde libwww mad midi mikmod motif mozilla mp3 mpeg mudflap ncurses nls nptl ogg openmp pam pcre perl png ppc pppd python qt4 quicktime readline reflection ruby sdl session spell spl ssl tcpd truetype truetype-fonts type1-fonts unicode vorbis xml xorg xv zlib" ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="chips dummy fbdev glint imstt mach64 mga nv r128 radeon s3 s3virge savage sisusb tdfx trident v4l voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

Comment 9 Natanael Copa 2008-02-21 14:38:44 UTC
patch is applied to both 1.40.5-r1 and 1.40.6. Please add to 1.40.4 too.

thanks!
Comment 10 Stefan Hellermann 2008-02-21 19:36:50 UTC
sadly it works only for 1.40.5-r1, 1.40.6 seems to need another patch, it fails later with the same "undefined reference to `___tls_get_addr'" error. I think this is possible an upstream bug, when I tell configure to not use tls it should not use it anywhere.
Comment 11 Natanael Copa 2008-02-22 07:43:12 UTC
(In reply to comment #10)
> sadly it works only for 1.40.5-r1, 1.40.6 seems to need another patch, it fails
> later with the same "undefined reference to `___tls_get_addr'" error. I think
> this is possible an upstream bug, when I tell configure to not use tls it
> should not use it anywhere.
> 

com_err-1.40.6 needs same fix to solve that. I don't know if we should file a new bug for that.

Isn't there a useflag "threads" or similar that could be used for turning off threading support systemwide?
Comment 12 hexa 2008-02-25 14:03:12 UTC
I have the same problem withhout uclib :-)

--
../../lib/libuuid.so: undefined reference to `___tls_get_addr'
collect2: ld returned 1 exit status
make[2]: *** [uuid_time] Error 1
make[2]: Leaving directory `/var/tmp/portage/sys-fs/e2fsprogs-1.40.4/work/e2fsprogs-1.40.4/lib/uuid'
make[1]: *** [all-libs-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/sys-fs/e2fsprogs-1.40.4/work/e2fsprogs-1.40.4'
make: *** [all] Error 2
--

Portage 2.1.3.19 (default-linux/x86/2006.1, gcc-3.3.5-20050130, glibc-2.3.4.20041102-r1, 2.6.15-gentoo-r1ISG i586)
=================================================================
System uname: 2.6.15-gentoo-r1ISG i586 Pentium MMX
Timestamp of tree: Sun, 24 Feb 2008 02:00:01 +0000
app-shells/bash:     3.2_p17
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.11.13-r1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.5, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.11-r4
sys-devel/libtool:   1.5.18-r1
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i386-pc-linux-gnu"
CFLAGS="-Os -mcpu=pentium-mmx -pipe"
CHOST="i386-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-Os -mcpu=pentium-mmx -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="berkdb bitmap-fonts cli cracklib crypt cups dri fortran gdbm gpm iconv isdnlog midi mudflap ncurses nls nptl nptlonly openmp pam pcre perl ppds pppd python readline reflection session spl ssl tcpd truetype-fonts type1-fonts unicode urandom x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2008-02-27 17:40:37 UTC
*** Bug 211650 has been marked as a duplicate of this bug. ***
Comment 14 Sergey Dryabzhinsky 2008-03-12 19:17:14 UTC
Support of 'tls' is need to be disables for uClibc build in 'sys-libs/com_err' too. And maybe in 'sys-libs/ss'.

As I add same line into com_err ebuild - e2fsprogs 1.40.(4-7) compiled successfuly.
Comment 15 solar (RETIRED) gentoo-dev 2008-03-12 19:49:16 UTC
(In reply to comment #14)
> Support of 'tls' is need to be disables for uClibc build in 'sys-libs/com_err'
> too. And maybe in 'sys-libs/ss'.

Then file a new bug. This bug is for e2fsprogs only.
Comment 16 Chris Wilson 2008-05-04 00:07:19 UTC
I'm afraid I have the same problem as #12, also without uclibc. I'm just trying to update my system from glibc 2.3.5/gcc 3.3.6 to latest versions. So far I upgraded gcc and now emerge -e system fails on e2fsprogs with the same error:

        LD uuid_time
`-mcpu=' is deprecated. Use `-mtune=' or '-march=' instead.
../../lib/libuuid.so: undefined reference to `___tls_get_addr'
collect2: ld returned 1 exit status
make[2]: *** [uuid_time] Error 1
make[2]: Leaving directory `/var/tmp/portage/sys-fs/e2fsprogs-1.40.8/work/e2fsprogs-1.40.8/lib/uuid'
make[1]: *** [all-libs-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/sys-fs/e2fsprogs-1.40.8/work/e2fsprogs-1.40.8'
make: *** [all] Error 2
 *
 * ERROR: sys-fs/e2fsprogs-1.40.8 failed.

I don't see anything wrong with my glibc configuration:

[ebuild   R   ] sys-libs/glibc-2.3.6-r5  USE="nls nptl nptlonly -build -erandom -glibc-compat20 -glibc-omitfp (-hardened) (-multilib) -profile (-selinux)" 0 kB                                         

Should this bug be reopened?
 
chris@top ~ $ emerge --info
Portage 2.1.4.4 (default-linux/x86/2006.1, gcc-4.1.2, glibc-2.3.6-r5, 2.6.22.1-vs2203rc1-acpi i686)
=================================================================
System uname: 2.6.22.1-vs2203rc1-acpi i686 AMD Athlon(tm) 64 Processor 3200+
Timestamp of tree: Sat, 03 May 2008 00:30:01 +0000
ccache version 2.3 [disabled]
app-shells/bash:     3.2_p17-r1
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.3
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.4.3-r4, 1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i386-pc-linux-gnu"
CFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer"
CHOST="i386-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/php/apache1-php5/ext-active/ /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acpi berkdb cli cracklib crypt cups dri fortran gdbm iconv isdnlog lm_sensors midi mudflap ncurses nls nptl nptlonly openmp pam pcre perl pmu ppds pppd python readline reflection session spl ssl tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 17 Natanael Copa 2008-05-05 07:11:17 UTC
(In reply to comment #16)
> I'm afraid I have the same problem as #12, also without uclibc. I'm just trying
> to update my system from glibc 2.3.5/gcc 3.3.6 to latest versions. So far I
> upgraded gcc and now emerge -e system fails on e2fsprogs with the same error:

maybe try emerge glibc before emerging system.
Comment 18 Chris Wilson 2008-05-05 12:10:19 UTC
I was following the instructions at http://www.gentoo.org/doc/en/change-chost.xml, which said I should upgrade gcc first, then make world, then glibc, then make world again. It was in the first make world that this failed.

I've started the process of upgrading glibc anyway and hope that I don't land in "severe side effects".
Comment 19 Bertrand Jacquin 2009-02-07 22:11:21 UTC
Created attachment 181284 [details, diff]
correct IUSE

 * QA Notice: USE Flag 'elibc_uclibc' not in IUSE for sys-libs/e2fsprogs-libs-1.41.3-r1

This patch correct build on uclic cross-compile env.
Comment 20 daid kahl 2009-07-12 10:10:13 UTC
> I've started the process of upgrading glibc anyway and hope that I don't land
> in "severe side effects".
> 

My recent experience is that >=e2fsprogs-1.40.9 will result in this error with glibc-2.3.x systems.  However, e2fsprogs-1.39-r2 (found on older mirrors) is fine for these libraries.  For one of my systems, it needs to run a linux-2.4 kernel and thus older glibc to avoid NPTL.  I appreciate that the bug will likely not be fixed upstream since it is resulting from running deprecated glibc. 

However, a blocker on the newer versions of e2fsprogs requiring a certain glibc version would be nice.
Comment 21 Tibor Vago 2009-07-22 22:02:25 UTC
I get the same error today with util-linux-2.16