Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 204081 - [RSYNC] rsync4.de.gentoo.org is out of sync
Summary: [RSYNC] rsync4.de.gentoo.org is out of sync
Status: RESOLVED FIXED
Alias: None
Product: Mirrors
Classification: Unclassified
Component: Server Problem (show other bugs)
Hardware: All Linux
: Highest critical (vote)
Assignee: Mirror Admins
URL:
Whiteboard:
Keywords:
: 220923 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-02 17:25 UTC by Raúl Porcel (RETIRED)
Modified: 2008-07-07 04:21 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raúl Porcel (RETIRED) gentoo-dev 2008-01-02 17:25:18 UTC
mirror is 15 days out of sync. Timestamp.chk says 18 december
Comment 1 Raúl Porcel (RETIRED) gentoo-dev 2008-01-03 12:42:20 UTC
Jens, can you check?
Comment 2 Jens Ott 2008-01-03 13:22:07 UTC
(In reply to comment #1)
> Jens, can you check?
> 

Hi,

I forwarded your mail to the guys who are responsible for the mirrors now. I hope they'll fix it and reply soon. 

Please use mirrors@plusserver.de in future on issues on the mirrors, I changed the department and have no longer access to the mirrors.

Kind regards
Jens
Comment 3 Raúl Porcel (RETIRED) gentoo-dev 2008-01-03 18:56:10 UTC
Seems to work fine. 
Jens, could you please create a bugzilla account for that address and subscribe it to the mailing list?

Thanks, i'll leave this bug open so the contact can be changed
Comment 4 Guido S. Nickels 2008-01-03 22:33:42 UTC
Hi!

The mirror is sync now, there was a stale pid file preventing the sync-script to start :o/

Cheers!

Guido
Comment 5 Shyam Mani (RETIRED) gentoo-dev 2008-01-04 15:50:37 UTC
Still not in sync.

IP: rsync4.de.gentoo.org
Checked at (UTC)   Timestamp
================================================
     15:49:36   Fri, 04 Jan 2008 01:16:01 +0000

Please look into this.
Comment 6 Raúl Porcel (RETIRED) gentoo-dev 2008-01-28 19:32:25 UTC
HOSTNAME: rsync4.de.gentoo.org
IP: 85.25.128.62
   Checked at      |      Timestamp     |      Status
================================================
Mon, 28 Jan 2008 19:31:25 +0000   |     Sat, 19 Jan 2008 18:16:01 +0000   
IP: 217.172.191.164
   Checked at      |      Timestamp     |      Status
================================================
Mon, 28 Jan 2008 19:31:26 +0000   |     Sat, 19 Jan 2008 18:16:01 +0000    

Please have a look
Comment 7 Raúl Porcel (RETIRED) gentoo-dev 2008-02-20 11:46:54 UTC
Seems to work now
Comment 8 Raúl Porcel (RETIRED) gentoo-dev 2008-02-20 11:48:06 UTC
err, reopening because the contact change still needs to be done...
Comment 9 Shyam Mani (RETIRED) gentoo-dev 2008-03-01 20:58:23 UTC
Raul, fail :p

It was already done. 
Comment 10 Raúl Porcel (RETIRED) gentoo-dev 2008-04-02 11:59:37 UTC
HOSTNAME: rsync4.de.gentoo.org
IP: 85.25.128.62
   Checked at      |      Timestamp     |      Status
================================================
Wed, 02 Apr 2008 11:56:29 +0000   |     Wed, 26 Mar 2008 12:15:01 +0000      |     [ OUT OF SYNC ]: 10001 minutes ( 166 hours )
IP: 217.172.191.164
   Checked at      |      Timestamp     |      Status
================================================
Wed, 02 Apr 2008 11:56:30 +0000   |     Wed, 26 Mar 2008 12:15:01 +0000      |     [ OUT OF SYNC ]: 10001 minutes ( 166 hours )
Comment 11 Stephan Schaefer 2008-04-09 13:27:26 UTC
Raul,

in the future we plan to do our initial sync from the following IP: 69.64.45.12, can you please allow this ip to sync from rsync://rsync1.us.gentoo.org. We will then sync internally to our german nas node.
Comment 12 Stephan Schaefer 2008-04-18 05:14:17 UTC
Raul,

iam still waiting for a response. Can you please contact me, thank you in advance.
Comment 13 Raúl Porcel (RETIRED) gentoo-dev 2008-04-18 09:19:10 UTC
(In reply to comment #12)
> Raul,
> 
> iam still waiting for a response. Can you please contact me, thank you in
> advance.
> 

I'm sorry but i can't do nothing about it. Only fox2mike and astinus can do something, i don't have access to anything related with mirrors.
Comment 14 Raúl Porcel (RETIRED) gentoo-dev 2008-05-08 15:22:05 UTC
*** Bug 220923 has been marked as a duplicate of this bug. ***
Comment 15 Shyam Mani (RETIRED) gentoo-dev 2008-06-10 04:09:20 UTC
Right now, I have 3 IPs on the ACL for rsync4.de :

85.25.128.62
217.172.171.254
69.64.45.12

Please let me know which one you plan to sync from and which one should be in DNS.

Thanks
Comment 16 Stephan Schaefer 2008-06-10 11:53:59 UTC
Hello,

rsync4.de.gentoo.org should only have one A Record: 85.25.128.62, also
we need a second nameserver record rsyncX.us.gentoo.org which should
point to 69.64.45.119, which is our mirror in st. louis, mo (usa).

We will initiate the sync from 69.64.45.12 (nat ip of our mirror storage backend) and then sync internally
to our german cluster through a private data link, so that's the ip we need access for on rsync1.us.gentoo.org.

Just to clear up the situation a little bit, I want to explain our setup.
We have two storage clusters for mirroring, one in germany and one in the united states.
Each cluster consist of one NAS Node and two WEB nodes, the WEB nodes
import the filesystem from the NAS node. Therefore the IP of the DNS Record(s) and
the IP we start the sync from are different.



DNS Records:
rsync4.de.gentoo.org  A 85.25.128.62
rsyncX.us.gentoo.org  A 69.64.45.119

Mirror Access:
rsync1.us.gentoo.org should be accesible from IP: 69.64.45.12
Comment 17 Shyam Mani (RETIRED) gentoo-dev 2008-06-11 10:26:21 UTC
Stephan,

Thanks for explaining the setup.

Right now, both 85.25.128.62 and 69.64.45.12 have access to rsync1.us. 

One problem on our side was a dual DNS entry for rsync4.de, which was an older IP that wasn't removed...so I've taken care of that now.

I'll check rsync4.de (85.25.128.62) tomorrow to make sure it's okay. 

Once all this is fine, you can open another bug if you want the US mirror made public and I'll add that in as well. Don't want to mix both.

Thanks!

Comment 18 Shyam Mani (RETIRED) gentoo-dev 2008-07-07 04:21:47 UTC
Looks good. Closing. Please open a new bug if you want a US mirror added as well.