Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 20326 - need to tell how to specify a dependancy that must have been built a certain way and how to build it
Summary: need to tell how to specify a dependancy that must have been built a certain ...
Status: RESOLVED DUPLICATE of bug 2272
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Documentation (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-02 08:43 UTC by Aaron Peterson
Modified: 2011-10-30 22:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Peterson 2003-05-02 08:43:23 UTC
I have at least one program that cares about what library a library was built
with that it needs...

specifically gnet needing to be linked against glib2 instead of glib1.2

emerging gnet will make it go with glib1.2 unless the ebuild is modified or a
specific environment variable is set.

So, how does one call another ebuild from an ebuild? If it is mearly typing it
on a line, I must ask is this safe?

or should I just merge the ebuilds together and recompile gnet (or any other
package that it matters what it was linked with) with my ebuild?

and if this is explained, maybe include some english with the explanation?
Comment 1 Aaron Peterson 2003-08-06 08:17:13 UTC
I ran into this problem with my Overnet Core Controller ebuild  (its floating arround on the forums somewhere..)

anyway...   yeah i think it was glib1.2 and glib2 that was causing the problems... I had to edit the ebuild and re emerge the other thing...


I suppose one could just "merge" the ebuilds together... compile the requirement, then compile the goodie...  then somehow emerge the requirement again with it's normal settings...


This should be specified... maybe like this

Depends{
>=foolib3.1
>=barlib2.3.1:glib[glib2]

to say that it has to be built with glib2 instead of 1.2 or something.. 

use a colon or some other symbol in the use flags...

then portage should know to re emerge the file after its done...

and the glib package would have to  accept being passed a build value...

I'm tired... and my system is... not as broken as it has been... (my girlfriend is going to be mad at me... again... for attempting to fix my gentoo box)
Comment 2 Brian Harring gentoo-dev 2004-08-10 23:43:12 UTC
Marking as a dupe of 2272, since that functionality is how this would be implemented.

*** This bug has been marked as a duplicate of 2272 ***