Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 203196 - sys-kernel/gentoo-sources usb bluetooth dongle spams dmesg to the point of making it useless for debugging other problems (Patch in hand)
Summary: sys-kernel/gentoo-sources usb bluetooth dongle spams dmesg to the point of ma...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
Keywords: InVCS
Depends on:
Reported: 2007-12-24 00:02 UTC by Ariel Poliak
Modified: 2008-12-01 20:10 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

solution patch - in diff -u format (linux-2.6.23-gentoo-r5_bluetooth_0e5e-6622_stop-dmesg-spam.patch,536 bytes, patch)
2007-12-24 00:03 UTC, Ariel Poliak
Details | Diff
lsusb -v information about the device causing the problem (KY-BT100.bluetooth,5.64 KB, text/plain)
2008-07-05 14:43 UTC, Markos Chandras (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Ariel Poliak 2007-12-24 00:02:19 UTC
I am using a generic bluetooth dongle, id 050e-6622. Whenever the dongle is plugged in, dmesg gets filled with messages about the device. I do not have the exact message, since I patched my system to prevent the error. I will post the patch next

Reproducible: Always

Steps to Reproduce:
1. plug in dongle or `hciconfig hci0 up`
2. get dmesg spammed
3. `hciconfig hci0 down` stops spam

Portage 2.1.4_rc11 (default-linux/x86/2007.0/desktop, gcc-4.2.2, glibc-2.7-r1, 2.6.23-gentoo-r5 i686)
System uname: 2.6.23-gentoo-r5 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Timestamp of tree: Sat, 22 Dec 2007 00:16:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.3
dev-lang/python:     2.5.1-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r2
CFLAGS="-O2 -march=pentium4 -pipe"
CONFIG_PROTECT="/etc /opt/openjms/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium4 -pipe"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="                                                                              "
LINGUAS="en_US es_AR en es"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="3ds 7zip S3TC X X509 Xaw3d a52 aac aalib acct ace acl acpi addbookmarks additions administrator adns afs agg aim akode alac alias alsa amarok amazon amd amr animgif ao aotuv aqua_theme ares arts artworkextra asm aspnet2 async audacious audiofile autoipd automount autoreplace avahi background bash-completion battery bcmath beagle berkdb bigpatch binary-drivers binfilter bitmap-fonts bittorrent bl blender-game bluetooth bonjour bookmarks branding bzip2 cairo cal3d calendar caps carbone_theme cardbus ccache cdaudio cdda cddb cdf cdinstall cdio cdparanoia cdr cdrom cdsound child-protection chipcard chm cisco clamav cli clock-screen cmdsubmenu cmucl colordiff compress config_wizard connectionstatus console contactnotes cpio cpudetection cpufreq cpulimit cracklib crciprec crypt cscope css ctype cups curl curlwrappers cursors cvs daap dar32 dar64 dbus dc1394 dedicated depth32 device-mapper dga dhcp dia dict disk-partition divx djbfft djvu dmi dnd dolby-record-switch dom4j domain-aware domainkeys doomsday dpmod dri dts dv dvbplayer dvd dvdnav dvdr dvdread dvi dynamicplugin eap-tls ecc editor eds emboss emerald emf emoticon emovix enca encode enscript eolconv epiphany erandom escreen esd etwin evo excel exif extensions extra-cardsets extraicons extramodules faillog fam fame fasttrack fat fax fbcon fbcondecor fbdev fbsplash festival ffmpeg finger firefox fits fix-connected-rt flac flash flatfile flexresp2 fltk fluidsynth fmod font-server fontconfig foomaticdb force-cgi-redirect fortran fping freetts ftp fuse fusion gadu galago gcj gd gdbm gdl gdm gedit general ggi gif gimp gimpprint glade glgd glib glibc-compat20 glitz glsa glut gmail gmedia gmttria gnet gnokii gnome gnome-print gnuplot gnutella gnutls gocr gphoto2 gpm gps grace grammar graphviz gre groupwise gs gsf gsm gssapi gstreamer gtk gtkhtml gtkspell gzip gzip-el h323 hacking hal hash hbci hddtemp hesiod hfs high-ints highlight history howl howl-compat html http httpd hub hyperestraier hyperwave-api ibam ical icecast icon icons iconv icp icq id3 id3tag idea idle idn ieee1394 ifp ilbc image imagemagick imap imlib immqt-bc imq inherit-graph inifile injection inkjar inline innodb insecure-savers interpreter ipod iptv ipv6 irc irda irman irmc isdnlog iso14755 italk jabber jack jack-tmpfs jad jai java java5 javacomm javamail javascript jbig jce jfs jikes jingle jms john joystick jpeg jpeg2k jpgraph jrtplib jsapi jumpplay junit jython kcal kde kdeenablefinal kdepim kdm kerberos key-screen keyring keyscrub kipi krb4 l7filter ladspa lame lapack largeterminal lash latex lcd lcms ldap ldap-sasl libburn libcaca libdsk libsamplerate libsexy libwww lights live lm_sensors log4j login-watch logitech-mouse logrotate lua lyrics lzo lzw mad mail maildir maps markdown math matroska maya-shaderlibrary mbox mbrola mcal md5sum mdb mdnsresponder-compat memlimit menubar mew mhash midi mikmod mime mimencode ming mixer mjpeg mmap mmkeys mmx mmxext mng mod_irc mod_muc mod_pubsub modplug mono motif mounts-check mozdevelop mozembed mp2 mp3 mp4 mp4live mpd mpeg mpeg2 mpi mplayer mschap msdav msn mtp mudflap multiuser musepack music musicbrainz mysqli na_dd na_icons nas nat nautilus ncurses neXt net netboot nethack netmeeting netpbm network new-login nextaw nfs nis nls nntp nocd noepg nowlistening nptl nptlonly nsplugin ntfs ntlm ntp numarray nut nuv nvram oav obex objc++ objc-gc ocrad offensive office ogg openal opendoc openexr openft opengl openmp openntpd openssl opensslcrypt openstreetmap oscar oss overlays padlock pam pam_chroot pam_timestamp paste64 pcap pcapnav pcmcia pcntl pcre pda pdf perfprofiling perl physfs player plugin plugins pmu png pnm polling pop portaudio posix postproc postscript povray ppds pppd prediction prelude preview-latex print ps pvr pysolcards python qdbm qmax qq qsa qt3 qt3support qt4 query-browser quicktime quotes radio radius rar rc5 rdesktop react readline real realmedia recode reflection regex reiser4 reiserfs remix replytolist resolvconf restrict-javascript rfkill rle roe rotor rplay rpm rss rtc rtsp samba sametime scanner schedule screen scripting sdk sdl sdl-image sdl-sound sdlaudio seamless-hbars sensord server session sftp sguil sharedext sharedmem shorten shout sid signatures silc silvercity skey skins slang slp smime smp sms sndfile snmp snortsam sockets socks5 softfax sound sounds sourcecaps sourceview speech speedo speex spell spl sql sqlite sqlite3 srt sse sse2 ssl startup-notification staticsocket statistics stats stlport stream stroke subject-rewrite submenu subtitles subversion suidcheck svg svga svgz swat symlink sysfs syslog szip tagwriting talkfilters tcl tcpd tcpmd5 tcpwrapper tcsim tesseract tetex text texteffect textures tftp tga tgif themes theora thesaurus threads thunderbird tidy tiff timestats timidity tivo tk tlen tntc tokenizer toolbar toolkit-scroll-bars tools tordns tos totem transcode translator transmitter trayicon truetype truetype-fonts tv_check twinserial twolame type1-fonts udpfromto unicode unzip upnp usb userfiles utempter uuencode v4l v4l2 vcd vcdx vdr vhosts videos vidix vim vim-pager vim-with-x visual visualization vlm vnc vncviewer voice vorbis vorbis-psy wav wavpack web webdav webinterface webpresence wifi win32codecs winbind winpopup wireshark wma wmf wmp wordperfect wxwindows x11vnc x264 x86 xanim xattr xcb xcf xchatdccserver xcomposite xext xface xforms xfs xft xgetdefault xhtml xine xinerama xml xmlreader xmlrpc xmlwriter xorg xosd xpm xrandr xscreensaver xsettings xskatcards xsl xterm xulrunner xv xvid xvmc xvnc yaepg yahoo yp yv12 zeroconf zip zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="synaptics mouse keyboard logitech evdev vmmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US es_AR en es" USERLAND="GNU" VIDEO_CARDS="radeon"
Comment 1 Ariel Poliak 2007-12-24 00:03:02 UTC
Created attachment 139223 [details, diff]
solution patch - in diff -u format
Comment 2 Mike Pagano gentoo-dev 2008-01-18 23:47:08 UTC
Are you the author of this patch? 
Comment 3 Ariel Poliak 2008-01-21 20:15:51 UTC
I found the information for the fix on a google search. This means other people are also affected. I can't find the original page with the fix info, but the exact same problem is described in Ubuntu's bugtracker (

I manually updated the source file on my system and when it worked, created the patch file.

I ran diff -u, so technically I am the author of THIS patch, however it is based on another patch, which I can no longer find.

If you are asking if I'm willing to keep the patch working as the kernel is updated and syntaxes change until it is incorporated in the official kernel, the answer is yes...
Comment 4 Mike Pagano gentoo-dev 2008-01-22 01:26:47 UTC
Here's the link to ubuntu's patch.

Could not find this on usb-devel list, git repo or lkml or mainline git repo. Not sure why Ubuntu has not submitted this.;a=commitdiff;h=771d0cc54dc1710c585d3ee29447ddfc92aec440
Comment 5 Mike Pagano gentoo-dev 2008-01-23 00:10:39 UTC
I emailed the canonical guy at Ubuntu who committed the patch and asked him if he plans on submitting this upstream. Here's his answer, which I think implies that they will not be submitting upstream.  

Here is the provenance for the fix (which Ossi Berg says he found in the 
vanilla kernel):

I have not bothered to check that the patch is already upstream somewhere.

Comment 6 Daniel Drake (RETIRED) gentoo-dev 2008-01-23 08:25:29 UTC
yes, we should submit this then (with correct author attribution). However, you can't just submit a patch like that, you need a proper description of the issue it solves. So we need Ariel to give us the exact error message first.
Comment 7 Daniel Drake (RETIRED) gentoo-dev 2008-01-23 08:38:29 UTC
or at least just to confirm from memory that it looked something like:

hci_scodata_packet: hci0 SCO packet for unknown connection handle 92
Comment 8 Ariel Poliak 2008-01-23 23:37:05 UTC
(In reply to comment #7)
> hci_scodata_packet: hci0 SCO packet for unknown connection handle 92
That is in fact the query I put into Google to get to the solution...
Comment 9 Ariel Poliak 2008-01-23 23:40:30 UTC
(In reply to comment #7)
> hci_scodata_packet: hci0 SCO packet for unknown connection handle 92
That is in fact the query I put into Google to get to the solution...

I no longer have the original error message, as it was logrotated until it got flagged for deletion, and I patched my kernel, so the problem no longer occurs (at least until the next time I emerge gentoo-sources), but I am 100% sure that was the error message that flooded dmesg.
Comment 10 Daniel Drake (RETIRED) gentoo-dev 2008-01-25 13:59:08 UTC
submitted upstream
Comment 11 Daniel Drake (RETIRED) gentoo-dev 2008-02-08 12:45:25 UTC
no response after 2 weeks: sent again
Comment 12 Daniel Drake (RETIRED) gentoo-dev 2008-02-13 16:47:23 UTC
patch added to -mm
Comment 13 Daniel Drake (RETIRED) gentoo-dev 2008-03-05 09:17:25 UTC
Please attach the "lsusb -v" output for this device
Comment 14 Daniel Drake (RETIRED) gentoo-dev 2008-03-05 20:02:56 UTC
Also please post the output of "hciconfig hci0 version" from when this device is up and running
Comment 15 Daniel Drake (RETIRED) gentoo-dev 2008-03-07 14:33:32 UTC
Don't worry about the above info now. someone else provided it and a final patch is going upstream
Comment 16 Ariel Poliak 2008-03-09 05:47:23 UTC
Sorry for dropping off the face of the earth. I just went through three weeks of midterm exams, several homework programming projects, and a catastrophic system failure on one of my other systems. I have not booted Gentoo since I started studying for those midterms (if I did, I would have spent all the time emerging stuff and messing with it, and would not have studied at all -- same reason why I left Portal at home before Finals Week last semester...)

Anyway, I'm in Spring Break now, and being I'm under 21 (1 month and change left), there's not a whole lot to do, so I'll do the digging around for that information, even if it is not completely necessary, but at least for archival and completeness-of-information purposes.

I'll post that information sometime this week.

Once Again, sorry for the delay in replying.
Comment 17 Daniel Drake (RETIRED) gentoo-dev 2008-03-30 09:19:11 UTC
Fixed in gentoo-sources-2.6.24-r4 (genpatches-2.6.24-5)
Comment 18 Markos Chandras (RETIRED) gentoo-dev 2008-07-05 14:28:46 UTC
Now it hasnt been fixed. I still have the same problem. I ll try to apply the patch
Comment 19 Markos Chandras (RETIRED) gentoo-dev 2008-07-05 14:31:24 UTC
*** Bug 230854 has been marked as a duplicate of this bug. ***
Comment 20 Markos Chandras (RETIRED) gentoo-dev 2008-07-05 14:37:36 UTC
Nope patch doesnt work

I am using 2.6.25-gentoo-r6 kernel
Comment 21 Markos Chandras (RETIRED) gentoo-dev 2008-07-05 14:43:43 UTC
Created attachment 159630 [details]
lsusb -v information about the device causing the problem
Comment 22 Luca Santarelli 2008-11-30 11:04:32 UTC
(In reply to comment #18)
> Now it hasnt been fixed. I still have the same problem. I ll try to apply the
> patch

I second Markos' comment. It (still) doesn't work on 2.6.26-gentoo-r3.

Shouldn't this mean a "REOPEN BUG"?

As a side note, after I start the service, /etc/init.d/bluetooth reports "crashed" as status and I can't find any device to pair, but adding the term "bluetooth" to a forum search is the same as adding "*" :-(

On a dual booting Windows XP the dongle works fine, pairs with devices and transfers files.

Where should I search for informations? I'm using bluez* as per x86 tree (so 2.x)
Comment 23 Markos Chandras (RETIRED) gentoo-dev 2008-11-30 11:49:57 UTC
From what I understand this is not a Gentoo specific bug but an upstream one. Im not sure about that thought. Look at /var/log/messages for the error output
Comment 24 Luca Santarelli 2008-11-30 16:58:16 UTC
(In reply to comment #23)
> From what I understand this is not a Gentoo specific bug but an upstream one.
> Im not sure about that thought. Look at /var/log/messages for the error output

I've dug a bit and yes, it's an upstream bug.
I've fixed it for our dongle (we have the same one), it's a single line of code in drivers/bluetooth/hci_usb.c which needs to be modified.
As soon as I understand how to make a proper email to upstream, I'll send it asking for inclusion.

Regarding the BlueZ issue, going ~x86 fixed the crash, now bluetooth is working.
Comment 25 Markos Chandras (RETIRED) gentoo-dev 2008-11-30 22:43:36 UTC
Could you please post here the changes you made on that file? Thanks :)
Comment 26 Daniel Drake (RETIRED) gentoo-dev 2008-12-01 00:21:11 UTC
This bug has to be "fixed" seperately for each broken device that is in existence. We fixed it for Ariel's device but there are probably other (broken devices) like yours in the wild. Please open new bug reports.

Also, just because it is an upstream bug doesn't mean you should avoid posting it here. We need to fix our kernel as well as upstream.
Comment 27 Luca Santarelli 2008-12-01 20:10:58 UTC
(In reply to comment #26)
> Also, just because it is an upstream bug doesn't mean you should avoid posting
> it here. We need to fix our kernel as well as upstream.

Daniel, thanks for your kind answer. I have opened a new bug, attaching the patch I made (Markos, you can grab the patch and apply it).

It's here:

If you're kind enough to point me to the right way to submit a patch upstream, I'll gladly do it myself (first kernel patch in my life, I'm kind of moved). I heard about people who sign your patch, but I don't know much more...