Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 203141 - net-www/libflashsupport: pulseaudio issue
Summary: net-www/libflashsupport: pulseaudio issue
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Jim Ramsay (lack) (RETIRED)
Depends on:
Reported: 2007-12-23 14:02 UTC by Rafał Mużyło
Modified: 2008-04-26 23:36 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

trivial patch fixing the problem (pulse.patch,422 bytes, patch)
2007-12-23 14:03 UTC, Rafał Mużyło
Details | Diff
libflashsupport-1.2.ebuild.patch (libflashsupport-1.2.ebuild.patch,584 bytes, patch)
2008-04-26 11:16 UTC, Henning Schild
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rafał Mużyło 2007-12-23 14:02:18 UTC
Hi, it's me again.
Bug #180575 should be address again.
As this ebuild has had been in the tree for far more than 30 days, I'm reopening this bug and reporting a minor issue that should be addressed before stabilizing.
For pulseaudio this library looks for /var/lib/run/pulse/native socket for system-wide, however correct socket is /var/run/pulse/native.
And I think a correct way of stabilizing this would be making it a PDEPEND of netscape-flash.
Comment 1 Rafał Mużyło 2007-12-23 14:03:22 UTC
Created attachment 139178 [details, diff]
trivial patch fixing the problem
Comment 2 Rafał Mużyło 2007-12-23 14:07:21 UTC
One more thing: current ebuild gives
QA Notice: The following shared libraries lack a SONAME
for this lib.
Comment 3 Petteri Räty (RETIRED) gentoo-dev 2008-01-03 00:43:56 UTC
I just installed latest ~arch libflashsupport and pulseaudio and flash works just fine to pulseaudio. I suggest testing those.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2008-02-09 18:03:54 UTC
(In reply to comment #3)
> I just installed latest ~arch libflashsupport and pulseaudio and flash works
> just fine to pulseaudio. I suggest testing those.

Same here. 

Comment 5 Rafał Mużyło 2008-04-23 15:57:58 UTC
I thought that this bug was fixed ages ago, but it's still not the case.
But today I came across
While I can't be sure this was the cause, it still looks like nobody looked at my patch.
Again, for pulseaudio to work correctly with flash, when run system-wide (via init.d script), lookup path HAS TO BE MODIFIED (as stated in comment #1).
Comment 6 Rafał Mużyło 2008-04-23 16:01:34 UTC
I meant of course initial report, not comment #1.
Must remember to post after cooling down.
Comment 7 Henning Schild 2008-04-26 10:44:55 UTC
Why was that bug never fixed? I just figured out the same fix after installing pulseaudio and libflashsupport on my machine. But why did i have to when the problem and the fix are known for so long.
The only thing that might be missing is a patch to the README of libflashsupport.

Maintainer what kept you from fixing this obvious bug? I am really upset right now.

I tried the latest pulseaudio (media-sound/pulseaudio-0.9.10-r1) and it did not solve the problem. And even if it would solve the problem it would require the user to ~keyword more than is needed to get flash+pulse running. Not to mention the fact that new pulseaudio may depend on bluetooth stuff that also needs to be ~keyworded or would require custom useflags for pulseaudio to prevent the dependency.
Comment 8 Henning Schild 2008-04-26 11:16:11 UTC
Created attachment 151009 [details, diff]
Comment 9 Jim Ramsay (lack) (RETIRED) gentoo-dev 2008-04-26 23:06:35 UTC

Do you happen to know when the patch changed from /var/lib/run/pulse to /var/run/pulse?

I don't want to make this change across the board if there are still systems that use the older path.
Comment 10 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-04-26 23:14:47 UTC
The current one can be depended upon for all users to be there.

But do me a favour and don't use that sed, use sed -i -e 's:/var/lib/run/pulse:/var/run/pulse:' instead.. the backslash quoting makes my eyes bleed!
Comment 11 Jim Ramsay (lack) (RETIRED) gentoo-dev 2008-04-26 23:36:14 UTC
(In reply to comment #10)
> The current one can be depended upon for all users to be there.

Thanks very much.  I have applied the patch, but made it look nicer.

> the backslash quoting makes my eyes bleed!

Is that bleed, or flame?