Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 202845 - media-sound/baudline (new ebuild)
Summary: media-sound/baudline (new ebuild)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Michael Weber (RETIRED)
URL: http://www.baudline.com
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2007-12-20 04:53 UTC by Ilya Kashirin
Modified: 2010-10-05 02:58 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
baudline-1.0.7.ebuild (baudline-1.0.7.ebuild,1.72 KB, text/plain)
2007-12-20 04:53 UTC, Ilya Kashirin
Details
baudline-1.0.7.ebuild (baudline-1.0.7.ebuild,2.02 KB, text/plain)
2007-12-20 16:57 UTC, Ilya Kashirin
Details
files/baudline.png (baudline.png,313 bytes, text/plain)
2007-12-20 20:43 UTC, Ilya Kashirin
Details
baudline-1.0.7.ebuild (baudline-1.0.7.ebuild,2.39 KB, text/plain)
2007-12-20 20:44 UTC, Ilya Kashirin
Details
baudline-1.0.7.ebuild (baudline-1.0.7.ebuild,2.74 KB, text/plain)
2008-01-03 09:27 UTC, Pham Ngoc Hai
Details
media-sound/baudline/baudline-1.0.7.ebuild (baudline-1.0.7.ebuild,2.56 KB, text/plain)
2008-01-04 17:07 UTC, Pham Ngoc Hai
Details
baudline-1.0.7.ebuild (baudline-1.0.7.ebuild,2.90 KB, text/plain)
2008-01-07 19:11 UTC, Ilya Kashirin
Details
baudline-1.0.7.ebuild (baudline-1.0.7.ebuild,2.79 KB, text/plain)
2008-09-07 04:25 UTC, Denis Pesotsky
Details
baudline-1.0.7.ebuild (baudline-1.0.7.ebuild,2.79 KB, text/plain)
2008-09-07 04:31 UTC, Denis Pesotsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ilya Kashirin 2007-12-20 04:53:05 UTC
Baudline is a time-frequency browser designed for scientific visualization of the spectral domain.  Signal analysis is performed by Fourier, correlation, and raster transforms that create colorful spectrograms with vibrant detail.  Conduct test and measurement experiments with the built in function generator, or play back audio files with a multitude of effects and filters.  The baudline signal analyzer combines fast digital signal processing, versatile high speed displays, and continuous capture tools for hunting down and studying elusive signal characteristics.

Reproducible: Always

Steps to Reproduce:
Comment 1 Ilya Kashirin 2007-12-20 04:53:40 UTC
Created attachment 138951 [details]
baudline-1.0.7.ebuild
Comment 2 Ilya Kashirin 2007-12-20 16:56:59 UTC
Comment on attachment 138951 [details]
baudline-1.0.7.ebuild

license restriction
Comment 3 Ilya Kashirin 2007-12-20 16:57:20 UTC
Created attachment 138981 [details]
baudline-1.0.7.ebuild
Comment 4 Ilya Kashirin 2007-12-20 20:43:04 UTC
Created attachment 138996 [details]
files/baudline.png
Comment 5 Ilya Kashirin 2007-12-20 20:44:03 UTC
Created attachment 138998 [details]
baudline-1.0.7.ebuild
Comment 6 Pham Ngoc Hai 2008-01-03 09:27:43 UTC
Created attachment 139940 [details]
baudline-1.0.7.ebuild

This a modified verion of Ilya Kashirin's version with proper source files for different archs
Comment 7 Pham Ngoc Hai 2008-01-04 17:07:44 UTC
Created attachment 140084 [details]
media-sound/baudline/baudline-1.0.7.ebuild

A little fix for the previous ebuild due to repeated code
Comment 8 Ilya Kashirin 2008-01-07 19:11:03 UTC
Created attachment 140400 [details]
baudline-1.0.7.ebuild

some fixes from Pham Ngoc Hai`s version
1. Fixe KEYWORDS
2. Add creating baudline.desktop with associate some audio formats
Comment 9 Denis Pesotsky 2008-05-01 22:21:31 UTC
Please, add it into portage tree. Ebuild works perfect for me.
Comment 10 Denis Pesotsky 2008-09-07 04:25:46 UTC
Created attachment 164770 [details]
baudline-1.0.7.ebuild

Fixed few things in ebuild:
1) Reworked SRC_URI
2) Removed ~sparc. It doesnt support Linux on sparc (only Solaris)

1 question: what to do with optional dependencies? For example, it can read MP3 files only if mpg123 or mpg321 are installed.
Comment 11 Denis Pesotsky 2008-09-07 04:31:49 UTC
Created attachment 164772 [details]
baudline-1.0.7.ebuild

Oh, small fix to make it work. Sorry.
Comment 12 Ilya Kashirin 2008-09-07 10:35:04 UTC
> 1 question: what to do with optional dependencies? For example, it can read MP3
> files only if mpg123 or mpg321 are installed.

I guess, add mp3 use-flag. 

Comment 13 Denis Pesotsky 2008-09-07 15:36:41 UTC
But it doesnt need mpg321 to compile. You can install mpg123 when baudline is already installed and it works fine
Comment 14 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-14 18:19:59 UTC
(this is an automated message based on filtering criteria that matched this bug)
'EBUILD' is in the KEYWORDS which should mean that there is a ebuild attached 
to this bug.
This bug is assigned to maintainer-wanted which means that it is not in the 
main tree.
Heuristics show that no Gentoo developer has commented on your ebuild.

Hello, The Gentoo Team would like to firstly thank you for your ebuild 
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The 
sunrise overlay[1] is a overlay for Gentoo which we allow trusted users to 
commit to and all users can have ebuilds reviewed by Gentoo devs for entry 
into the overlay. So, the sunrise team is suggesting that you look into this 
and submit your ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us. 
We anticipate a large number of requests in a short time. 

Thanks,
On behalf of the Gentoo Sunrise Team,
Jeremy.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq
Comment 15 Michael Weber (RETIRED) gentoo-dev 2010-10-05 02:58:30 UTC
+*baudline-1.08 (05 Oct 2010)
+
+  05 Oct 2010; Michael Weber <xmw@gentoo.org> +baudline-1.08.ebuild,
+  +metadata.xml:
+  Initial import, fixing bug 202845. Thanks to Ilya Kashirin
+  <seclorum@seclorum.ru>, Pham Ngoc Hai <pngochai@yahoo.com> and Denis
+  Pesotsky <obey@obey.su> for their ebuilds and testing on this bug.
+