Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 202550 - gnome-base/nautilus-2.20.0-r1: Ctrl+K is an undocumented keyboard shortcut
Summary: gnome-base/nautilus-2.20.0-r1: Ctrl+K is an undocumented keyboard shortcut
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-17 06:32 UTC by morgan wahl
Modified: 2008-01-04 03:56 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description morgan wahl 2007-12-17 06:32:55 UTC
The menus in nautilus give Ctrl+T as the shortcut for "Move to Trash" (and it works fine), but Ctrl+K seems to do the same thing. 

This may not seem like much of a bug, but it did cause me problems once: I had an app open which uses Ctrl+K, and I mixed up which window had focus and sent Ctrl+K to nautilus. It was my fault for mixing up what had keyboard focus, but the problem was that I couldn't figure out what had happened to my selected files; Ctrl+K isn't mentioned in any of the nautilus menus. 

I'm not sure if this is Minor or Trivial.

Reproducible: Always

Steps to Reproduce:
1. select a file in nautilus
2. type "Ctrl+K"
3.

Actual Results:  
the file is moved to the trash

Expected Results:  
nothing
Comment 1 Rémi Cardona gentoo-dev 2007-12-17 06:39:26 UTC
Ctrl+K does nothing on my system... Do you have any extensions for nautilus? Please provide emerge --info.

Thanks
Comment 2 morgan wahl 2007-12-20 16:55:17 UTC
(In reply to comment #1)
> Ctrl+K does nothing on my system... Do you have any extensions for nautilus?
> Please provide emerge --info.
> 
> Thanks
> 

I don't have any extensions.

here's emerge --info:
Portage 2.1.3.19 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r3 i686)
=================================================================
System uname: 2.6.23-gentoo-r3 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
Timestamp of tree: Thu, 20 Dec 2007 12:30:03 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon64 -pipe -O2"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -pipe -O2"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://www.gtlib.gatech.edu/pub/gentoo http://gentoo.mirrors.tds.net/gentoo http://distro.ibiblio.org/pub/linux/distributions/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LINGUAS="en en_US es es_AR hi hi_IN ja ja_JP sk sk_SK de de_DE ase ase@Sgnw yo yo_NG ru ru_RU la"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/musicbrainz /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib acl acpi aiglx aim alsa amr amrnb amrwb apache2 applet asf avahi bash-completion berkdb bidi bitmap-fonts bittorrent bonjour bookmarks boost bootsplash bzip2 cairo cdda cddb cdparanoia cdr cdrom chm cjk cli cracklib crypt css cups daap dbus device-mapper dmi doc dpms dri dts dv dvd dvdnav dvdr dvdread eds emboss enblend enca encode esd evo exif fam fat fbsplash ffmpeg firefox flac fortran ftp fuse galago gdbm geoip gif gimp gimpprint gnome gnutls gpm graphviz gsf gstreamer gtk guile h264 hal hddtemp hfs ical iconv id3 idn ieee1394 imagemagick ipod ipv6 isdnlog jabber jack java jbig jpeg jpeg2k kde kerberos ladspa lcms ldap libnotify libsamplerate lm_sensors lzo mad matroska midi mikmod mime mjpeg mmx mmxext mng mozbranding mozdevelop mozilla mozsvg mp3 mp4 mpeg mpeg2 mplayer mudflap musicbrainz mysql nautilus ncurses newspr nfs nls nptl nptlonly nsplugin ntfs nvidia objc ofx ogg openal openexr opengl openmp oscar pam pcre pdf perl png pnm ppds pppd prediction pulseaudio python qt qt3 qt3support qt4 quicktime rar readline real reflection reiserfs rtc ruby samba sane sasl scanner scheme sdl session sift smp sms sndfile sox speex spell spl srt sse sse2 ssl svg svga tcpd theora threads tiff tracker trayicon truetype truetype-fonts type1-fonts unicode upnp usb userlocales v4l v4l2 vcd vorbis win32codecs wmf x264 x86 xattr xcomposite xfs xine xinerama xml xorg xosd xpm xprint xscreensaver xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US es es_AR hi hi_IN ja ja_JP sk sk_SK de de_DE ase ase@Sgnw yo yo_NG ru ru_RU la" USERLAND="GNU" VIDEO_CARDS="radeon vesa vga fbdev v4l"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

nautilus is 2.20.0
Comment 3 Rémi Cardona gentoo-dev 2007-12-21 07:34:03 UTC
Then I have no clue where this is coming from ...
Comment 4 Daniel Gryniewicz (RETIRED) gentoo-dev 2007-12-22 16:56:25 UTC
ctrl-k does nothing here, either.  Have you changed your locale or keyboard settings, maybe?
Comment 5 Cosimo Cecchi 2007-12-27 12:02:42 UTC
It does nothing here, as well.
Comment 6 Saleem Abdulrasool (RETIRED) gentoo-dev 2008-01-04 03:56:16 UTC
No response and we are unable to reproduce.  Marking as NEEDINFO.