Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 202517 - dev-util/processing (new package) Processing Development Environment
Summary: dev-util/processing (new package) Processing Development Environment
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 1 vote (vote)
Assignee: Default Assignee for New Packages
Whiteboard: sunrise-suggested
Keywords: EBUILD
: 405815 (view as bug list)
Depends on: 143019 170305
  Show dependency tree
Reported: 2007-12-16 20:32 UTC by Santiago M. Mola (RETIRED)
Modified: 2019-05-14 19:14 UTC (History)
13 users (show)

See Also:
Package list:
Runtime testing required: ---

simple ebuild for 0135 (processing-0135.ebuild,545 bytes, text/plain)
2008-06-03 18:16 UTC, Jan Hendrik Grahl (RETIRED)
processing-1.0.1.ebuild (processing-1.0.1.ebuild,1.17 KB, text/plain)
2008-12-19 12:14 UTC, MATSUU Takuto (RETIRED)
processing-1.0.1.ebuild (processing-1.0.1.ebuild,1.47 KB, text/plain)
2009-01-06 17:10 UTC, MATSUU Takuto (RETIRED)
processing-1.0.1.ebuild (processing-1.0.1.ebuild,1.68 KB, text/plain)
2009-01-11 23:20 UTC, MATSUU Takuto (RETIRED)
processing-1.1.ebuild (processing-1.1.ebuild,1.95 KB, text/plain)
2010-03-19 16:47 UTC, MATSUU Takuto (RETIRED)
ebuild w/ USE="doc examples" (processing-1.1.ebuild,2.39 KB, text/plain)
2010-04-19 01:38 UTC, Michael Weber (RETIRED)
processing ide ebuild (processing-ide-1.5.1.ebuild,1.36 KB, text/plain)
2012-02-27 01:19 UTC, renato gallo
processing 1.5.1 ebuild (processing-ide-1.5.1.ebuild,1.36 KB, text/plain)
2012-02-27 01:22 UTC, renato gallo
processing 1.5.1 desktop file (processing.desktop,227 bytes, text/plain)
2012-02-27 01:23 UTC, renato gallo
processing 1.5.1 wrapper patch (wrapper-1.5.1.patch,1.69 KB, patch)
2012-02-27 01:24 UTC, renato gallo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Santiago M. Mola (RETIRED) gentoo-dev 2007-12-16 20:32:50 UTC
From their webpage:
"Processing is an open source programming language and environment for people who want to program images, animation, and interactions. It is used by students, artists, designers, researchers, and hobbyists for learning, prototyping, and production. It is created to teach fundamentals of computer programming within a visual context and to serve as a software sketchbook and professional production tool. Processing is developed by artists and designers as an alternative to proprietary software tools in the same domain."

You can see some cool examples at or
Comment 1 Jan Hendrik Grahl (RETIRED) gentoo-dev 2008-06-03 18:15:17 UTC
I created a simple ebuild for Processing based on the mozilla-firefox-bin ebuild. Worked fine for me for 0135. The processing executable in 0138 (beta) had to be called from the /opt/processing directory in my case. An improvement could be to separate the Java installation from the package and use the system JRE. Also, including a link in /usr/bin to /opt/processing/processing might be helpful.
Comment 2 Jan Hendrik Grahl (RETIRED) gentoo-dev 2008-06-03 18:16:26 UTC
Created attachment 155399 [details]
simple ebuild for 0135
Comment 3 Alistair Bush (RETIRED) gentoo-dev 2008-06-04 00:33:03 UTC
(In reply to comment #2)
> Created an attachment (id=155399) [edit]
> simple ebuild for 0135

This is taken from a trunk checkout but should be rather representative

alistair@LINUX ~/gentoo/processing $ find . -iname '*.jar'

Plus the fact that it is a java app will mean that the java eclasses will need to be used :) ( java-pkg-2 at least )

Plus im wondering whether they have "borrowed" eclipse code....
Comment 4 MATSUU Takuto (RETIRED) gentoo-dev 2008-12-19 12:14:09 UTC
Created attachment 175860 [details]
Comment 5 MATSUU Takuto (RETIRED) gentoo-dev 2008-12-19 12:19:08 UTC
my processing-1.0.1.ebuild has not solved Comment #3 issue.
Comment 6 MATSUU Takuto (RETIRED) gentoo-dev 2009-01-06 17:10:39 UTC
Created attachment 177576 [details]
Comment 7 MATSUU Takuto (RETIRED) gentoo-dev 2009-01-11 23:20:53 UTC
Created attachment 178140 [details]
Comment 8 Steve Brudenell 2009-03-07 20:03:25 UTC
Ping? Has anyone been looking at this? Processing has been out (in beta, at least) for several years and is rapidly gaining popularity. I really don't want my Gentoo use to exclude my processing use...
Comment 9 Kevin Bowling 2010-03-03 05:01:13 UTC
Any news?
Comment 10 Steve Yohanan 2010-03-17 04:16:35 UTC
also interested in seeing an ebuild for this.
Comment 11 MATSUU Takuto (RETIRED) gentoo-dev 2010-03-19 16:47:27 UTC
Created attachment 224255 [details]
Comment 12 Michael Weber (RETIRED) gentoo-dev 2010-04-19 01:38:49 UTC
Created attachment 228349 [details]
ebuild w/ USE="doc examples"

Hi, I've done some minor improvements on this and try to get it into sunrise.

- browser-command is xdg-open instead of firefox
- search for updates is disabled (install useless on a non-root account)
- doc and examples depends on IUSE flag.
- amd64 really needs 32bit java from emul-linux-x86-java to load .so (Examples -> Libraries -> OpenGL). The solution is a manipulated ${PATH}
- Added launcher menu entry.

Maybe this whole package can be build on top of 

Thanks to matsuu for the previous ebuild!
Comment 13 Michael Weber (RETIRED) gentoo-dev 2010-04-20 05:36:30 UTC
Processing does run with 64bit java, iff you extract the .so from the amd64.jar files. I've been working on a source based ebuild from the releases subversion tag/revision. There is no proper replacement for qtjava, which is in kde-sunset overlay w/ obsoleted kde-meta eclass. gluegen is mentioned in bug 170305 and joglin bug 143019.

See for details.
Comment 14 Michael Weber (RETIRED) gentoo-dev 2010-07-31 21:16:29 UTC
I'm just bumping it to 1.2.1 ...
Comment 15 Dmitry Dzhus 2010-09-23 18:37:53 UTC
Works with 1.2.1.

Download location changed:

Comment 16 Jesse Adelman 2011-07-15 04:00:43 UTC
1.5.1 released in May, FYI. :)
Comment 17 Jeroen Roovers (RETIRED) gentoo-dev 2012-02-27 01:01:21 UTC
*** Bug 405815 has been marked as a duplicate of this bug. ***
Comment 18 renato gallo 2012-02-27 01:19:37 UTC
Created attachment 303433 [details]
processing ide ebuild
Comment 19 renato gallo 2012-02-27 01:21:17 UTC
Comment on attachment 303433 [details]
processing ide ebuild

processing 1.5.1
Comment 20 renato gallo 2012-02-27 01:22:11 UTC
Created attachment 303435 [details]
processing 1.5.1 ebuild
Comment 21 renato gallo 2012-02-27 01:23:22 UTC
Created attachment 303437 [details]
processing 1.5.1 desktop file
Comment 22 renato gallo 2012-02-27 01:24:19 UTC
Created attachment 303439 [details, diff]
processing 1.5.1 wrapper patch
Comment 23 renato gallo 2012-02-27 01:30:44 UTC
for disambuiguation with dev-python/processing-0.52.ebuild i'd call this dev-embedded/processing-ide
Comment 24 Jesse Adelman 2012-11-16 01:19:39 UTC
Any hope of this getting into Sunrise, at least? :)
Comment 25 Michael Palimaka (kensington) gentoo-dev 2012-11-16 12:31:15 UTC
(In reply to comment #24)
> Any hope of this getting into Sunrise, at least? :)

Sunrise is a user-maintained overlay, so stop by #gentoo-sunrise if you would like to try your hand.
Comment 26 Xavier Miller (RETIRED) gentoo-dev 2013-06-07 08:16:07 UTC
Processing 2.0 is released.