Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 201102 - net-firewall/ipp2p: Unaligned access in search_all_ed2k
Summary: net-firewall/ipp2p: Unaligned access in search_all_ed2k
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: Sparc64 Linux
: High normal (vote)
Assignee: Sparc Porters
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: unaligned-access
  Show dependency tree
 
Reported: 2007-12-03 14:00 UTC by Jaime Fordham
Modified: 2011-08-12 18:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaime Fordham 2007-12-03 14:00:02 UTC
I've just built a sparc64 (Ultra/5) based firewall with ipp2p compiled
as a module (latest version from ebuild) and I'm constantly getting the following message in my logs:

Kernel unaligned access at TPC[100f8490] search_all_edk+0x20/0x4c
[ipt_ipp2p]


Reproducible: Always




Portage 2.1.3.19 (default-linux/sparc/sparc64/2007.0/server, gcc-4.1.2, glibc-2.6.1-r0, 2.6.22-gentoo-r9-blackmesa sparc64)
=================================================================
System uname: 2.6.22-gentoo-r9-blackmesa sparc64 sun4u
Timestamp of tree: Sun, 02 Dec 2007 21:00:01 +0000
app-shells/bash:     3.2_p17
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.61-r1
sys-devel/automake:  1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="sparc"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=ultrasparc -pipe"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -mcpu=ultrasparc -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="apache2 bash-completion bitmap-fonts bzip2 cli cracklib cups dri examples fortran gd gdbm gpm iconv iproute2 isdnlog ldap mailwrapper md5sum midi mudflap mysql ncurses nptl nptlonly openmp pam pcre ppds pppd radius reflection samba session snmp sparc spl ssl truetype truetype-fonts type1-fonts unicode xml xorg zip zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="dummy fbdev glint mach64 mga r128 radeon sunbw2 suncg14 suncg3 suncg6 sunffb sunleo tdfx v4l voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2007-12-03 23:13:37 UTC
The bugzilla product is ONLY for problems with the bugs.g.o site itself, not any others!
Comment 2 Łukasz Damentko (RETIRED) gentoo-dev 2008-10-30 17:01:39 UTC
Reassigning to another maintainer since eradicator has left Gentoo.
Comment 3 Alin Năstac (RETIRED) gentoo-dev 2008-12-13 12:45:37 UTC
Reassigned to sparc, since I don't know anything about this architecture. AFAIK, the code runs on 64-bit processors (I've test it on amd64).
Comment 4 Sergei Trofimovich gentoo-dev 2011-08-12 18:39:05 UTC
Gone from the tree with bug #309655.

Closing as WONTFIX.