Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 200767 - [PATCH] media-video/mjpegtools-1.8.0-r1 fails to compile with uclibc++ / GCC 4.3
Summary: [PATCH] media-video/mjpegtools-1.8.0-r1 fails to compile with uclibc++ / GCC 4.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL: http://sourceforge.net/tracker/index....
Whiteboard:
Keywords:
: 215156 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2007-11-29 20:04 UTC by Natanael Copa
Modified: 2008-04-20 08:02 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
mjpegtools-1.8.0-limits.h.patch (mjpegtools-1.8.0-limits.h.patch,1.10 KB, patch)
2007-11-29 20:05 UTC, Natanael Copa
Details | Diff
mjpegtools-1.9.0_rc3-gcc-4.3.patch (mjpegtools-1.9.0_rc3-gcc-4.3.patch,5.52 KB, patch)
2008-03-09 04:20 UTC, Ryan Hill (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Natanael Copa 2007-11-29 20:04:52 UTC
g++-uc -DHAVE_CONFIG_H -I. -I.. -I.. -I../utils -Os -pipe -mno-sse2 -fno-strict-aliasing -pthread -MT motionest.lo -MD -MP -MF .deps/motionest.Tpo -c motionest.cc  -fPIC -DPIC -o .libs/motionest.o
macroblock.cc: In member function `void MacroBlock::SelectCodingModeOnVariance()':
macroblock.cc:52: error: `INT_MAX' was not declared in this scope
Comment 1 Natanael Copa 2007-11-29 20:05:47 UTC
Created attachment 137345 [details, diff]
mjpegtools-1.8.0-limits.h.patch

fixes the issue
Comment 2 Ryan Hill (RETIRED) gentoo-dev 2008-03-09 04:20:43 UTC
Created attachment 145622 [details, diff]
mjpegtools-1.9.0_rc3-gcc-4.3.patch

We need this for GCC 4.3 too.  This is the same patch against 1.9.0_rc3 plus a couple additional missing headers and fix for this error:

SkipList.hh:60: error: declaration of 'typedef class Allocator<SkipList<KEY, VALUE, KEYFN, PRED>::Node, SkipList<KEY, VALUE, KEYFN, PRED>::HEADERCHUNK> SkipList<KEY, VALUE, KEYFN, PRED>::Allocator'
Allocator.hh:18: error: changes meaning of 'Allocator' from 'class Allocator<SkipList<KEY, VALUE, KEYFN, PRED>::Node, SkipList<KEY, VALUE, KEYFN, PRED>::HEADERCHUNK>'
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2008-03-28 10:25:48 UTC
*** Bug 215156 has been marked as a duplicate of this bug. ***
Comment 4 SpanKY gentoo-dev 2008-04-20 08:02:06 UTC
added patch to 1.9.0_rc3