Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 200735 - GST_REGISTRY points to no file. media-video/totem-2.20.1 can't configure
Summary: GST_REGISTRY points to no file. media-video/totem-2.20.1 can't configure
Status: RESOLVED DUPLICATE of bug 143810
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: GStreamer package maintainers
URL:
Whiteboard:
Keywords:
: 215316 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-11-29 11:06 UTC by Electrion Mycene
Modified: 2009-09-07 22:06 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log for media-video/totem-2.20.1 (config.log,46.67 KB, text/plain)
2007-11-29 13:27 UTC, Electrion Mycene
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Electrion Mycene 2007-11-29 11:06:23 UTC
media-video/totem-2.20.1 can't configure successfully. It fails to find gstreamer plugins.

But if I untar the sources, apply the patches and run './configure' even in an sandbox shell, it works properly.

I've found that in the gnome2.eclass, the environment value "GST_REGISTRY" added to work around gst-inspect in gnome2_src_configure points to no file.

I suggest the following modification:

# GST_REGISTRY is to work around gst-inspect trying to read/write /root
GST_REGISTRY="${S}/registry.xml" econf "$@" ${G2CONF} || die "configure failed"

replace by: 

# GST_REGISTRY is to work around gst-inspect trying to read/write /root
cp "/root/.gstreamer-0.10/registry.i686.xml" "${S}/registry.xml"
GST_REGISTRY="${S}/registry.xml" econf "$@" ${G2CONF} || die "configure failed"


I'm convinced it is not a great patch (don't test if the registry exists, can't adapt to gstreamer version, ...), but now the emerge works.

Reproducible: Always

Steps to Reproduce:
1. emerge totem
2.
3.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-11-29 11:10:13 UTC
> cp "/root/.gstreamer-0.10/registry.i686.xml"

Uh... this definitely is a no-go.
Comment 2 Electrion Mycene 2007-11-29 11:19:25 UTC
(In reply to comment #1)
> > cp "/root/.gstreamer-0.10/registry.i686.xml"
> 
> Uh... this definitely is a no-go.
> 

I agree.

But I still don't know how to generate properly the requested "${S}/registry.xml".
Comment 3 Gilles Dartiguelongue gentoo-dev 2007-11-29 12:01:47 UTC
could you list your installed gst-* plugins, post your emerge --info and attach the config.log  ?
Comment 4 Electrion Mycene 2007-11-29 13:27:34 UTC
Created attachment 137314 [details]
config.log for media-video/totem-2.20.1
Comment 5 Electrion Mycene 2007-11-29 13:29:13 UTC
emerge --info:
Portage 2.1.3.19 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.22-gentoo-r9 i686)
=================================================================
System uname: 2.6.22-gentoo-r9 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Timestamp of tree: Thu, 29 Nov 2007 07:46:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium4 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LINGUAS="fr"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/portage/local/layman/science /usr/portage/local/layman/xeffects"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl acpi ads alsa anthy apache2 bash-completion berkdb bitmap-fonts branding bzip2 cairo cdr cjk cli cracklib crypt cups dbus dri dvd dvdread emboss encode evo fam fftw firefox flac fortran gdbm gif gnome gpm gstreamer gtk hal iconv imagemagick isdnlog java jpeg libnotify logrotate mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png postgres ppds pppd python quicktime readline reflection session spell spl sse sse2 ssl svg tcpd tetex tiff truetype truetype-fonts type1-fonts unicode usb vorbis win32codecs winbind x86 xml xorg xprint xv xvid xvmc zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Installed gst-plugins:
media-libs/gst-plugins-base
media-libs/gst-plugins-good
media-libs/gst-plugins-ugly
media-plugins/gst-plugins-a52dec
media-plugins/gst-plugins-alsa
media-plugins/gst-plugins-cdparanoia
media-plugins/gst-plugins-dvdread
media-plugins/gst-plugins-ffmpeg
media-plugins/gst-plugins-flac
media-plugins/gst-plugins-gconf
media-plugins/gst-plugins-gnomevfs
media-plugins/gst-plugins-lame
media-plugins/gst-plugins-libmms
media-plugins/gst-plugins-libvisual
media-plugins/gst-plugins-mad
media-plugins/gst-plugins-meta
media-plugins/gst-plugins-mpeg2dec
media-plugins/gst-plugins-ogg
media-plugins/gst-plugins-pango
media-plugins/gst-plugins-theora
media-plugins/gst-plugins-vorbis
media-plugins/gst-plugins-x
media-plugins/gst-plugins-xvideo

And the config.log in attachment
Comment 6 Electrion Mycene 2007-11-29 13:32:14 UTC
Sorry : FEATURES for emerge --info is:

FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
Comment 7 Gilles Dartiguelongue gentoo-dev 2008-04-10 21:39:31 UTC
*** Bug 215316 has been marked as a duplicate of this bug. ***
Comment 8 Alexis Ballier gentoo-dev 2008-06-26 14:25:58 UTC
similar problem here:
gst-inspect-0.10 works fine if I already have the registry.

If I remove it I get this:
$ gst-inspect-0.10
(gst-inspect-0.10:26366): Gtk-WARNING **: cannot open display: 
Error initializing: Error re-scanning registry , child terminated by signal

So that might be due to sandboxing and/or X not running. Here it is through a ssh session without X forwarding that I trigger this. If I add X forwarding, gst-inspect-0.10 works as expected.


This causes me totem configure failures as the user compiling it cannot access to X. I haven't been able to trace it to what tries to open an X session though.
Comment 9 Nguyen Thai Ngoc Duy 2008-09-30 18:58:07 UTC
You may want to look at bug 216009
Comment 10 Gilles Dartiguelongue gentoo-dev 2009-08-03 20:45:06 UTC
even though I can reproduce this problem by running commands by hand, preparing /root or /var/tmp/portage to trigger this bug yields no result. Closing worksforme. If you can still reproduce this bug, please attach config.log (again), emerge --info (especially FEATURES) and ls -l /var/tmp/portage or /root according to your FEATURES.
Comment 11 Gilles Dartiguelongue gentoo-dev 2009-08-03 21:02:12 UTC

*** This bug has been marked as a duplicate of bug 143810 ***