Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 200076 - media-sound/pulseaudio keywording request for ~x86-fbsd
Summary: media-sound/pulseaudio keywording request for ~x86-fbsd
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo/BSD Team
URL:
Whiteboard:
Keywords: KEYWORDREQ
: 229489 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-11-23 13:10 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2013-08-26 21:41 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2007-11-23 13:10:57 UTC
The new PulseAudio adds a couple more dependencies compared to 0.9.7:

 - gnome-extra/gnome-audio is now a dep. It is used for the hotplugging sound, there is nothing to build, and no gnome dependencies, it's just a package of wav files.
 - net-wireless/bluez-libs 3 or later is used for bluetooth support, this shouldn't be a problem for anybody but x86 team, whose KEYWORD was not dropped, but default-linux/x86/no-nptl/2.4 should mask the bluetooth USE flag for PulseAudio, and BSD that should probably do the same.
 - sys-auth/policykit, imported in the tree today, is also an optional dependency, it hasn't been mass keyworded yet, so there are a lot of arches needing it.

Please keyword and/or mask USE flags. Thanks.

Diego
Comment 1 Dawid Węgliński (RETIRED) gentoo-dev 2007-11-24 10:32:03 UTC
As i see x86 has nothing to do here at the moment:
./default-linux/x86/no-nptl/2.4/package.use.mask:>=media-sound/pulseaudio-0.9.8 bluetooth
policykit-0.6.ebuild:KEYWORDS="~amd64 ~x86"

CC us back if you have something to do ;)
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2007-11-24 10:45:10 UTC
Yes the profile USE masking was what you needed.
Comment 3 Jeroen Roovers gentoo-dev 2007-12-22 17:38:42 UTC
Marked ~hppa.
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2007-12-29 17:39:13 UTC
New revisions, new USE flag, asyncns for net-libs/libasyncns. Please test and either keyword or mask the asyncns USE flag.

HPPA please also keyword baselayout-1 compatible ebuild.
Comment 5 Jeroen Roovers gentoo-dev 2007-12-29 17:44:27 UTC
(In reply to comment #4)
> HPPA please also keyword baselayout-1 compatible ebuild.

What does that mean?
Comment 6 Diego Elio Pettenò (RETIRED) gentoo-dev 2007-12-29 17:53:08 UTC
There are two -r ebuilds for every change, the even-numbered one (for now, it's not a rule to be even-numbered) is for baselayout 1 and 2, the odd-numbered one only works for baselayout 2 and is thus package.masked. HPPA only keyworded one of the odd numbered ones for 0.9.8 series (and is thus masked).
Comment 7 Jeroen Roovers gentoo-dev 2007-12-29 18:05:07 UTC
That wasn't obvious at all from either Summary or Description. :)
Comment 8 Raúl Porcel (RETIRED) gentoo-dev 2007-12-31 11:00:26 UTC
~alpha/~ia64/~sparc/~x86 done
Comment 9 Markus Rothe (RETIRED) gentoo-dev 2008-01-06 12:20:00 UTC
added ~ppc64
Comment 10 Jeroen Roovers gentoo-dev 2008-01-08 22:17:36 UTC
Marked ~hppa.
Comment 11 Carsten Lohrke (RETIRED) gentoo-dev 2008-06-26 12:25:09 UTC
*** Bug 229489 has been marked as a duplicate of this bug. ***
Comment 12 Alistair Bush (RETIRED) gentoo-dev 2009-01-20 04:51:35 UTC
Any chance of getting ppc to keyword pulseaudio please.
Comment 13 Joe Jezak (RETIRED) gentoo-dev 2009-02-23 15:28:54 UTC
I've keyworded the latest (0.9.14) and 0.9.10-r1 ~ppc. If you'd like me to look into an other version, please re-add us to the bug. Thanks!
Comment 14 Raúl Porcel (RETIRED) gentoo-dev 2009-02-23 15:31:52 UTC
arm/sh is also done...
Comment 15 Samuli Suominen gentoo-dev 2009-05-12 07:28:42 UTC
bsd?
Comment 16 Arun Raghavan (RETIRED) gentoo-dev 2011-05-18 04:19:43 UTC
(In reply to comment #15)
> bsd?

ping?
Comment 17 Alexis Ballier gentoo-dev 2013-08-26 21:41:09 UTC
not worth it for bsd unless someone is willing to do the work