Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 200059 - sys-apps/hal-0.5.10 - {policy,console}kit/acl support should not be mandatory
Summary: sys-apps/hal-0.5.10 - {policy,console}kit/acl support should not be mandatory
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Project Gentopia
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-23 09:22 UTC by Jakub Moc (RETIRED)
Modified: 2007-11-23 14:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
hal-0.5.10.ebuild.diff (hal-0.5.10.ebuild.diff,1.38 KB, patch)
2007-11-23 09:23 UTC, Jakub Moc (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jakub Moc (RETIRED) gentoo-dev 2007-11-23 09:22:24 UTC
Because it's clearly optional, configurable and because to some people the choice still matters.

Patch attached.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2007-11-23 09:23:22 UTC
Created attachment 136744 [details, diff]
hal-0.5.10.ebuild.diff

If you want to make it enabled by default in profiles or via EAPI-1 and use defaults, that's perfectly fine. Removing the choice is not.
Comment 2 Andrey Melentyev 2007-11-23 10:21:25 UTC
consolekit is also a dependency for xinit:

# equery d consolekit
[ Searching for packages depending on consolekit... ]
sys-apps/hal-0.5.10 (>=sys-auth/consolekit-0.2)
x11-apps/xinit-1.0.5-r1 (hal? sys-auth/consolekit)
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-11-23 10:24:28 UTC
(In reply to comment #2)
> consolekit is also a dependency for xinit:

Only w/ USE=hal, plus off-topic here.
Comment 4 Doug Goldstein gentoo-dev 2007-11-23 14:25:58 UTC
It's not optional. The ./configure script has polkit as optional as legacy. We're not supporting both configurations since upstream has made it clear it will be manditory. Additionally, next versions of GNOME will make polkit mandatory.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2007-11-23 14:39:12 UTC
- PolicyKit        >= 0.5       (optional)
- ConsoleKit       >= 0.2.0     (optional, needed if use PolicyKit)

Well thanks, I'll maintain this in my overlay myself, it works just fine w/o this  needless cruft forced on people that have no need for it.