Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 199937 - dev-lang/perl-5.8.8-r4 won't build
Summary: dev-lang/perl-5.8.8-r4 won't build
Status: RESOLVED DUPLICATE of bug 115815
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-22 00:16 UTC by Dominic Wong
Modified: 2007-11-22 12:52 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build error and 'emerge --info' output (perl-build.error,4.90 KB, text/plain)
2007-11-22 00:16 UTC, Dominic Wong
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dominic Wong 2007-11-22 00:16:04 UTC
Tried to update my system using emerge -uavD world --newuse. 


Reproducible: Always

Steps to Reproduce:
1. Ran emerge -uavD world --newuse, which reports that it needs to upgrade perl-5.8.8-r3 to perl-5.8.8-r4.

Actual Results:  
Build fails, see description.

Expected Results:  
It should have installed perl-5.8.8-r4.
Comment 1 Dominic Wong 2007-11-22 00:16:35 UTC
Created attachment 136647 [details]
Build error and 'emerge --info' output
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2007-11-22 08:20:04 UTC
<snip>
sv.c: In function 'Perl_sv_2iv':
sv.c:2141: error: 'undef' undeclared (first use in this function)
sv.c:2141: error: (Each undeclared identifier is reported only once
sv.c:2141: error: for each function it appears in.)
sv.c: In function 'Perl_sv_2uv':
sv.c:2435: error: 'undef' undeclared (first use in this function)
sv.c: In function 'Perl_sv_2nv':
sv.c:2762: error: 'undef' undeclared (first use in this function)
sv.c: In function 'Perl_sv_clear':
sv.c:5222: warning: ignoring return value of 'Perl_io_close', declared with attribute warn_unused_result
make: *** [sv.o] Error 1
</snip>

Post cat /proc/cpuinfo output, please...
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2007-11-22 08:44:15 UTC
Have you tried disabling distcc?
FEATURES="-distcc" emerge -1 perl
Comment 4 Dominic Wong 2007-11-22 12:35:55 UTC
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping        : 9
cpu MHz         : 3000.000
cache size      : 512 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid xtpr
bogomips        : 6015.56
clflush size    : 64

Comment 5 Dominic Wong 2007-11-22 12:36:20 UTC
Tried disabling distcc as suggested, no use.
Comment 6 Dominic Wong 2007-11-22 12:36:48 UTC
("no use" = same build error result)
Comment 7 Dominic Wong 2007-11-22 12:41:20 UTC
Never mind. Wrong arch (prescott). Sorry for wasting your time. :(
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2007-11-22 12:51:48 UTC
Yeah, no pni in flags -> not prescott.
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2007-11-22 12:52:04 UTC

*** This bug has been marked as a duplicate of bug 115815 ***